0xc0000142 Beim Starten von App-V Anwendungen vom Netzwerk oder auch nicht.

Hallo zusammen,

den oben genannten Fahler findet man im Zusammenhang mit verschiedeen Ursachen. Ichwerde hier mal drei beleuchten.

Also es handelt sich um diesen Fehler:

 

clip_image001

 

Ursache 1:

NTFSDisable8.3 Names passen nicht vom Sequencer zum Client. Bereits beschrieben hier:

http://support.microsoft.com/kb/2777003

 

Ursache 2:

Man nutzt CM 2012 SP1 und hat das Sequencer OS über die Setup.exe verteilt (das ist mit WinPE 4 nicht mehr unterstützt - http://technet.microsoft.com/en-us/library/hh824993.aspx)

Wenn man dann später auf das WIM Image (Client) Wechselt kann man die Anwendungen nicht mehr starten.

Abhilfe schafft hier ein Dummy Update auf einem Sequencer der übder ds WIM Image betankt wurde.

 

Ursache 3:

Die Executable die gestartet werden soll liegt auf einem Netzlaufwerk – entweder als Mapped Drive oder als UNC Pfad.

In den Foren liest man das man einfach den Client Computer Account auf den Share Lese Berechtigung geben muss. Das ist nur teilweise richtig.

Folgendes ist zu beachten:

1. Ausführen über ein Mapped Drive funktioniert gar nicht (Shortcut sieht so aus: U:\Share1\Share2\Meins.exe /appvve:12345…

2. Ausführen über den UNC Pfad geht wenn alle vorraussetzungen erfüllt sind (Shortcut sieht so aus: \\Server\Share1\share2\Meins.exe /appvve:12345…

Die Vorraussetzungen sind:

1. Wie Beschrieben der Shortcut muss ein UNC Pfad enthalten

2. Der Computer Account des Clients muss lese berechtigung auf den Haupt Share haben – also in dem Beispiel nicht Share2 – wie man es erwarten würde sondern Share1.

Damit startet dann auch diese Anwendung.

 

Generell besagt dieser Fehler nichts anderes, als dass ein Virtuelles Subsystem hier nicht gestartet werden kann. Welches das ist in den Ursachen auch unterschiedlich.

Schönen Gruß

 

Sebastian Gernert – Escalation Engineer App-V