Prerequisites for installing Event Hubs on Azure Stack Hub

The following prerequisites must be completed before you can install Event Hubs on Azure Stack Hub. Several days or weeks of lead time may be required to complete all steps.

Important

These prerequisites assume that you've already deployed at least a 4-node Azure Stack Hub integrated system. The Event Hubs resource provider is not supported on the Azure Stack Development Kit (ASDK).

Important

Azure Stack Hub 2002 build version or higher is required by Event Hubs. Please note that Azure Stack Hub builds are incremental. For example, if you have version 1910 installed, you must first upgrade to 2002, then to 2005. That is, you cannot skip builds in-between.

Common prerequisites

If you've already installed a resource provider, you've likely completed the following prerequisites, and can skip this section. Otherwise, complete these steps before continuing:

  1. Register your Azure Stack Hub instance with Azure, if you haven't done so. This step is required as you'll be connecting to and downloading items to marketplace from Azure.

  2. If you're not familiar with the Marketplace Management feature of the Azure Stack Hub administrator portal, review Download marketplace items from Azure and publish to Azure Stack Hub. The article walks you through the process of downloading items from Azure to the Azure Stack Hub marketplace. It covers both connected and disconnected scenarios. If your Azure Stack Hub instance is disconnected or partially connected, there are additional prerequisites to complete in preparation for installation.

  3. Update your Azure Active Directory (Azure AD) home directory. Starting with build 1910, a new application must be registered in your home directory tenant. This app will enable Azure Stack Hub to successfully create and register newer resource providers (like Event Hubs, IoT Hub, and others) with your Azure AD tenant. This is an one-time action that needs to be done after upgrading to build 1910 or newer. If this step isn't completed, marketplace resource provider installations will fail.

Event Hubs prerequisites

  1. Procure public key infrastructure (PKI) SSL certificates for Event Hubs. The Subject Alternative Name (SAN) must adhere to the following naming pattern: CN=*.eventhub.<region>.<fqdn>. Subject Name may be specified, but it's not used by Event Hubs when handling certificates. Only the Subject Alternative Name is used. See PKI certificate requirements for the full list of detailed requirements.

    example certificate

    Note

    PFX files must be password protected. The password will be requested later during installation.

  2. Be sure to review Validate your certificate. The article shows you how to prepare and validate the certificates you use for the Event Hubs resource provider.

Next steps

Next, install the Event Hubs resource provider.