Explore and create tables with the Data tab

You can use the Data tab in the Data Science & Engineering workspace to create, view, and delete tables.

Databricks recommends using features in Databricks SQL to complete these tasks; the Data explorer provides an improved experience for viewing data objects and managing ACLs and the create table UI allows users to easily ingest small files into Delta Lake.

Requirements

To view and create databases and tables, you must be connected to a running cluster.

View databases and tables

Click Data Icon Data in the sidebar. Azure Databricks selects a running cluster to which you have access. The Databases folder displays the list of databases with the default database selected. The Tables folder displays the list of tables in the default database.

Create tables list

You can change the cluster from the Databases menu, create table UI, or view table UI. For example, from the Databases menu:

  1. Click the Down Caret at the top of the Databases folder.

  2. Select a cluster.

    Select cluster

Import data

If you have small data files on your local machine that you want to analyze with Azure Databricks, you can import them to DBFS using the UI.

Note

This feature may be disabled by admin users. To enable or disable this setting, see Manage data upload.

Files imported to DBFS using these methods are stored in FileStore.

Create a table

The Create Icon Create in the sidebar and the Create Table button in the Data tab both launch the Create Table UI. You can populate a table from files in DBFS or data stored in any of the supported data sources.

Note

When you create a table using the UI, you cannot update the table.

Create a table using the UI

With the UI, you can only create external tables.

  1. Click Data Icon Data in the sidebar. The Databases and Tables folders appear.

  2. In the Databases folder, select a database.

  3. Above the Tables folder, click Create Table.

  4. Choose a data source and follow the steps in the corresponding section to configure the table.

    If an Azure Databricks administrator has disabled the Upload File option, you do not have the option to upload files; you can create tables using one of the other data sources.

    Configure table

    Instructions for Upload data option

    1. Drag files to the Files dropzone or click the dropzone to browse and choose files. After upload, a path displays for each file. The path will be something like /FileStore/tables/<filename>-<integer>.<file-type>. You can use this path in a notebook to read data.

      File dropzone

    2. Click Create Table with UI.

    3. In the Cluster drop-down, choose a cluster.

    Instructions for DBFS option

    1. Select a file.
    2. Click Create Table with UI.
    3. In the Cluster drop-down, choose a cluster.
  5. Click Preview Table to view the table.

  6. In the Table Name field, optionally override the default table name. A table name can contain only lowercase alphanumeric characters and underscores and must start with a lowercase letter or underscore.

  7. In the Create in Database field, optionally override the selected default database.

  8. In the File Type field, optionally override the inferred file type.

  9. If the file type is CSV:

    1. In the Column Delimiter field, select whether to override the inferred delimiter.
    2. Indicate whether to use the first row as the column titles.
    3. Indicate whether to infer the schema.
  10. If the file type is JSON, indicate whether the file is multi-line.

  11. Click Create Table.

Create a table in a notebook

In the Create New Table UI you can use quickstart notebooks provided by Azure Databricks to connect to any data source.

  • DBFS: Click Create Table in Notebook.
  • Other Data Sources: In the Connector drop-down, select a data source type. Then click Create Table in Notebook.

View table details

The table details view shows the table schema and sample data.

  1. Click Data Icon Data in the sidebar.

  2. In the Databases folder, click a database.

  3. In the Tables folder, click the table name.

  4. In the Cluster drop-down, optionally select another cluster to render the table preview.

    Table details

    Note

    To display the table preview, a Spark SQL query runs on the cluster selected in the Cluster drop-down. If the cluster already has a workload running on it, the table preview may take longer to load.

Delete a table using the UI

  1. Click Data Icon Data in the sidebar.
  2. Click the Menu Dropdown next to the table name and select Delete.

. Add Table Icon