Scenario: Apache Hive Zeppelin Interpreter gives a Zookeeper error in Azure HDInsight

This article describes troubleshooting steps and possible resolutions for issues when using Interactive Query components in Azure HDInsight clusters.

Issue

On an Apache Hive LLAP cluster, the Zeppelin interpreter gives the following error message when attempting to execute a query:

java.sql.SQLException: org.apache.hive.jdbc.ZooKeeperHiveClientException: Unable to read HiveServer2 configs from ZooKeeper

Cause

The Zeppelin Hive JDBC Interpreter is pointing to the wrong URL.

Resolution

  1. Navigate to the Hive component summary and copy the "Hive JDBC Url" to the clipboard.

  2. Navigate to https://clustername.azurehdinsight.net/zeppelin/#/interpreter

  3. Edit the JDBC settings: update the hive.url value to the Hive JDBC URL copied in step 1

  4. Save, then retry the query

Next steps

If you didn't see your problem or are unable to solve your issue, visit one of the following channels for more support:

  • Get answers from Azure experts through Azure Community Support.

  • Connect with @AzureSupport - the official Microsoft Azure account for improving customer experience. Connecting the Azure community to the right resources: answers, support, and experts.

  • If you need more help, you can submit a support request from the Azure portal. Select Support from the menu bar or open the Help + support hub. For more detailed information, review How to create an Azure support request. Access to Subscription Management and billing support is included with your Microsoft Azure subscription, and Technical Support is provided through one of the Azure Support Plans.