SoapException.IsVersionMismatchFaultCode(XmlQualifiedName) SoapException.IsVersionMismatchFaultCode(XmlQualifiedName) SoapException.IsVersionMismatchFaultCode(XmlQualifiedName) SoapException.IsVersionMismatchFaultCode(XmlQualifiedName) Method

Definition

Returns a value that indicates whether the SOAP fault code is equivalent to the VersionMismatch SOAP fault code regardless of the version of the SOAP protocol used.

public:
 static bool IsVersionMismatchFaultCode(System::Xml::XmlQualifiedName ^ code);
public static bool IsVersionMismatchFaultCode (System.Xml.XmlQualifiedName code);
static member IsVersionMismatchFaultCode : System.Xml.XmlQualifiedName -> bool
Public Shared Function IsVersionMismatchFaultCode (code As XmlQualifiedName) As Boolean

Parameters

Returns

true if code is equivalent to the VersionMismatch SOAP fault code; otherwise, false.

Remarks

Recipients of a SoapException can use this method to determine whether the Code property is functionally equivalent to the VersionMismatch SOAP fault code defined in SOAP 1.1 regardless of the version of the SOAP protocol used. Versions of the SOAP protocol later than 1.1 might use different names or namespaces for the VersionMismatch SOAP fault code defined in SOAP version 1.1, which is represented by the SoapException.VersionMismatchFaultCode field. SOAP 1.2 names the fault code the same; however, it is scoped by a different XML namespace and is represented by the Soap12FaultCodes.VersionMismatchFaultCode field.

Applies to

See also