MyCat

Note

This documentation is for EF Core. For EF6.x, see Entity Framework 6.

This database provider allows Entity Framework Core to be used with MyCat. The provider is maintained as part of the Pomelo Foundation Project.

Note

This provider is not maintained as part of the Entity Framework Core project. When considering a third party provider, be sure to evaluate quality, licensing, support, etc. to ensure they meet your requirements.

Install

Download and run the latest release from the project site.

Get Started

The following resources will help you get started with this provider.

Supported Database Engines

  • MyCat

Supported Platforms

  • .NET Framework (4.5.1 onwards)
  • .NET Core
  • Mono (4.2.0 onwards)