Troubleshooting issues on Microsoft Defender for Endpoint on Android

Applies to:

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When onboarding a device, you might see sign in issues after the app is installed.

During onboarding, you might encounter sign in issues after the app is installed on your device.

This article provides solutions to help address the sign-on issues.

Sign in failed - unexpected error

Sign in failed: Unexpected error, try later

An sign-in failed error Unexpected error in the sign-in page of the Microsoft Defender 365 portal.

Message:

Unexpected error, try later

Cause:

You have an older version of "Microsoft Authenticator" app installed on your device.

Solution:

Install latest version and of Microsoft Authenticator from Google Play Store and try again.

Sign in failed - invalid license

Sign in failed: Invalid license, please contact administrator

The directive contact details in the sign-in page of the Microsoft Defender 365 portal

Message: Invalid license, please contact administrator

Cause:

You do not have Microsoft 365 license assigned, or your organization does not have a license for Microsoft 365 Enterprise subscription.

Solution:

Contact your administrator for help.

Report unsafe site

Phishing websites impersonate trustworthy websites for the purpose of obtaining your personal or financial information. Visit the Provide feedback about network protection page if you want to report a website that could be a phishing site.

Phishing pages aren't blocked on some OEM devices

Applies to: Specific OEMs only

  • Xiaomi

Phishing and harmful web threats that are detected by Defender for Endpoint for Android are not blocked on some Xiaomi devices. The following functionality doesn't work on these devices.

A site-unsafe notification message

Cause:

Xiaomi devices include a new permission model. This prevents Defender for Endpoint for Android from displaying pop-up windows while it runs in the background.

Xiaomi devices permission: "Display pop-up windows while running in the background."

The pop-up setting pane in the Microsoft Defender 365 portal

Solution:

Enable the required permission on Xiaomi devices.

  • Display pop-up windows while running in the background.

Unable to allow permission for 'Permanent protection' during onboarding on some OEM devices

Applies to: Specific OEM devices only.

  • Xiaomi with Android 11

Defender App asks for Battery Optimization/Permanent Protection permission on devices as part of app onboarding, and selecting Allow returns an error that the permission couldn't be set. It only affects the last permission called "Permanent Protection."

Cause:

Xiaomi changed the battery optimization permissions in Android 11. Defender for Endpoint is not allowed to configure this setting to ignore battery optimizations.

Solution:

We are working with OEM to find a solution to enable this permission from the app onboarding screen. We will update the documentation when this is resolved. Users can follow these steps to enable the same permissions from the device settings:

  1. Go to Settings on your device.

  2. Search for and select Battery Optimization.

    The page on which you can search and select Battery Optimisation

  3. In Special app access, select Battery Optimization.

    The Special app access pane from which you can select Battery Optimisation

  4. Change the Dropdown to show All Apps.

    The drop-down from which you can change the value to All Apps under the Battery Optimisation pane

    The drop-down that displays the All Apps option under the Battery Optimisation pane

  5. Locate "Microsoft Defender for Endpoint" and select Don't Optimize.

    The page that enables location of the option Microsoft Defender for Endpoint and selection of Don't Optimize

Return to the Microsoft Defender for Endpoint onboarding screen, select Allow, and you will be redirected to the dashboard screen.

Send in-app feedback

If a user faces an issue which is not already addressed in the above sections or is unable to resolve using the listed steps, the user can provide in-app feedback along with diagnostic data. Our team can then investigate the logs to provide the right solution. Users can follow these steps to do the same:

  1. Open the MDE application on your device and click on the profile icon in the top-left corner.

    The profile icon in the Microsoft Defender for Endpoint portal

  2. Select "Help & feedback".

    The Help & feedback option that can be selected in the Microsoft Defender for Endpoint portal

  3. Select "Send feedback to Microsoft".

    Select send feedback to Microsoft

  4. Choose from the given options. To report an issue, select "I want to report an issue".

    The I want to report an issue option

  5. Provide details of the issue that you are facing and check "Send diagnostic data". We recommend checking "Include your email address" so that the team can reach back to you with a solution or a follow-up.

    The pane on which you can add details and attach diagnostic data

  6. Click on "Submit" to successfully send the feedback.