Troubleshoot license issues for Microsoft Defender for Endpoint on macOS

Applies to:

Want to experience Microsoft Defender for Endpoint? Sign up for a free trial.

While you are going through Microsoft Defender for Endpoint on macOS and Manual deployment testing or a Proof Of Concept (PoC), you might get the following error:

License error

Message:

No license found

Looks like your organization does not have a license for Microsoft 365 Enterprise subscription.

Contact your administrator for help.

Cause:

You deployed and/or installed the Microsoft Defender for Endpoint on macOS package ("Download installation package"), but you might not have run the configuration script ("Download onboarding package"), or you have not assigned a license to the user.

You can also encounter this error when the Microsoft Defender for Endpoint on macOS agent isn't up to date.

Solution:

Follow the MicrosoftDefenderATPOnboardingMacOs.py instructions documented here: Client configuration

For scenarios where Microsoft Defender for Endpoint on macOS isn't up to date, you'll need to update the agent.