NuGet Warning NU1605

Detected package downgrade: 'PackageB' from 4.0.0 to 3.5.0. Reference the package directly from the project to select a different version.
'PackageA' 3.5.0 -> 'PackageB' 3.5.0
'PackageC' 4.0.0 -> 'PackageD' 4.0.0 -> 'PackageB' 4.0.0

Issue

A dependency package specified a version constraint on a higher version of a package than restore ultimately resolved. That is, because of the "nearest wins" rule when resolving packages, a nearer package in the graph may have overridden a distant package.

Solution

Add a direct reference to the project for the higher version of the package that you want to use.

Then, update the installed package and clear the global packages folder.