Access may stop responding when you try to create an MDE, ACCDE, or ADE file

Note

Office 365 ProPlus is being renamed to Microsoft 365 Apps for enterprise. For more information about this change, read this blog post.

Moderate: Requires basic macro, coding, and interoperability skills.

This article applies to a Microsoft Access database (.mdb or .accdb) and a Microsoft Access project (.adp).

Original KB number:   814858

Symptoms

When you try to save an Access database file (.mdb or .accdb) as an MDE file (.mde) or ACCDE file (.accde), or when you try to save an Access project file (.adp) as an ADE (.ade) file, Access may stop responding. You may receive the following error message:

Microsoft Access has encountered a problem and needs to close. We are sorry for the inconvenience.
Please tell Microsoft about this problem.
We have created an error report that you can send to help us improve Microsoft Access. We will treat this report as confidential and anonymous.
To see what data this error report contains, click here.

Cause

This problem may occur when the compiled Visual Basic for Applications (VBA) project of the .mdb file or the .adp file is corrupted.

Workaround

To work around this problem, you can reload the VBA project of the Access database from text and then create the MDE, ACCDE, or ADE file. To do this, follow these steps:

Note

Make a backup copy of the database before you start these steps.

  1. On the taskbar, click start and then click Run.

  2. Type <Microsoft_Access_Path>\msaccess.exe /decompile and then click OK.

    Note

    <Microsoft_Access_Path> is the path of the folder where Access is installed.

  3. Open the original .mdb file, the original.accdb file, or the original .adp file that you want to save as the new MDE file, ACCDE file, or ADE file. To do this, follow these steps:

    1. Press ALT+F11 to open the Visual Basic Editor.
    2. On the Debug menu, click Compile <DatabaseName>.
    3. On the File menu click Save <DatabaseName>, and then close the Visual Basic Editor.
  4. In recent versions of Access, click File > Save As > Save Database As and then click Make ACCDE File or click Make ADE.

    In Access 2010 and Access 2007, click the Database Tools tab, and then click Make ACCDE File or click Make ADE in the Database Tools group.

    In Microsoft Office Access 2003 or in earlier versions of Access, click Database Utilities on the Tools menu, and then click Make MDE File or click Make ADE File.

  5. In the Save MDE As dialog box, in the Save As dialog box, or in the Save ADE As dialog box, locate the folder where you want to save the MDE, the ACCDE file, or the ADE file, type the file name in the File name box, and then click Save.