"You first must install one of the following versions of .NET Framework" when you run the IdFix tool

Note

Office 365 ProPlus is being renamed to Microsoft 365 Apps for enterprise. For more information about this change, read this blog post.

Problem

When you try to run the IdFix DirSync Error Remediation Tool in your on-premises Active Directory Domain Services (AD DS) environment, you receive the following error message:

To run this application, you first must install one of the following versions of .NET Framework. 

This issue occurs if the Microsoft .NET Framework 4 isn't installed on the computer. The IdFix tool requires the .NET Framework 4 to run.

Solution

To resolve this issue, install the .NET Framework 4 on the computer on which the IdFix tool is installed. The .NET Framework 4 is available from Microsoft .NET Framework 4 (Web Installer).

More information

For more information about the IdFix tool, see IdFix DirSync Error Remediation Tool.

Still need help? Go to Microsoft Community or the Azure Active Directory Forums website.