How to: Integrate Classic Client Report Designer and Visual Studio Report Designer

To create and modify client report definition (RDLC) report layouts, you must use Visual Studio. When you create an RDLC layout for a report, you may need to perform some steps in the Classic client Object Designer and some steps in Visual Studio Report Designer. To work with both Object Designer and Visual Studio Report Designer, you need to know when and where to save your work and how to switch between them efficiently.

You can save the RDLC report layout of the report in Visual Studio multiple times while you make changes. However, after you save those changes in the Classic client, if you make additional changes in Visual Studio, then those changes are not saved in the Classic client. After you save the report in the Classic client, we recommend that you close the report in Visual Studio so that you do not make additional changes that will not be saved. If you want to change the layout after saving the report in the Classic client, then you must click the View menu in the Classic client and then click Layout to reopen the RDLC layout in Visual Studio.

To work with both Object Designer and Visual Studio Report Designer

  1. In the Classic client, on the Tools menu, click Object Designer.

  2. To modify a Classic client report layout, in Object Designer, click Report, select the report that you want to modify, and then click Design.

  3. To create a new RDLC report layout for a report, in Object Designer, click Report, select the report, and then click Design. On the Tools menu, click Create Layout Suggestion.

  4. To modify an existing RDLC report layout, in Object Designer, click Report, select the report that you want to modify, and then click Design. On the View menu, click Layout.

  5. After you make changes in the RDLC layout, on the File menu, click Save Report.rdlc.

  6. In the Classic client, select an empty line in the report in Object Designer. A dialog box appears the following message:

    The layout of report id: '<report ID>' is changed by another application.

    Filename of the changed RDLC: <filename>

    Do you want to load the changes?

  7. In the dialog box, click Yes to load the changes that you made to the RDLC layout into the Classic client.

  8. In the Classic client, on the File menu, click Save.

  9. In the Save dialog box, select Compiled, and then click OK.

    Note

    If you close the report in Object Designer in the Classic client, make changes in Visual Studio Report Designer, and try to save the RDLC layout, then you will get the Save As dialog box. This is because the RDLC layout that you are trying to save is not connected to Object Designer. When you closed the report in Object Designer, the version of the RDLC layout that was connected to Object Designer was saved in the report and then deleted.

  10. (optional) To make additional changes to the report layout, on the View menu, click Layout, and then repeat stepsĀ 5 through 9.

See Also

Tasks

Troubleshooting: Classic Client Report Designer and Visual Studio Report Designer