Troubleshooting: The Server Is Not Compatible

If the versions of the Microsoft Dynamics NAV Server and the Microsoft Dynamics NAV Universal App are not compatible, you will get an error.

On the tablet when connecting the Microsoft Dynamics NAV Universal App version 1.1 to Microsoft Dynamics NAV 2016, you will get the following error:

This version of the device app is not compatible with the Microsoft Dynamics NAV service. Please upgrade your app.

On the phone when connecting the Microsoft Dynamics NAV Universal App version 2.0 to Microsoft Dynamics NAV 2015, you will get the following error:

This server is not compatible and must be upgraded to a newer version. Please contact your system administrator.

The versions are compatible as described below:

  • If you have the latest version of the Microsoft Dynamics NAV Universal App on the tablet, you can connect to both Microsoft Dynamics NAV 2015 and Microsoft Dynamics NAV 2016.

  • If you have the latest version of the Microsoft Dynamics NAV Universal App on the phone, you can only connect to Microsoft Dynamics NAV 2016.

  • If you have an older version of the Microsoft Dynamics NAV Universal App, you cannot connect to Microsoft Dynamics NAV 2016 until you have updated the Microsoft Dynamics NAV Universal App to the latest version from the device store.

See Also

Concepts

Troubleshooting the Microsoft Dynamics NAV Universal App