Space Plan Technical Overview for Visio 2002

Archived content. No warranty is made as to technical accuracy. Content may contain URLs that were valid when originally published, but now link to sites or pages that no longer exist.

Published: October 1, 2001

Visimation, Inc.

Microsoft Certified Partner

Applies to:

Microsoft Visio Professional 2002

Summary: This article provides a technical feature overview, planning tips, example scenarios, and performance guidelines for the new Microsoft Visio 2002 Professional Space Plan solution. (19 printed pages)

For the latest information, please see http://www.microsoft.com/technet/prodtechnol/visio/default.mspx and http://www.microsoft.com/office/visio/.

On This Page

About this article
Introduction
Space Plan Menu Commands
Visio 2002 Space Plan Scenarios
The Visio Space Plan Template
Creating and Updating a Space Plan
Using Color for Emphasis
Customizing your Space Plan
Generating Reports
Performance
Recommended Readings

About this article

The features discussed in this article are available only to Microsoft® Visio® 2002 space planning. Microsoft Visio 2000 Facilities Management (FM) is different from the Visio 2002 Space Plan, although the drawing files for Visio 2002 Space Plan and Visio 2000 FM are compatible.

Some of the examples in this article use the Visio 2002 Organization Chart sample data found in the C:\Program Files\Microsoft Office\Visio10\1033\Samples\ Organization Chart\Sample Org Chart Data.xls file.

Introduction

Using the Visio Space Plan template, you can create space plan drawings and color-coded customized reports with as little effort as importing a Microsoft Excel spreadsheet containing employee information and office room numbers. Or, you can import a computer-aided design (CAD) drawing of your building floor plan and combine this data with your personnel database to create complex and powerful reports.

With Visio 2002 Professional Space Plan, you can:

  • Use comprehensive diagramming and drawing tools designed for office, business, and technical professionals.

  • Create precise, measured building plan drawings for floor planning and building infrastructure drawings, and plan drawings of corporate offices and manufacturing facilities.

  • Create your plans and drawings quickly and easily by importing existing data. Import from a Lightweight Directory Access Protocol (LDAP) compliant directory such as Microsoft Windows® 2000 Active Directory™, an Open Database Connectivity (ODBC) compliant directory like Microsoft Access, from a MAPI store like Microsoft Exchange Server, or from Microsoft Excel.

  • Customize your drawing views and reporting capability by color coding your space plans, and generate custom reports based upon selected information or criteria.

  • Create, categorize, and label new shapes by shape type: person, location, or an asset such as equipment, furniture, and printers. Create additional custom shape properties, storing and tracking any information you choose about your office and space plan.

  • Create complete, accurate layouts with an expanded shape collection that includes the new curved walls shape. Shapes are now organized in an intuitive and easy-to-find manner designed for quick access.

Visio Space Plan is ideally suited to meet the needs of most users requiring a space-planning tool. Whether you are a facilities coordinator responsible for physically moving office workers from one location to another, or an office administrator responsible for tracking space and assets, Visio 2002 Professional Space Plan is for you. Figure 1 shows a completed Office Space Plan.

Cc723709.spcpln01(en-us,TechNet.10).gif

Figure 1: Office space plan

Space Plan Menu Commands

The Visio 2002 Space Plan template opens with a Plan menu that contains commands that are specific to space plan drawings.

Table 1 New Visio 2002 Space Plan Menu Commands

Plan Menu Option

Feature Description

Explorer

View your space plan information in a window called the Explorer. The Explorer provides hierarchical views of your plan information with a Categories Explorer view and a Spaces Explorer view.

Color by Values

Color code your space plan based on the property values of shapes. For example, color code your space plan by department codes. You can also add a legend to your drawing that explains the color coding.

Label Shapes

Add labels to new shapes in your drawing using the Label Shapes command. This displays values from your custom properties as shape text.

Assign Categories

Assign one of the predefined space plan categories to a custom shape you have created for use with the solution. For example, create a new asset or person shape.

Import Data

Import data from an LDAP data source such as Active Directory, an ODBC compliant data source like Access, from MAPI based sources like Exchange Server, or from Excel using the Import Data wizard.

Refresh Data

Update your space plan drawing as you make changes to your source data.

Convert to Walls

Convert exterior or interior wall shapes into a space shape. For example, convert floor plan walls into an office shape.

Set Display Options

Choose to display the space use, name, and area values, or change the unit of measurement (for example, square feet, square inches) on your space plan.

Note: Convert to Walls and Set Display Options are not space plan tools.

To enable the Plan menu if it is not available on the main menu

  • On the Tools menu, point to Macros, point to Building Plan, and then click Enable Space Plan to load the Space Plan Solution.

  • On the File menu, point to New, point to Building Plan, and then click Space Plan to open the Space Plan Template.

Visio 2002 Space Plan Scenarios

Visio Space Plan is customizable to the degree that it can produce a space plan or a report that matches the data you import from your data source. This limits the usability and range of space planning only by the type of data you can create or import into Visio 2002. Visio Space Plan can report on any information that includes a location value.

Consider these sample space-planning scenarios:

  • Move management You must produce an office plan for tomorrow's status meeting, showing your recommendations for where employees will sit in the new building. All you have to begin your task is a printout of the new floor plan and an Excel spreadsheet with employee names, departments, manager name, and cost centers. You scan in the floor plan with a scanner application, and import the scanned file and the Excel file into Visio 2002. You can now quickly create a professional looking office seating plan to share with your facilities management team, enabling them to jump start planning for the physical move.

  • Find employees and assets After creating your space plan and locating employees in their office space, you learn that the CFO wants to sit near to all her direct reports. You can use the Find command on the Edit menu to locate each direct report by name on your space plan, and then drag and drop them into their new office space.

  • Color-coded departmental diagrams Your company has decided to relocate some departments into a new office building. You need to quickly determine which departments should move and which should stay in the current building. Using the Color by Values command, you can easily develop color-coded departmental diagrams based upon your department codes. Assign the color blue to your Finance department, green to Sales, and orange to the IT department. Now you can quickly see how much of your current building is dedicated to each department.

  • Space occupancy reports Your company is growing faster than your new building is being built and many employees are now sharing office space. Use the Color by Values command to create a color-coded Occupancy report that colors offices with two employees in green and offices with one employee in blue.

  • Power and energy maps As the facilities coordinator, you've been asked to verify that each conference room and office is wired with the correct electrical wattage to support new office and computer equipment. You import into Visio Space Plan an Excel spreadsheet containing room numbers, the wiring wattage for each room, and whether a room is an office or a conference room. By color coding your plan on the electrical wattage field, you can quickly see which rooms need to be upgraded.

The Visio Space Plan Template

The space plan information is sorted into nine categories, describing a location, person, or an asset. You can import data for any of these categories from an external data source.

Table 2 Space Plan Categories

Category

Description

Location: Space or Boundary categories

Spaces are containers for people and assets. A space usually represents an office or a common area in your space plan. Boundaries are containers for spaces. A boundary most often represents a department.

Person

Allows tracking information about all the people in your organization. You can associate a person with a space, which allows you to track and report on the location of the person.

Asset: Computer, Equipment, Fixture, Furniture, Printer, and Asset categories

Use the generic Asset category to track assets of any kind, or track specific assets using categories such as Computer or Printer.

Each category has a set of predefined properties associated with it. You can easily modify the properties of a category, either manually or when you import data. For example, the Person category includes a property for Name, but you can also add properties for Last Name and First Name.

Each category is represented by a shape on the Resources stencil. If you have a shape that isn't associated with a category, you can create an association for it. For example, you might want to use a custom shape to represent all of your computers. You can associate this shape with either the Computer or the Asset category. Assigning a shape to a category automatically gives it the properties for that category.

Creating and Updating a Space Plan

This section describes how to create a space plan including discussing issues you need to consider before you begin developing your plan. The Explorer, Import Data, and Refresh Data space plan commands, found on the Plan menu, are described.

You can create a space plan in one of two ways:

  • Create a new space plan from scratch.

  • Import an existing database containing your space information using the Import Data wizard.

Both methods are described below, following the section "Before you begin your space plan".

Before You Begin Your Space Plan

Visio Space Plan is a powerful tool, and understanding a few key concepts before you begin can help make your space plan more effective. A meaningful diagram or report can be created quickly by importing a few columns of data stored in an Excel spreadsheet.

To receive the full functionality and robustness of the Visio Space Plan solution, consider the following items first:

  • Measurements of scale All floor and space plans use a scale value, and by default the value is measured in square meters or in square feet. Visio Space Plan lets you layer a space plan on top of a floor plan.

  • Consider dividing your source data into logical subsets when importing Initially, when you import, your data is placed in the Unplaced Data folder of the Explorer window. If your drawing file contains a large amount of unplaced information, it is recommended that you import subsets of data instead of importing the entire data file at once. Information in this folder is only held in memory and is not stored in a file, so if you exit from your session before moving all items from the Unplaced Data folder to your plan, any items still in the folder are lost. By importing smaller subsets of data, you can more easily manage the data in the Unplaced Data folder during a single session.

  • Categories Data is imported into specific space plan categories. You can only import data for one category at a time. For example, you can import data from a personnel database into the Person category, and then import data from a computer equipment database into the Computer category.

  • Space ID field The Space ID field is used to create an association between a space on your plan and the other shapes that can be added to that space. For example, when you import data like people, furniture and computer equipment using the Import Data command, the shapes representing these objects are placed in the space on the plan based upon the Space ID value.

    You should map a unique value from your source data to Space ID. For example, you might choose to map room numbers to Space ID.

  • Key field Like any tool that allows you to manipulate or update records of information, Space Plan needs a way to uniquely identify each shape in your plan and all the properties associated with that shape. Visio uses the Key field to associate each data record imported with the Import Data command to its specific shape. For example, when a unique Key is assigned, a link is created between a specific person shape and the database record for that person. This allows you to drag and drop the person shape assigned to Patricia Brooke to a new office, and Visio can move all the information about Patricia Brooke and her person shape to the new office.

    To use Refresh data you must map a field, or Excel column, from your source file that contains unique data for each record to the Key field during the Import Data wizard process. This is critical if you intend to use features like the Refresh Data command, or if you plan to import data multiple times from the same source file using Import Data. Without a unique value in each record's Key field, Import Data will import all of your data again, versus only importing changed information.

    Note: The Key field does not display on your plan or appear on any reports. You can view the value in this field by clicking on the Show ShapeSheet command from Window menu. Find the Custom Properties Prop.ID field.

  • One building per drawing file Each page in your drawing can represent a floor in your facility. You can also split floors across multiple pages. If your drawing file contains information for multiple buildings, ensure that each space in each building can be uniquely identified with a Key field. Typically, the Key maps to an office number; however, spaces in multiple buildings can have similar room numbers so office number may not work in the case where more than one building is contained in a drawing.

Using the Explorer Window

The Explorer provides a central location from which you can manage and arrange the information in your plan. You can view your information in the Categories Explorer pane, viewing hierarchical categories such as assets, boundaries, people, and spaces, or in the Spaces Explorer pane, viewing Name information organized by office or room, including the people and assets associated with each space.

To open the Explorer

  • On the Plan menu, click Explorer. The Explorer window provides both a category and space view of your data.

Creating a New Space Plan from Scratch

You can create a basic space plan from scratch in just a few simple steps. If you have access to a floor plan, you can insert the floor plan into a Visio Professional diagram and use it as a background on which to build your own space plan. If the floor plan is a paper copy, first scan the paper copy plan using a scanner application and then import it into Visio. The space plan overlays the floor plan and is the layer at which you create your space plan shapes.

  • On the File menu, point to New, point to Building Plan, and then click Space Plan. This opens a blank scaled drawing page in landscape orientation.

  • Next, create space shapes to designate each separate area, such as offices and common areas in your drawing. To add spaces, you can import data or drag Space shapes from the Resources stencil onto the drawing page. See this article's Creating a space plan with Import Data section for instructions on how to import data.

  • Assign names and space identifiers (Space IDs) to each of the space shapes in the drawing. To assign a name and space ID, you can use imported data or enter values manually. To manually add values, right-click on the space shape and click Properties from the shortcut menu. This displays the Custom Properties dialog box.

  • Continue dragging spaces onto the drawing page and arranging the shapes until you have created a space plan that reflects the layout of the offices in your building. To change the size or shape of a space, drag one of the space shape's green selection handles.

Creating a Space Plan with Import Data

This example uses the Visio 2002 Organization Chart sample data found in the C:\Program Files\Microsoft Office\Visio10\1033\Samples\Organization Chart\Sample Org Chart Data.xls file.

  1. On the Plan menu, click Import Data, select Space in the Category list, and then click Next.

  2. On the My database information is stored in: dialog box, select Excel for Source. Click Browse and navigate to C:\Program Files\Microsoft Office\Visio10\1033\Samples\Organization Chart folder and choose Sample Org Chart Data.xls. Click Open and then click Next.

  3. On the Choose the columns that contain name and location information dialog box, shown in Figure 2, select Office_Number for the Name, Space ID, and Key fields. Select <None> for Building ID. Click Next. The Name, Space ID, Building ID, and Key ID fields are described below.

    Cc723709.spcpln02(en-us,TechNet.10).gif

    Figure 2: Choose name and location information in the Import Data dialog box

    1. Name This is the value typically used to label the shape on the drawing and in the Explorer. The data from your source file that you map to this field should uniquely identify the item within the category you are creating (for example, Patricia Brooke as an individual within the person category, or room number as a shape within the space category). In the example shown in Figure 2, you are importing data into the Space category.

      The information mapped to this field displays in the Explorer window and in the space plan to identify the space shape (for example, room number).

    2. Space ID The data from your source file that you map to this field should uniquely identify the category you are creating. This field is used to place person or asset shapes into the correct office or space shape on the plan by matching Space ID values.

      It is acceptable for Space ID and Name to be mapped to the same source data. If this field is not assigned, shapes cannot be automatically placed in the drawing.

    3. Building ID The data from your source file that you map to this field is used to filter or select only the source records pertinent to the current drawing, or building. If your data source includes information for multiple buildings, select the field that most uniquely identifies the building.

    4. Key This field is used to uniquely identify each record of data in your space plan, as described in this document's Before you begin your space plan section. In the Import Data wizard, you must map a field, or Excel column, that contains unique data for each record in your data source to the Key field in order to use the Refresh Data command, or to update your space plan with any new changes made to your source data using the Import Data command.

      Note: The Key field does not display on your plan or appear on any reports. To view the value in this field, select the Show ShapeSheet command from Window menu. Find the Custom Properties Prop.ID field.

    On the Choose the fields that you want to add as custom properties dialog box, do the following:

    1. In the Fields list, click Department. In the Properties list, click Department, and then click Add.

    2. In the Fields list, click Telephone. In the Properties list, click Phone Number, and then click Add.

    3. In the Fields list, click Name. In the Properties list click <New>, and then click Add.

    4. Click Next, and then click Finish.

    The Import Data tool displays an Import Data Report with the columns and field values you selected, and imports this data into the Explorer. Note the Action column lists all items as Unplaced.

    Cc723709.spcpln03(en-us,TechNet.10).gif

    Figure 3: The Import Data Report

  4. Click the Categories tab in the Explorer window and expand the Unplaced Data folder by clicking the plus sign (+) next to the folder. Click the plus sign (+) next to the Space category. Alternately, click the Spaces tab in the Explorer window. Your imported space information is displayed.

    Cc723709.spcpln04(en-us,TechNet.10).gif

    Figure 4: Spaces tab in Explorer Window showing Unplaced Data

  5. Select and drag each item from Explorer to the appropriate position on the space plan. Notice that as each shape is placed, the shape information moves from the Unplaced Data container to the model space container.

  6. Drag all items in the Unplaced Data folder to your space plan.

Tips on Handling Unplaced Data

Note: Shapes in the Unplaced Data container are held in memory only for the duration of your session. You must place all items on your diagram in order to save the shapes and data. Otherwise this data is deleted when you exit from your session.

  • Cut and paste any unplaced data into an Excel spreadsheet to be imported at a later time. You can use the Import Data Report to capture the unplaced data you wish to paste into an Excel spreadsheet.

  • Drag and drop the shapes onto your open space plan. You needn't place the shapes within an office on your plan; place them outside the drawing page on the perimeter of your plan.

Using Refresh Data to Update a Space Plan

Use the Refresh Data command to update your space plan with changes made to your source data. In order for the Refresh Data command to correctly update your data, you must map a field, or Excel column, from your data source that contains unique data for each record to the Key field when you import your data. The Key field is how each record is uniquely identified.

To update your space plan

  • On the Plan menu, click on Refresh Data.

  • Select the check boxes for the categories that you want to update.

  • Select Update Current page, select the Show report option, and then click OK.

Tip You can prevent specific shapes from being removed by locking layers. For example, lock the Person layer to refresh asset shapes without removing person shapes from the drawing.

Tips on Creating and Modifying Space Plans

To change a room number or the name of a shape

  1. Click the space shape so that the office space is selected. On the View menu, click Custom Properties Window.

  2. Click the Name or Space ID values to edit the fields. The values in your space changes as you edit the field. Close the window when you are finished.

    You must now update the plan's Prop.ID field located within Custom Properties.

  3. On the Window menu, click Show ShapeSheet and scroll to Custom Properties. Find the Value column and change the Prop.ID value to match the new room number and name, as shown in Figure 5.

    Cc723709.spcpln05(en-us,TechNet.10).gif

    Figure 5: ShapeSheet® Custom Properties window

Locating Missing Shapes and Finding Shapes on your Plan

After importing new data into an existing space plan, in some cases you can view the new data in the Explorer window but you may not see the shapes on the plan. This is because the shape may be placed "under" the space shape it occupies.

To locate missing shapes

  1. Click on the space where the new shape should reside.

  2. On the Shape menu, point to Order, and click on Send to Back.

  3. The new shape is now visible.

You can also use the Find command available on the Edit menu to locate a shape with a specific value. If the shape appears to be behind another shape, you can move it to the front using the Bring to Front command

To use Find and Bring to Front

  1. On the Edit menu, click Find and enter the value you want to locate.

  2. Click Find Next until you locate the shape. Click Cancel.

  3. Right-click on the shape, point to Shape on the shortcut menu, and click Bring to Front.

Using Color for Emphasis

After you have imported your data and associated your source information, like office number name, department, cost center code, or equipment type with the space, person, location, or asset shapes, you can use the Color by Values command to customize your plan and reports.

Coloring your floor plans to emphasize items produces valuable, easy-to-see categorization of your information. Examples of using coloring include identifying personnel by a Cost Center, or creating an Occupancy Report showing what offices or cubicles seat more than one employee.

Using Color by Values to Color your Space by Values

These steps can be used to produce a colored Cost Center Report. Before you can generate a Cost Center Report, ensure your source data includes a cost center or department field.

  1. First import your data using the Import Data command or create a plan from scratch if you haven't already done so. See Creating and updating a space plan for instructions on how to create your space plan.

  2. On the Plan menu, click Color by Values.

    Note: Optionally, you can first select specific shapes to be colored then choose the Color by Values command.

  3. In the Color by Values dialog box, select the category of the shapes you want to color in the Shape category list. To color the Person shape by Department or Cost Center, select Person in the Shape category list.

  4. In the Shape property list, select the property on which you want to base the coloring. Select Department or Cost Center in the Shape property list for the Cost Center Report.

  5. In the Sample list, select the value to which you want to assign a color and pattern, and then click Change Color. For the Cost Center Report, select a cost center or department to which you want to assign a color and pattern, and then click Change Color.

    Cc723709.spcpln06(en-us,TechNet.10).gif

    Figure 6: Assign colors by department with Color by Values

  6. In the Change Color dialog box, select a new color or pattern, and then click OK.

  7. To generate an explanatory list of colors on the drawing page, select the Create Legend option, and then click OK.

  8. The legend for the Color by Values selection is in the lower left-hand corner of the drawing.

    Tip To apply the same legend to other drawings, copy the legend onto a stencil. Drag the legend from the stencil to the new drawing to be colored.

Using Color by Values to Produce an Occupancy Report

You can color your offices by the number of occupants (Person shapes) within each office. First, you must add Person shapes to the drawing.

  1. On the Plan menu, click Color by Values.

  2. In the Color by Values dialog box, select Space in the Shape category list.

  3. In the Shape property list, select Occupancy. Select Create Legend. Click OK.

Customizing your Space Plan

This section describes how to customize your space plan by incorporating custom shapes. The Assign Categories and Label Shapes space plan commands found on the Plan menu are described, and an explanation is given on revising the Master Shape to fit your requirements.

Using Assign Categories

You can create your own shape to be used as a space plan shape. For example, create a shape to signify a conference room or a piece of equipment. After you create a shape, you need to add properties to the custom shape before Space Plan can recognize it. The Assign Category command adds these necessary properties.

To assign categories to a shape

  1. Select the custom shape on your space plan.

  2. On the Plan menu, click Assign Category. In the Assign Category dialog box, select a Category from the list, and click OK.

  3. Click Properties and on the Properties dialog box, match Properties values to Category Properties values. Click Add, and then click OK.

  4. To set custom properties to this shape, select and right-click the shape, and point to Shape on the shortcut menu. Click Custom Properties and add the appropriate values. Click OK.

Using Label Shapes

You can display the values of any custom property as shape text with this utility for both custom and predefined shapes. If you create a custom shape, first assign it to a category and then label that shape with a property defined for the category. For a predefined shape, select a different custom property to display as shape text. You can elect to display the custom property label on your space plan too, for example Name: Patricia Brooke or Title: Executive Assistant.

To create a custom shape and assign a label

  1. Click on the Rectangle tool or Line tool buttons on the Toolbar to draw a closed shape. Before you can assign a label, you must first assign a category to the shape.

  2. Click on the shape. On the Plan menu, click Assign Category, and select Space in the Category list. Click OK. Custom properties are added to the shape making it a space.

  3. Right-click the shape and click Properties on the shortcut menu to add a room number value to the Name and Space ID fields. Click OK.

  4. On the Plan menu, click Label Shape, and select Name in the Category list. To show the label Name in the shape on your space plan, select the Display property name in label field. Click OK.

Revising the Master Shape

You can change the appearance (for instance, the font or fill color) of a master shape used on your space plan or you can develop a new master shape from scratch. This allows you to personalize your plans. For example, you can conform to company space plan standards for font and shape background, or meet special needs such as placement of your space plan within a proposal or presentation.

To revise the Person shape for the current drawing

  1. On the File menu, point to Stencils, and click Document Stencil. This opens a new stencil specific to this drawing.

  2. Double-click the Person shape, and then double-click the Person text. On the shortcut menu, select the formatting option you want.

  3. Click inside the shape, then right-click and then point to Format on the shortcut menu to select the Fill, Text, and Line properties.

  4. Close the master drawing window, and then click Yes to the Update 'Person' prompt.

To revise the master Person shape for all new drawings

  1. On the File menu, point to Stencils, point to Building Plan, and then click Resources to ensure the Resources stencil is open.

  2. Right-click the title bar of the Resources stencil. Click Edit, and then double-click the Person shape.

  3. Double-click the Person text, and then right-click to select the formatting you want from the shortcut menu.

  4. Click inside the shape, then right-click and point to Format on the shortcut menu to change the Fill, Text, or Line properties.

    Note: The changes you make to the master Person shape only affect any new uses of the shape, but do not affect shapes currently placed within any drawing.

Generating Reports

There are three methods available to produce reports. The Asset Report and the Space Report are predefined reports. You can create your own customized reports on any custom properties field using the Report Definition Wizard. Finally, you can produce color-coded reports with the Color by Values command. For examples of using color to produce reports, see this article's section on Using color for emphasis.

Asset Report and Space Report

You can create a report of the assets in your plan or the spaces in your plan by using the Asset report or Space report shapes on the Resources stencil. The asset report contains information on space name and the names of the assets in your space, and the space report contains information about the space name, area, use, and department.

To add a Space Report or Asset Report shape to your space plan drawing

  • From the Resources stencil, drag the Space report or Asset report shape onto the drawing page.

Report Definition Wizard

You can create and customize your own reports using the Report Definition Wizard. For example, create a report of computer equipment and other assets located within each office, or calculate the square footage assigned to each department within your building. The Report Definition Wizard lets you create reports on some or all of the shapes within your drawing and the shapes' properties.

To create a report of your people, assets, or office spaces in Excel format

  1. On the Tools menu, click Report, and then click New on the Report dialog box.

  2. Choose All Shapes in the document on the Report Definition Wizard dialog box and click Limit Selection. This displays a Loading data progress bar.

  3. On the Limit Selection dialog box, create a Defined criteria variable by choosing Shape Type from the Property list and set the Condition equal to (=) a Value of Person. This filters for information only on the person shape. Click Add and click OK.

    Note: To filter your data for space shape only, choose Shape Type from the Property list and set the Value equal to (=) Space. Click Add and click OK.

  4. Click Next on the Report Definition Wizard dialog box. Select the Show all properties option and choose the properties to display in your report columns, such as Name, Department, Reports To, Belongs To, and Email address. Click Next.

  5. Enter a title in the Report Title field, and click Next.

  6. On the Save the report definition dialog box, enter a name for the Report Definition Name, and select to Save in a file. Navigate to where your file is to be saved and click Finish.

  7. Click Run on the Report dialog box, and choose Microsoft Excel in the Select report format list box. Navigate to where your file is to be saved for Save report as and click OK.

  8. Select the Open report now box and click OK.

    Note: After you have created this report once, you can use it with any other drawing.

Performance

This information is given as a guideline only since official Visio 2002 Space Plan benchmarks are not available. Be aware that application performance is also affected by many variables, including your hardware and software configuration, other applications running on the system at the same time, and the complexity of your space drawing. The amount of time required to import a file into a space plan is impacted by the size of the source file.

As an example, an Excel spreadsheet containing information on the occupants of Microsoft Building 18 was created. It took approximately 98 seconds to import this data and populate a space plan with the 651 Person shapes. Opening the space plan for Building 18 required approximately 30 seconds. This plan's file was approximately 4.5MB in size and contains 859 spaces on 3 floors (3 pages).

For performance reasons, the Undo command available from the Edit menu, is disabled after the first 50 operations. If you perform more than 50 actions, like creating more than 50 shapes in a space plan, the Undo is disabled for actions 51 and on. This is because Undo is memory intensive, and the potential processing time required to Undo a large number of user actions can be significant.

For a step-by-step guide on how to create a space plan and floor plan by importing existing data, see the article Build a Space Plan from a List of Office Numbers in Visio 2002.

http://office.microsoft.com/assistance/2002/articles/vSpacePlan_aw.aspx

About Visimation

Visimation is a Microsoft Certified Partner who specializes in Microsoft Visio consulting, custom development, training, and services.

http://www.visimation.com/