Manage and Visualize Your Windows 2000 Deployment

Archived content. No warranty is made as to technical accuracy. Content may contain URLs that were valid when originally published, but now link to sites or pages that no longer exist.

By Judy Lemke

On This Page

Introduction
Phases of Windows 2000 deployment
Phase 1: Vision/Scope
Phase 2: Planning
Phase 3: Development
Phase 4: Proof of concept
Phase 5: Pilot
Phase 6: Deployment
Phase 7: Post-implementation review
Summary
Additional Information

Introduction

For many companies, the next big IT initiative involves deploying Microsoft Windows 2000. The payoff promises to be significant: a reliable, scalable, manageable, Internet-ready platform for your organization. Planning and managing the deployment project, designing a reliable network and directory structure, and aligning people and processes to the new technology are critical components to smooth, rapid deployment-and to your success. Volumes of information exist describing the specific steps and technical recommendations for successfully deploying Windows 2000, but little information has appeared about how to organize your deployment team to support this operation.

Enter Microsoft Project 2000, Microsoft Project Central, and Microsoft Visio 2000 Enterprise. These easy-to-learn tools can help you through every phase of Windows 2000 deployment. Use Project 2000 and Project Central to manage the project from beginning to end. Use Visio 2000 Enterprise to create diagrams to help you visualize every aspect of the project. For example, document and plan your network and directory structure, diagram business processes, track your new Windows 2000-based systems, and then share these diagrams with members of the team using your company intranet. With these three tools, your teams, clients, and vendors can all understand the project, from the big picture to the details, and work toward common goals.

About this document

This document discusses

  • The phases of Windows 2000 deployment as outlined in the Windows 2000 Deployment template included with Project 2000.

  • Managing your Windows 2000 deployment project using Project 2000, and collaborating with the deployment team using Project Central.

  • Visualizing your deployment through Visio diagrams, specifically designing and documenting your existing and proposed network and directory structure using Visio 2000 Enterprise.

It also includes step-by-step procedures for project management and diagramming tasks, such as revising the Windows 2000 Deployment template included with Project 2000 to fit your company's needs and diagramming your proposed Active Directory services and site structure with Visio 2000 Enterprise. This document does not discuss the specific steps in deploying Windows 2000. For more information about these steps, visit the Windows 2000 Server Deployment Page.

About the document structure

This document was written with modularity in mind so you can approach it in a variety of ways. You can read it in a linear fashion or jump directly to the section that interests you most.

Each section provides a general description of one phase of Windows 2000 deployment, the project management tasks involved in the phase, and the Visio diagrams you can create to support the phase. Each section also contains navigational links so you can jump from section to section.

The Phases of Windows 2000 Deployment section introduces you to each of the phases and acts as a document map. Use it to jump to specific sections and step-by-step procedures.

Phases of Windows 2000 deployment

This section introduces you to the seven phases of Microsoft Windows 2000 deployment according to the Windows 2000 Deployment template included with Microsoft Project 2000 and the Windows 2000 Enterprise Planning Workbook.

This section provides a general description of each phase, how to use Microsoft Project 2000 and Microsoft Project Central for the project management tasks related to the phase, and how to use Microsoft Visio 2000 Enterprise to create diagrams for each phase. It also includes hyperlinks to the specific phases, related tasks, and step-by-step procedures.

**Phase 1:**Vision/Scope

  • Build the business case for deploying Windows 2000: What are your specific business goals? How can Windows 2000 help you achieve them? The answers will help you choose the most useful Windows 2000 features.

  • Determine your technology goals, project objectives, and scope so you can create a framework for your project plan.

  • Visualize the big picture with Visio diagrams, such as block diagrams, workflow diagrams, and process flow diagrams. Use these diagrams in your proposals for executive sponsorship and funding. Develop a diagram plan: a list of diagrams you'll create to assist in deploying Windows 2000.

Manage the project with Microsoft Project 2000 during this phase by creating a framework for your project plan.

Visualize the project with Microsoft Visio 2000 Enterprise during this phase by envisioning your project with Visio diagrams.

**Phase 2:**Planning

  • One of the functions of the Planning phase is to establish the steps that your deployment team uses to specify, implement, test, and perform the required activities.

  • Assemble the project team, and then define the project roles, tasks, and communication strategy. Plan for the unknown by setting up a contingency plan.

  • Visualize your current computing environment including the network environment, the company's organization, and test environment using Visio 2000 Enterprise.

Manage the project with Microsoft Project 2000 and Microsoft Project Central during this phase by building your project plan and define your communication strategy.

Visualize the project with Microsoft Visio 2000 Enterprise during this phase by diagramming your current computing environment.

Phase 3: Development

  • You have a project plan, communication strategy, and diagrams of your current environment in place at the beginning of this phase. Now, develop an actual design, sometimes called the functional design specification, for each Windows 2000 feature you want to deploy. Develop a detailed plan for configuring and distributing Windows 2000, including testing all scenarios. By the end of this phase, you should have permission from management to proceed with the deployment.

  • Facilitate collaboration by putting your communication strategy into action with Project Central. Assess the risks of your project plan.

  • As part of the design specification process, diagram your proposed computing environment, including your Active Directory service using Visio 2000 Enterprise.

Manage the project with Microsoft Project 2000 and Microsoft Project Central during this phase by collaborating with team members using Project Central.

Visualize the project with Microsoft Visio 2000 Enterprise during this phase by diagramming your proposed computing environment.

**Phase 4:**Proof of concept

  • Prove that your deployment will be successful and catch problems before the actual deployment by setting up a representative sample of your production environment and testing all aspects of deployment in the test environment.

  • Evaluate and update your project plan and design specifications.

Manage the project with Microsoft Project 2000 during this phase by testing and

revising your deployment plan.

Visualize the project with Microsoft Visio 2000 Enterprise during this phase by testing your proposed computing environment.

**Phase 5:**Pilot

  • After you have completed your feature design and development and thoroughly tested your feature configurations, you are ready to conduct a pilot project, which involves implementing the entire plan on a representative group of users.

  • Share relevant pieces of the project plan, specifically the deployment plan, and your Visio design diagrams with the pilot group so they can give you feedback.

Manage the project with Microsoft Project 2000 and Microsoft Project Central during this phase by sharing your deployment plan with your pilot group.

Visualize the project with Microsoft Visio 2000 Enterprise during this phase by sharing your proposed computing environment diagrams with your pilot group.

**Phase 6:**Deployment

  • Now you are ready to incrementally deploy Windows 2000 throughout your enterprise.

  • In this phase, report on the progress of your deployment by generating reports in Project 2000. Create diagrams with Visio 2000 Enterprise that give an overview of the progress of this phase.

Manage the project with Microsoft Project 2000 and Microsoft Project Central during this phase by reporting on the progress of your deployment.

Visualize the project with Microsoft Visio 2000 Enterprise during this phase by visualizing your deployment progress.

**Phase 7:**Post-implementation review

  • This is the final phase of the project. During this phase, review the project and document the lessons learned to provide a foundation for future deployment projects or post-implementation directives.

  • Review your project plan and Visio diagrams, and reuse the data for other deployments and for maintaining your Windows 2000 environment.

Manage the project with Microsoft Project 2000 during this phase by reviewing your project plan and reusing the data.

Visualize the project with Microsoft Visio 2000 Enterprise during this phase by reviewing your Visio diagrams and creating current computing environment diagrams.

Phase 1: Vision/Scope

The first step in planning your deployment is to define your project objectives and the scope of your project. It is in this step that you identify the specific business goals you want to achieve and how Microsoft Windows 2000 can help you achieve them. This strategy will also help you choose the most useful Windows 2000 features. It is also in this step that you start pursuing executive sponsorship and funding. Use Visio diagrams in your proposals to help support your business case for deploying Windows 2000.

Create a framework for your project plan

Used effectively, a project plan can clearly identify specific phases of your overall deployment process, provide a clear and functional roadmap, and make it easier for your deployment teams to assess progress. The Windows 2000 Deployment template included with Microsoft Project 2000 provides that framework for your project plan.

Cc751340.p101(en-us,TechNet.10).gif

Revise the Windows 2000 Deployment template throughout the deployment process to fit your company's specific deployment needs.

To start with the Windows 2000 Deployment template and begin revising it to create your project plan

  1. Start Microsoft Project 2000. On the File menu, click New, and then, in the New dialog box, click the Project Templates tab.

  2. Double-click Windows 2000 Deployment.

  3. In the Project Information for Windows 2000 Deployment dialog box, enter the projected project start date.

    p102

    If you choose to schedule from the start date, the Finish date box becomes unavailable. You set the start date and Project 2000 calculates the finish date based on your task information.

    Your project plan is opened in the Gantt Chart view. To change project views, click a view on the View menu.

  4. On the File menu, click Save to save your project plan.

Note: To change the project information later, on the Project menu, click Project Information. To enter or review additional project-level information, on the File menu, click Properties.

Now that you have a framework to work with, you can add your own milestones and revise the existing milestones in your project plan to begin bringing the big picture into focus. Usually the first milestone is when the project team and executive sponsor agree on the overall direction for deploying Windows 2000 in your organization.

To add milestones to your project plan

  1. Right-click a task, and then choose New Task.

  2. Select the Duration field for the new task, type 0, and then press Enter.

  3. Select the Task Name field, type the task name, and then press Enter.

Note: To revise an existing milestone, just right-click the milestone, click Task Information, and then make changes to the milestone in the Summary Task Information dialog box.

Another project management aspect to consider in this phase is what other types of information you want to track in your project plan. The Windows 2000 Deployment template sets up your project plan to track tasks, duration, start and finish dates, predecessors, and resource names. You can track other information, such as cost, percentage of work completed, and risk probability, or you can customize task fields to track information not listed by default.

To track information in your project plan

  1. In the Gantt Chart view, select the column to the left of which you want to insert the new column.

  2. On the Insert menu, click Column.

  3. In the Column Definition dialog box, specify the field name, title, title alignment, data alignment, and width of the column.

    p103

    The Field name specifies the type of information to track in the column.

  4. Right-click the column after you've inserted it, and then click Customize Fields to revise the information in the column.

    p104

    In the Customize Fields dialog box, you can change the field type, create your own formulas, and specify graphical indicators that appear if certain criteria are met.

You can also make supporting documents-such as a Word document that outlines the business case for the Windows 2000 deployment or a Visio drawing that depicts a process-accessible from within your project by adding hyperlinks to Web pages, or to files or folders on your computer or network. Or, you can store a supporting file in your project plan.

To make supporting documents accessible from your project plan

  1. Make sure you're in the Gantt Chart view. On the View menu, click Gantt Chart, or click Gantt Chart in the View Bar to the left of your project plan.

  2. Select a task, and then, on the Insert menu, click either of these options:

    • Object to store a file in your project plan. Store it in your Project 2000 file if, for example, you want to share the document with users who are not part of your networked environment, or who will be working off-line. Because an embedded object becomes part of the Project 2000 file, it requires more disk space and will not reflect any updates that are made in the original document. You can also link to an object and display it as an icon; however, you'll probably insert a hyperlink instead of an object if you want to link to a file.

    • Hyperlink to link to a file, Web site, or bookmark within your project plan. Link to documents from your Project 2000 file if you want to share the document with users who are part of your networked environment, if you want to be able to access a document, or if you want to reference an Internet or intranet site from within Project 2000. Once created, a hyperlink icon will appear in the Indicators field.

Note: The Indicators field appears by default as the first column in the Gantt Chart view and the Task Sheet view. When you point to an icon in the Indicators field, a tip provides more information about the condition of the task.

Envision your project with Visio diagrams

Visio drawings can provide a clear, visual roadmap for your Windows 2000 deployment. In this phase, begin thinking about the diagrams you'll need throughout your Windows 2000 deployment-for example, diagrams that represent snapshots of your current and proposed computing environment and diagrams that support your business case for deploying Windows 2000. Make these decisions before you proceed with your deployment planning because they'll affect what you do and how you do it. Clear project and diagram plans will help you stay on course.

Cc751340.p105(en-us,TechNet.10).gif

Visio diagrams, such as block diagrams, process flow diagrams, and work flow diagrams, can support your business case for deploying Windows 2000. They simplify complex processes and ideas for upper-level management whose sponsorship and funding you seek.

To create a Visio diagram

  1. Start Microsoft Visio 2000. In the Welcome to Microsoft Visio dialog box, click OK.

    Note: If you're already running Microsoft Visio 2000, point to File, point to New, point to a category, and then click the diagram type you want to create.

  2. In the Choose Drawing Type dialog box, click a category, and then double-click the diagram type you want to create.

    p106

    Click the Block Diagram category to browse Block Diagram templates. Click the Flowchart category to browse Flowchart templates that you can use to create process flowcharts, cross-functional flowchart, and work flow diagrams.

  3. After you open the template, begin dragging and dropping shapes from the stencil onto the drawing page.

    Cc751340.p107(en-us,TechNet.10).gif

    When you start a Visio drawing with a template, Visio 2000 opens one or more stencils that contain related shapes and a blank drawing page that is the appropriate size for your drawing type. A template also contains the appropriate line, fill, and text formatting styles for your drawing type.

  4. Select shapes, and then type to add text or choose Formatting buttons and tools from the toolbars to format the shapes.

  5. Connect shapes using the Connector tool on the Standard toolbar.

  6. Insert pages by right-clicking the Page tab at the bottom of the drawing page, and then clicking Insert Page.

    You can give each page in a Visio file a descriptive name, such as Active Directory sites or Windows 2000 Feature Evaluation.

  7. On the File menu, click Save to save the diagram as a Visio file.

Phase 2: Planning

Every development project goes through a life cycle-a process that includes determining IT goals and objectives, designing and developing features, conducting a pilot project, and installing the new operating system in your production environment. The principal function of a deployment planning process is to establish the steps that your deployment team uses to specify, implement, test, and perform the required activities. Although there is a predefined order for installing many of the major Microsoft Windows 2000 technologies, you will need to refine that order based on the feature decisions you make.

Just as you build your project plan and define your communication strategy during this phase, you create documents that support the functional design specification for each Windows 2000 feature and add diagrams to your document plan by creating supporting diagrams that represent your current computing environment.

Build your project plan and define your communication strategy

In this phase, you start fleshing out the project plan by assembling the project team, defining roles, and inserting detailed tasks. You also need to define a communication strategy. Keeping people informed keeps them involved. An effective communication strategy identifies the needs of several types of audiences, such as executive management, project teams, IT organization, and users at all levels. Use your communication strategy to build enthusiasm and support for the project, the new technologies, and the business processes that the technologies support.

Cc751340.p201(en-us,TechNet.10).gif

In this phase, use another view in Microsoft Project 2000, the Resource Sheet view, to create a list of resources and assign roles in your project plan. Then, change to the Gantt Chart view to add tasks and dates to your project plan.

To add tasks and dates to your project plan

  1. To add a task, make sure you're in the Gantt Chart view, right-click the task that will follow your new task, and then click New Task.

  2. To enter task information, right-click the new task, and then click Task Information.

    Cc751340.p202(en-us,TechNet.10).gif

    In the Task Information dialog box, you can specify information, such as the dates for a task, the duration of a task, other tasks to which a particular task is linked, resources, and notes about the task.

  3. To link tasks, select the tasks you want link, and then, on the Edit menu, click Link Tasks.

To create a list of resources and assign roles in your project plan

  1. On the View menu, click Resource Sheet.

    Note: You can also select a work resource from your e-mail address book. In a task view, such as the Gantt Chart, click Assign Resources, and then click Address. Select the resource from your e-mail address book. If you select a group alias name from the address book, the names of all members of the alias are entered into the resource list. Display the Resource Sheet view again. (If you want, you can leave the Assign Resources dialog box displayed as well.) The new names also appear in the resource sheet, where you can continue to enter resource information.

  2. On the View menu, point to Table, and then click Entry.

  3. In the Resource Name field, type a resource name and other information about the resource that you want to track, such as pay rate. If you want to designate resource groups, in the Group field for the resource name, type the name of the group.

  4. On the View menu, click Gantt Chart, select the Resource Names field for the task you want to assign, and then choose the resource name.

In this phase, you also set up a method for communicating with the project team and keeping the project file updated during the project. Project 2000 offers two workgroup solutions for collaborating with your team: an e-mail workgroup system and Microsoft Project Central. An e-mail workgroup system makes it possible to share basic information about the project, including task assignment information and task updates. Project Central offers even more flexibility, such as:

  • You can view tasks for all of the projects at once, and group, sort, and filter the tasks.

  • You can view the latest information for the entire project, not just the assigned tasks, at the Project Central administrator's discretion.

  • You can create new tasks and submit them to the administrator for incorporation into the project file.

  • Project managers can request and receive status reports in the format you specify and easily consolidate individual status reports into one project status report.

  • You can delegate tasks to others: for example, the project manager can send tasks to a team manager or a lead to be reassigned to individual resources.

Later in this document, we'll discuss how to set up Project Central on a user's desktop to collaborate with the project team.

Diagram your current computing environment

Before you design your Windows 2000 environment, you must thoroughly understand your current computing infrastructure. Documenting your existing computing environment will help you define where you are today and figure out what you want to do for the future, and will contribute to the success of your deployment. For example, in this phase, you could create diagrams using Microsoft Visio 2000 Enterprise that document your layer 2 and 3 network topology and your current directory services.

Cc751340.p203(en-us,TechNet.10).gif

Understanding your current network infrastructure will help you develop and visualize your proposed Windows 2000 network environment.

Note: You could also create current organization charts in this phase to help you create a proposed Active Directory structure in the next phase. Start with the Organization Chart template to create them.

To create a diagram that documents your layer 2 and layer 3 network topology

  1. Start Microsoft Visio 2000. In the Welcome to Microsoft Visio dialog box, click OK.

    Note: If you're already running Microsoft Visio 2000, point to File, point to New, point to Network Diagram, and then click AutoDiscovery and Layout.

  2. In the Choose Drawing Type dialog box, click Network Diagram.

  3. In the Drawing Type dialog box, double-click AutoDiscovery and Layout.

    The AutoDiscovery and Layout template and stencils open, and the AutoDiscovery and Layout menu and toolbar appear. The menu and toolbar are available only when you open this template or a diagram created using this template.

  4. On the AutoDiscovery menu, point to Discovery, and then click Discovery to begin working in the Discovery wizard. Or, click Discovery on the AutoDiscovery and Layout toolbar.

  5. Answer the questions on the wizard screens. Different screens appear depending on your choices.

    You can specify the network to search, the types of devices to discover and exclude, and the type of search the wizard performs.

    For example, you can specify whether the AutoDiscovery technology uses SNMP or Ping, or searches ARP caches as the method for discovering devices. And you can specify where Discovery looks for network devices by selecting to discover the entire enterprise network, specific networks or IP addresses, or a range of IP addresses.

    Cc751340.p204(en-us,TechNet.10).gif

    On the Discovery Type screen, specify whether you want the Discovery wizard to discover only routers and SNMP devices. If Ignore Previously Discovered Devices is selected, the Discovery wizard runs faster; however, changes to these devices aren't discovered.

    Cc751340.p205(en-us,TechNet.10).gif

    On the Enter SNMP Information screen, specify SNMP information, such as time-out settings. The time-out settings tell the Discovery wizard how long to wait for a device to respond to a Ping or SNMP request before either making another attempt or timing out (terminating the search). A Ping or SNMP request is made to a specific device in an attempt to discover information about that device. If you have many devices on your network that don't respond to SNMP requests, decrease the time in the SNMP time-out field so that the Discovery wizard does not wait so long before moving on to another device. You should also add the SNMP communities you want to use in your network, and move the most common community to the top of the Community Strings list.

    Cc751340.p206(en-us,TechNet.10).gif

    On the Discover Non-Router Devices screen, specify the method for discovering non-router devices. Choosing Ping Undiscovered Devices may cause Discovery to take longer, as the Discovery engine attempts to Ping devices that may not exist. The time required to attempt contact with each undiscovered device will be the number of retries multiplied by the time-out value.

    Cc751340.p207(en-us,TechNet.10).gif

    After you have completed the last wizard screen, the Discovery Monitor opens to show you the progress of the discovery of your network.

    When the Discovery wizard is finished, the message "AutoDiscovery is Finished" is displayed and the AutoDiscovery database is created.

  6. To begin laying out your diagram, point to File, click Page Setup, and then click the Page Size tab to specify the page size for your network diagram.

    Note: You can also lay out your diagram automatically by clicking AutoLayout on the AutoDiscovery menu.

  7. Click Add Networks on the AutoDiscovery and Layout toolbar. In the Add Networks dialog box, select a network, and then click OK.

    Usually you begin by adding your backbone network to the diagram. A shape representing the network is automatically added to the diagram.

  8. To connect network devices such as routers to the network, right-click the network in the diagram, and then click Connect Devices on the shortcut menu.

  9. In the Connect Devices dialog box, select those devices connected to the network that you want to place on the diagram. Check Attach Interface IP Address To Links to display the IP address of links between two devices on the diagram.

    Note: You can also quickly create tabular and textual reports of your discovered network's status. For example, you can quickly inventory IP addresses, summarize frame relay data, track changes to your network topology, and more. To generate a report, on the AutoDiscovery menu, point to Network Reporting, and then click Report Wizard.

    For more information about diagramming your network, read Step-by-step guide to diagramming your network with Microsoft Visio 2000 Enterprise.

To diagram your current directory services

  1. Start Microsoft Visio 2000. In the Welcome to Microsoft Visio dialog box, click OK.

    Note: If you're already running Microsoft Visio 2000, point to File, point to New, point to Network Diagram, and then click the directory service you want to import.

  2. In the Choose Drawing Type dialog box, click Network Diagram.

  3. In the Drawing Type dialog box, click the directory service you want to import.

  4. In the Connect to Directory dialog box, click Import from a Live Directory.

    In the Directory Browser, you will see a list of servers to which you can connect.

  5. Click Browse to navigate to the server you want to connect to, and then select it.

    If you aren't logged onto the server, you are prompted to supply your user name and password.

    Note: To be able to connect to a specific server, you must have permission to log onto that server.

  6. Click OK to return to the Connect to Directory dialog box.

    p208

    The directory path of the object you are selecting to import appears in the Directory Object field. This field displays the location of the object in the tree from the selected object to the [Sub Tree] level.

    Note: Each directory service uses a specific punctuation mark to separate objects in the path of the Directory Object field. LDAP separates objects using a comma (,) and Novell Directory Services (NDS) separates objects using a period (.).

  7. In the Filter Options section, select the types of classes you want to import.

  8. In the Import Depth field, enter a value that indicates the import depth level you want.

    The import depth level indicates the number of subsequent child levels for the selected directory object that you want to import. For example, if you import an Organizational Unit class and you enter 3 in the Import Depth field, you will import all the child objects that are three levels below the Organizational Unit.

  9. Click OK.

    The Connect to Directory dialog box closes. The [Sub Tree] icon appears in the Directory Navigator along with a schema based on the directory services solution you selected.

Phase 3: Development

You have a project plan, communication strategy, and diagrams of your current environment in place at the beginning of this phase. Now, develop an actual design, sometimes called the functional design specification, for each Microsoft Windows 2000 feature you want to deploy, one of the most important being Microsoft Active Directory. Develop a detailed plan for configuring and distributing Windows 2000, including testing all scenarios. Facilitate collaboration by putting your communication strategy into action with Microsoft Project Central, and diagram proposed network structures with Microsoft Visio 2000 Enterprise.

Collaborate with your team members using Project Central

When you use Project Central to communicate, you can post the most current project information for others to see. After you set up your project plan for viewing on Project Central, send workgroup members the URL that points to the Project Central Home Page so they can find Project Central by using Microsoft Project 2000 or their Web browser. After they have the URL, all they have to do is connect to Project Central and use it.

To set up your project plan for viewing on Project Central

  1. On the Tools menu, point to Workgroup, and then click TeamInbox.

  2. On the Welcome page, enter your name and password, and then click Enter.

  3. Click Admin on the menu bar or in the navigation pane.

  4. In the Actions list, click Manage Views, and then follow the Administration Overview instructions to create a view with categorized information and to set access permissions for others to view or update this information on Project Central.

  5. Click Views on the menu bar or in the navigation pane to see the information you specified, and let others know the information is available for viewing.

To connect the team to Project Central

  1. On the Tools menu, click Options, and then click the Workgroup tab.

  2. In the Default workgroup messages box, click Web. You can change the message option for individual resources using the Workgroup box on the General tab of the Resource Information dialog box.

  3. In the Microsoft Project Central Server URL box, type the URL for the Microsoft Project Central server.

    Cc751340.p301(en-us,TechNet.10).gif

    You need an account before you can work with Project Central, but one is created for you automatically when you send a workgroup message. If you want to work with Project Central before sending a workgroup message (for example to set up status reports or message rules), click Create Account.

    Note: If you don't know the URL for the Microsoft Project Central server, you can get it from your system administrator.

  4. Under Identification for Microsoft Project Central Server, click:

    • Windows user account to use your Windows user account to identify yourself to Project Central. All the workgroup messages you send will display the user account you used to log on to the network. Windows user accounts offer the strongest security for your project files. In addition, when you use a Windows user account, you are automatically authenticated when you access Project Central, so you don't need to enter a user name or password.

    • Microsoft Project user name to use Project Central authentication and your user name to identify yourself to Project Central. All the workgroup messages you send will display your user name as it appears on the General tab of the Options dialog box. When you access Project Central, you will be required to enter a user name and password.

      Note: By default, your password will be blank the first time you log on to Project Central. Set your password during your initial session.

  5. To apply your workgroup selections to all new projects, click Set as Default.

To start Project Central from Project 2000

  1. On the Tools menu, point to Workgroup, and then click TeamInbox.

  2. If you see a logon page, in the User Name box, type or select your name.

  3. If you see a logon page, in the Password box, type your password, and then click Go.

Diagram your proposed computing environment

Active Directory plays many roles, from being the backbone of distributed security to providing a service-publishing framework. It provides a central service for administrators to organize network resources; to manage users, computers, and applications; and to secure intranet and Internet network access. In this phase of Windows 2000 deployment, as part of the design specification process, use Microsoft Visio 2000 Enterprise to diagram your proposed Active Directory services and site structure, and your proposed Windows 2000 network topology.

Cc751340.p302(en-us,TechNet.10).gif

Before you deploy Windows 2000, you must develop a plan for the new network environment. Diagrams of your proposed network environment will help you flesh out that plan.

Note: You could also create physical layouts of your proposed test lab environment in this phase. Start with the Office Layout template to create them.

To diagram your proposed Active Directory services and site structure

  1. Start Microsoft Visio 2000. In the Welcome to Microsoft Visio dialog box, click OK.

    Note: If you're already running Microsoft Visio 2000, point to File, point to New, point to Network Diagram, and then click Active Directory.

  2. In the Choose Drawing Type dialog box, click Network Diagram.

  3. In the Drawing Type dialog box, double-click Active Directory.

  4. In the Connect to Directory dialog box, click Work Offline.

  5. To create your Active Directory object structure on this page, drag shapes onto the drawing page from the Active Directory Objects stencil.

    You can automatically connect and associate objects by dragging an object onto another object on the page.

    p303

    You can also manipulate your object hierarchy using the Directory Navigator window.

    Note: To add more than one shape at a time, right-click a shape, and then click Add Entries. To edit existing and add new properties, right-click a shape, and then choose Edit Properties.

  6. To create your Active Directory site structure on another page, insert a new page into the Visio file, click the Active Directory Sites and Services stencil at the bottom of the window to make it active, and then drag shapes from it onto the new drawing page.

  7. On the File menu, click Save to save the diagram as a Visio file, or to save it as an HTML or GIF file to share with other IT team members on your IT intranet site.

    To save a Visio diagram as an HTML or GIF file, in the Save As dialog box, choose the file type in the Save as type list.

In the next phase of Windows 2000 deployment, you will use this diagram to test your proposed Active Directory services.

To diagram your proposed Windows 2000 network topology

  1. Start Microsoft Visio 2000. In the Welcome to Microsoft Visio dialog box, click OK.

    Note: If you're already running Microsoft Visio 2000, point to File, point to New, point to Network Diagram, and then click Active Directory.

  2. In the Choose Drawing Type dialog box, click Network Diagram.

  3. In the Drawing Type dialog box, double-click Basic Network.

  4. From the Basic Network Shapes or Basic Network Shapes 3D stencil, drag a ring, bus, Ethernet, or other network topology shape onto the drawing page.

  5. From the Basic Network Shapes, Basic Network Shapes 2, or Basic Network Shapes 3D stencil, drag computer, printer, and other shapes to indicate the devices connected to the network that the network topology shape represents.

  6. Attach the devices to the network topology shape using the shape's built-in connectors.

  7. Select any network shape, and then type to replace the existing text with a person's name, a room number, or the name of the network device. Drag the control handle to reposition the text.

  8. Use the Laptop Computer, Modem, Fax, Public Switch, Cloud, Comm-link, and other connector shapes on the Basic Network stencils to indicate connections to devices outside of a network.

  9. Right-click any network shape, and then choose Properties to associate custom property values with the shape, such as manufacturer name, product number, serial number, location, room, or department.

    Note: After you add custom property values, you can generate reports based on these values. To generate a report, on the Tools menu, choose Property Report to start the Property Reporting wizard.

Phase 4: Proof of concept

Prove that your Microsoft Windows 2000 deployment will be successful and catch problems before the real deployment by setting up a representative sample of your production environment and testing all aspects of deployment in the test environment. Start by testing features that are mission-critical to your organization. Testing is a checkpoint against progress. You can't measure progress unless it has been verified by testing.

During this phase, you're not only testing the actual deployment, you're testing your deployment project plan and diagrams. Good testing results will help you secure buy-off among the team and other stakeholders.

Test and revise your deployment plan

During this phase, analyze your deployment plan to identify potential problems. You can use various strategies for changing and refining your project plan; for example, changing the finish date, adjusting tasks to shorten the schedule, resolving resource over allocations, ensuring that your scheduling reflects real-world constraints and dependencies, and reducing cost.

To change the finish date of your project

  1. On the Project menu, click Project Information.

    Be sure that the Schedule from box shows Project Finish Date.

  2. In the Finish date box, type or select the new finish date.

    Note: If the start date doesn't change after you've changed the finish date, then one or more tasks have a date constraint applied. You can review the constraints in your plan to make sure they're necessary and appropriate.

To change duration of tasks in your project plan

  1. Make sure you're in the Gantt Chart view, and then, in the Duration field of the task you want to change, type the duration you want.

    You can enter durations in minutes, hours, days, weeks, or months.

  2. If the new duration is an estimate, type a question mark after it.

  3. Press Enter.

    If you've created task dependencies, you can further refine them to schedule your tasks more accurately. You can use lead time to make tasks overlap, and you can introduce a delay between tasks with lag time

To set lead or lag time between tasks in your project plan

  1. Make sure you're in the Gantt Chart view, and then, in the Task Name field, right-click the task for which you want to set lead or lag time, and then click Task Information.

  2. Click the Predecessors tab.

  3. In the Lag field, type the lead-time or lag time you want as a duration or as a percentage of the predecessor task duration.

    Cc751340.p401(en-us,TechNet.10).gif

    Type lead time as a negative number (for example, -2 for two days lead time) or as a percentage, and type lag time as a positive number or as a percentage.

    Tip You can quickly add lead or lag time to a successor task by double-clicking the link line on the Gantt Chart, and then typing the amount of lead or lag time in the Task Dependency dialog box.

    You can also make new work assignments or change existing assignments based on your testing results. Then you need to communicate these changes to the assigned resources. You can communicate electronically through Microsoft Project Central or e-mail, or by printing assignment reports.

To change a work assignment and communicate the change by e-mail

  1. Make sure you're in the Gantt Chart view, and then, in the Task Name field, select the task for which you want to change the assignment.

  2. On the Tools menu, point to Resources, and then click Assign Resources.

  3. In the Assign Resources dialog box, make changes, and then click the appropriate button.

    p402

    In the Assign Resources dialog box, you can assign, remove, and replace resources.

  4. With the Task Name field of the task you changed still selected, hold down the CTRL key and click the task names to select nonadjacent tasks, or hold down the SHIFT key and click the task names to select adjacent tasks.

  5. On the Tools menu, point to Workgroup, and then click TeamUpdate.

  6. If you want to change the default subject for the update, type it in the Subject box.

  7. If you want to change the default message, type it in the message area.

  8. Click Send.

Test your proposed computing environment

You created your proposed Active Directory services diagram in the Development phase. In the Proof of Concept phase, you can test your proposed directory services by exporting your diagram to an LDAP Data Interchange Format (LDIF) file. You use the LDIF file format to save your directory diagram as an ASCII text file that you can import into your Windows 2000 test environment.

To export your Active Directory diagram to LDIF file format

  1. With your Active Directory service structure diagram open, on the Directory Services menu, point to Export to LDIF, and then click Export Entries.

  2. Type a name for the file.

  3. Select LDIF File*.ldf for Save as Type, and then click Save.

    The diagram is exported to an LDIF file format.

    Note: Values for properties are not checked against their syntax. Make sure that the value you enter for a property matches that property's syntax. If you enter an incorrect syntax format for a value, errors may result in the exported LDIF file.

  4. Navigate to your LDIF file and open it in a text-editing program, such as Microsoft Notepad or Wordpad.

  5. Delete the text that corresponds to the [Root] objects (top-level objects) that already exist in your target Active Directory structure.

    For example, in the case shown below, you would delete all of the text that corresponds to the com and AdventureWorks objects, shown in the shaded areas, because these objects already exist in the target Active Directory structure.

    AdventureWorks object hierarchy

    Directory service hierarchy

    Directory service objects

    Corresponding object text in the LDIF file

     

    p403

     

    p404

    version: 1dn: dc=comchangetype: adddc: com

       

    p405

    dn: ou=AdventureWorks,
    dc=comchangetype: addou: AdventureWorks

       

    p406

    dn: cn=Sales,ou=AdventureWorks,
    dc=comchangetype: addcn: Sales

       

    p407

    dn: cn=R&D,ou=AdventureWorks,
    dc=comchangetype: addcn: R & D

    The revised LDIF file would only include the text for the organizational units and would look like this:

dn: cn=Sales,ou=AdventureWorks,dc=com
changetype: add
cn: Sales
dn: cn=R&D,ou=AdventureWorks,dc=com
changetype: add
cn: R & D

  1. Save your revised LDIF file and import it into your Active Directory structure using Active Directory import functionality.

Phase 5: Pilot

After you verify your Microsoft Windows 2000 design in your test environment, you need to test it in your production environment with a limited number of users. A pilot reduces your risk of encountering problems during your full-scale deployment.

The primary purposes of a pilot are to demonstrate that your design works in the production environment as you expected and that it meets your organization's business requirements. A secondary purpose is that the pilot gives the installation team a chance to practice and refine the deployment process.

The pilot also provides an opportunity for users to give you feedback about how features work and if the timeframe was sufficient. Use this feedback to resolve any issues or to create a contingency plan. The feedback can also help you determine the level of support you are likely to need after full deployment. Ultimately, the pilot leads to your decision to proceed with a full deployment or to stop and rethink your solution.

Share your deployment plan with your pilot group

With Microsoft Project 2000, you can distribute parts of the project plan to people who are involved in the Windows 2000 deployment, but aren't on the project team, on your company's intranet in HTML file format.

Project 2000 uses import/export maps to determine which fields are exported to HTML file format and may use a template to determine how and where the information is displayed in the HTML file. You can create or edit both the HTML import/export maps and the HTML templates.

To save data in your project plan to HTML file format

  1. On the File menu, click Save As Web Page.

  2. If necessary, type a name for the exported file in the File name box.

  3. Click Save.

  4. In the Import/export map list, click the name of the map you want to use for exporting your data, or you can define a new map or edit an existing map.

    Cc751340.p501(en-us,TechNet.10).gif

    In the Export Mapping dialog box, select the data you want to include in your HTML file. Click New Map to create a custom HTML page. Click Edit to revise an existing map-for example, to add a graphic to your HTML page.

  5. Click Save.

    Note: You can include a snapshot of a Gantt Chart view by clicking the Copy Picture button on the Standard toolbar, and then adding it to your HTML page by clicking Edit in the Export Mapping dialog box, and then checking Include image file in HTML page.

Share your proposed computing environment diagrams with your pilot group

With Microsoft Visio 2000, you can also distribute relevant diagrams to people involved in the Windows 2000 deployment on your company's intranet. You can easily prepare Visio drawings so they can be viewed in two ways:

  • Save them as HTML pages.

    For example, you have a proposed Active Directory service diagram you want everyone on the deployment team to see. To immediately make the diagram available on the intranet, save it as an HTML page.

  • Save them in .jpg, .gif, or .png format.

    For example, you have a Web page on the intranet where you have explained the process your deployment team will use to deploy Windows 2000. Recently, you created a block diagram that makes the process easier to understand. To include the graphic on your existing Web page, export it as a .gif, and add an tag to your Web page HTML code.

To save a Visio diagram as an HTML page

  1. On the File menu, click Save As.

  2. Type a name for the HTML file.

  3. For Save as type, choose HTML Files (*.htm, *.html), choose where to save the file, and then click Save.

  4. In the Save as HTML dialog box, choose the graphics format and the drawing pages you want the HTML file to include. Take into consideration the browser that you plan to use to show the drawing.

  5. Click Filter Settings to control the on-screen image size of the saved drawing or to choose options specific to the graphics format, and then click OK twice.

    You are prompted to view the HTML pages.

  6. Click Yes to open your Web browser and view the first HTML page.

To save a Visio diagram in .jpg, .gif, or .png format

  1. On the File menu, click Save As.

  2. Type a name for the file.

  3. For Save as type, choose Graphics Interchange Format (*.gif), JPEG Format (*.jpg), or Portable Network Graphics Format (*.png).

  4. Choose where to save the file, and then click Save.

  5. In the Output Filter Setup dialog box, choose the options you want, and then click OK.

Phase 6: Deployment

This is it. At this point, you've tested all of your designs in the lab and conducted a pilot program to refine your plan and further test your designs. Now you are ready to incrementally deploy Microsoft Windows 2000 throughout your enterprise. Your goal is to deploy Windows 2000 successfully and efficiently, with minimum interruption to your users, the network, and the core business functions of the organization. Deploying Windows 2000 to the production environment shares many characteristics with deploying Windows 2000 in the pilot phase.

In this phase, report on the progress of your deployment by generating reports with Microsoft Project 2000, such as Unstarted Tasks, Tasks Starting Soon, Tasks In Progress, and Completed Tasks. Using Microsoft Visio 2000, you can also create diagrams such as timelines that give an overview of the progress of your deployment.

Report on the progress of your deployment.

The process of printing the report you need in Project 2000 can be as simple as clicking a button or as refined as creating and previewing custom reports. But, no matter how simple or refined the process, printing a view or report consists of essentially the same steps:

  • Select the view or report that best presents the information you want. If a standard view or report does not meet your exact information needs, you can apply different tables or filters, or change the way items are grouped or sorted.

  • Make display changes to the view or report if you want. For example, you may want to add your company's logo to the top of each page, include the project name at the bottom of every page, or scale information to fit on a single page.

  • Print the view or report. To make printing as efficient as possible, you can specify the options you want. For example, you can print a range of pages (defined by page numbers or dates), suppress (not print) blank pages, and print multiple copies.

You can preview a view or report before it's printed. Previewing a report can help you verify content and display changes you made so you can adjust them again if necessary.

Cc751340.p601(en-us,TechNet.10).gif

Use Project 2000 to generate status reports, such as Unstarted Tasks, which lists tasks that haven't yet started, their durations, predecessor tasks, start and finish dates, resources, and assignments, all sorted by start date.

To print a report

  1. On the View menu, click Reports.

  2. Click the report type you want, and then click Select.

    Cc751340.p602(en-us,TechNet.10).gif

    The Reports dialog box shows the type of reports you can create. To create a custom report, click Custom.

  3. Click the report you want to print, and then click Select.

    Or to customize predefined settings, click Edit, make the necessary changes, click OK, and then click Select.

  4. If you want to change the appearance of your report pages, click Page Setup, make the necessary adjustments, and then click Print Preview to see what you've changed.

  5. Click Print.

    Tip You can print any report without previewing it. On the View menu, click Reports, click Custom, and then click Select. In the Reports list, click the report you want to print, and then click Print. Make changes to the print options if needed, and then click OK.

Visualize your deployment progress

You can use Visio 2000 to visualize your deployment in timeline form with milestones and events of the deployment process. Timelines are particularly useful for showing a sequence of events in a process, a history of events, or a summary of a more complex project timeline or Gantt chart.

Cc751340.p603(en-us,TechNet.10).gif

Use a timeline to help upper management visualize your deployment progress.

To create a timeline

  1. On the File menu, point to New, point to Project Schedule, and then click Timeline to open the Timeline solution.

  2. Drag a timeline shape onto the drawing page from the Timeline Shapes stencil, and then configure the timeline using the Configure Timeline dialog box.

    p604

    Set the date range, scale, and format of the timeline in the Configure Timeline dialog box. To change this information at any other time, right-click the timeline, and then choose Configure Timeline.

  3. Drag milestone and interval shapes onto the timeline to illustrate important events and processes on your timeline, and then configure them using the Configure Milestones dialog box.

    p605

    The milestone is positioned on the timeline using the milestone date you chose. To change this information at any other time, right-click the milestone, and then choose Configure Milestone.

    Note: If you checked the Automatically Update Dates When Markers Are Moved box in the Configure Timeline dialog box, the dates on your marker, milestone, and interval shapes are automatically updated when you move them.

  4. Drag Today Marker or Elapsed Time shapes onto the timeline to illustrate the current date and elapsed time.

Phase 7: Post-implementation review

This is the final phase of your Microsoft Windows 2000 deployment project. During this phase, review the project and document the lessons learned to provide a foundation for future deployment projects or post-implementation directives. Include in this review the review of your project plan that you created with Microsoft Project 2000 and the diagrams you created using Microsoft Visio 2000. Decide how to reuse the data in your project plan and your diagrams.

Review your project plan and reuse the data

The end of a project is an opportunity to gather and record project information and share it with others. It is the time to answer questions like:

  • Was the project mission completed?

  • Was the work on time, within budget, and by specifications?

  • What can we do to improve future projects?

  • Were the stakeholders satisfied?

This is also the time for administrative closure and contract closeout. Administrative closure includes verifying scope, archiving or maintaining project information, and producing summary information such as cost, work, and tasks. Contract closeout ensures that the contractors' final work is completed and delivered and that billings or invoices are complete. At contract closeout, it's important to review schedules, changes, and contractor performance.

After you review your project plan and data, you may decide to reuse the plan and data for future projects. You can reuse your data by saving your Project 2000 file as a template.

To save your project plan as a project template

  1. On the File menu, click Save As.

  2. In the Save in box, select the drive and folder where you want to save the template.

  3. In the File name box, type a name for the template.

  4. In the Save as type box, click Template.

  5. Click Save.

  6. Select the check boxes for data you want to remove from your project file.

  7. Click Save.

Review your Visio diagrams and create current computing environment diagrams

You've reached the end of the project and your Windows 2000 environment is in place. At this point, you'll begin creating diagrams that represent your new computing environment, or reuse current diagrams as templates on which to base new diagrams. When you know that you'll be creating multiple drawing files that need a consistent look, you can create a template on which to base them. Templates eliminate the need to open the appropriate stencils, create styles, and establish page settings for each drawing file, because they are all contained in one place.

To save a Visio diagram as a template

  1. On the File menu, click Save As.

  2. Type the name of the file and navigate to the location in which you want to save the file.

    Tip If you want the template to appear in the list that is displayed on the New submenu, save it in the Solutions folder or one of its subfolders.

  3. In the Save as type box, click Template (*.vst).

  4. Click Save.

Summary

You've seen how you can use Microsoft Project 2000, Microsoft Project Central, and Microsoft Visio 2000 products, such as Visio 2000 Enterprise, to manage your project, collaborate with team members, and visualize your computing environment through every phase of your Microsoft Windows 2000 deployment. These tools help you simplify complex processes, organizations, and systems throughout your company. Not only do they assist in deploying Windows 2000, they make useful tools for managing and visualizing your new Windows 2000 environment.

Additional Information

For more information about deploying Microsoft Windows 2000, read the Deployment Planning Guide and the Windows 2000 Enterprise Planning Workbook.

For more information about Microsoft Active Directory, visit the Microsoft Windows 2000 Server Technology Center.

For more information about Microsoft Project 2000, visit http://www.microsoft.com/office/previous/project/2000tour/default.asp.

For more information about Microsoft Project Central, visit http://office.microsoft.com/home/office.aspx?assetid=FX01085795.

For more information about Microsoft Visio 2000 products, visit http://www.microsoft.com/office/visio/prodinfo/default.mspx.