Supported OS versions for Configuration Manager consoles

Applies to: System Center Configuration Manager (Current Branch)

To support the Configuration Manager console, the following OS versions require a minimum .NET Framework version of 4.5.2. The exception is Windows 10, which requires a minimum of .NET Framework 4.6.

  • Windows Server 2019: Standard, Datacenter (starting in version 1810)

  • Windows Server 2016: Standard, Datacenter

  • Windows Server 2012 R2 (x64): Standard, Datacenter

  • Windows Server 2012 (x64): Standard, Datacenter

  • Windows Server 2008 R2 with SP1 (x64): Standard, Enterprise, Datacenter

  • Windows 10 (x86, x64): Pro, Enterprise

  • Windows 8.1 (x86, x64): Professional, Enterprise

  • Windows 7 with SP1 (x86, x64): Professional, Enterprise, Ultimate

For more information about the Configuration Manager console, see the following articles: