AppPrerequisite element (AppPrerequisiteCollection complexType)

(SharePoint Add-in Manifest)

Applies to: SharePoint Add-ins | SharePoint Foundation 2013 | SharePoint Server 2013

Identifies a SharePoint Feature or capability that the add-in depends on. The SharePoint Add-ins installation infrastructure checks to see if the Feature or capability is present and activated. If it is not, installation of the add-in is blocked.

Note

The string app appears as part of or all of some element, attribute, and file names because SharePoint Add-ins were originally called "apps for SharePoint." To ensure backward compatibility, the schemas have not been changed.

    <AppPrerequisite Type="type_name " ID="feature/capability_guid_or_autohosted_component_type" MinimumVersion="n.n.n.n" />

Element information

Element type

AppPrerequisite

Namespace

http://schemas.microsoft.com/sharepoint/2012/app/manifest

Schema file

appmanifest.xsd

Definition

    <xs:element name="AppPrerequisite" type="AppPrerequisite" maxOccurs="500"></xs:element>     

Elements and attributes

If the schema defines specific requirements, such as sequence, minOccurs, maxOccurs, and choice, see the definition section.

Parent elements

Element

Type

Description

AppPrerequisites

AppPrerequisiteCollection

A list of prerequisites that a SharePoint Add-in depends on.


Child elements

None.


Attributes

Attribute

Type

Required

Description

Possible values

ID

xs:string

required

The ID that identifies a Feature or capability that the SharePoint Add-in depends on.

Varies depending on the value of the Type attribute.

If Type is Feature, the ID is the bracketed, hyphenated GUID of the Feature; for example {151D22D9-95A8-4904-A0A3-22E4DB85D1E0}.

If Type is Capability, the ID is one of the GUIDs in the following table. The hyphens are required.

Capability

Value

Access Services 2010

B2CEA5EF-26FF-4147-9074-731FE605F068

Access Services

7CC11180-92E4-49F4-AF68-A55CA440E761

Managed Metadata Web Service

8F32AE42-D7AA-4DBA-AF25-A9ED92468261

PowerPoint Services

0C92DF0B-8D97-4D7B-BD87-7D5A4F0C89AA

Secure Store Services

D4FAB6DC-93EA-48AB-B5DD-CCD9F2FC4E1C

Machine Translation Service

A5760A6E-47B1-4F31-B964-1C3F72020DBC

User Profile Service

A83C8D70-71DE-4260-9FB8-677418EB47F2

Visio Graphics Service

778D6B91-D46F-40E6-B7A4-1C666B800D03

Work Management Service

5E49F681-D570-4C2B-8A50-84D5F38E2A12

Duet

4F2DB42F-1AE3-4674-8E0B-2C125F9CAD4F

SharePoint Workflow Services

CDD8F991-B459-4512-8048-03D5A03FF27E

Search

132084D8-5DA6-4EAB-A636-3ADF44151846

EDU

89109E3B-2BF0-4262-A2F4-CEB7A3DECE21

MinimumVersion

VersionDefinition

optional

The minimum version of the feature or capability that the SharePoint Add-in depends on, for example 15.0.0.0.

Values of the VersionDefinition type.

Type

AppPrerequisiteTypeDefinition

required

The type of add-in prerequisite.

Values of the AppPrerequisiteTypeDefinition type, either Feature or Capability. (Autoprovisioning is not a supported value at this time.)