Event ID 8306 when you activate Security Token Service Application

Symptoms

In SharePoint Foundation 2010, you may experience one or more of the following symptoms:

Cause

This problem can be caused if one or more of the following conditions are true:

  • The .NET trust level for the secure token service is not set to "Full" in IIS.
  • The application pool for the secure token service is not started or is using invalid credentials.

Resolution

​In order to resolve this problem, you can try one of the following possible solutions:

  • From IIS Manager, click on the SecureTokenServiceApplication. In the "Features View", double click on .NET Trust Levels. Ensure that the trust level is set to "Full"
  • From IIS Manager, ensure that the application pool for SecureTokenServiceApplication is running. By default, the name of the application pool is SecureTokenServiceApplicationPool.