Error when you try to reset your password in Azure, Office 365, or Intune: We could not verify your account

This article describes a problem in which you receive an error message "We could not verify your account" when you try to reset your password in Microsoft Azure, Office 365, or Microsoft Intune. To resolve this problem, work with your administrator to update your telephone number.

Original product version:   Microsoft Entra ID, Microsoft Intune, Cloud Services (Web roles/Worker roles)
Original KB number:   2951246

Symptoms

When you use Microsoft Azure, Microsoft Office 365, or Microsoft Intune, you may receive the following error message when you try to reset your password:

We could not verify your account.

Cause

This problem may occur because there are no telephone numbers on file for you.

Resolution

To resolve this problem, work with your administrator to update your telephone number(s).

Contact us for help

If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.