Azure Virtual Desktop sign-in screen is blank

Azure Virtual Desktop users might encounter sign-in issues that result in a black screen. There are multiple possible causes for black screens, but users can be impacted from issues synchronizing with AppReadiness, and multiple sessions signing in or out.

Note

These sign-in issues may also occur in the RDS environment, where user profiles are created every sign-in and deleted every sign-out.

Causes

The following list contains known scenarios causing black screens, and the non-security fixes which address them. This list does not cover every possible reason a black screen can occur. Verify that you have the latest updates, as blank screen updates are being released on a near-monthly basis.

Issue Version of Windows Article #
The AppReadiness service sometimes fails to shut down waiting for some COM objects to disconnect. Resulting in failed user sign-in or black screen in WVD scenario. Windows 2004 October 1, 2020—KB4577063 (OS Build 19041.546) Preview (microsoft.com)
Windows 1909 & 1903 September 16, 2020—KB4577062 (OS Builds 18362.1110 and 18363.1110) Preview (microsoft.com)
Windows 1809 September 16, 2020—KB4577069 (OS Build 17763.1490) Preview (microsoft.com)
Addresses an issue where the WVD user might experience a blank screen during sign-in. Windows 2004 November 30, 2020—KB4586853 (OS Builds 19041.662 and 19042.662) Preview (microsoft.com)
Windows 1909 & 1903 November 19, 2020—KB4586819 (OS Builds 18362.1237 and 18363.1237) Preview (microsoft.com)
Windows 1809 November 19, 2020—KB4586839 (OS Build 17763.1613) Preview (microsoft.com)
Addresses an issue that displays a black screen to Azure Virtual Desktop users when they attempt to sign in. 1909 &1903 October 20, 2020—KB4580386 (OS Builds 18362.1171 and 18363.1171) Preview (microsoft.com)
Windows 1809 October 20, 2020—KB4580390 (OS Build 17763.1554) Preview (microsoft.com)
Desktop gets a black screen due to shell not starting AppXSvc deadlock. Addresses an issue that displays a black screen to Azure Virtual Desktop users when they attempt to sign in. Windows 2004 September 3, 2020—KB4571744 (OS Build 19041.488) Preview (microsoft.com)
Windows 1909 & 1903 April 21, 2020—KB4550945 (OS Builds 18362.815 and 18363.815) (microsoft.com)
Windows 1809 April 21, 2020—KB4550969 (OS Build 17763.1192) (microsoft.com)

Resolution

Note

Workarounds should not be considered long-term solutions. Back up your registry keys anytime that you test changes. If the black screen is tied with AppReadiness issues, set the following registry entries for the AppReadiness pre-shell task, and then change the first sign-in’s timeout window to 30 seconds to avoid the black screen for the first user’s sign-in.

Registry Location Data Type Value New timeout duration
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AppReadinessPreShellTimeoutMs Data Type: DWORD Value: 0x7530 30000 ms = 30s
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\FirstLogonTimeout Data Type: DWORD Value: 0x1e 30000 ms = 30s
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\DelayedDesktopSwitchTimeout Data Type: DWORD Value: 0x1e 30000 ms = 30s

More Information

If you continue to see black screens after you confirm that you have the latest updates, perform a full memory dump and include it in a support case.

Find the steps to enable and collect a dump file at Collect an OS memory dump