Internet Explorer cannot display an HTTPS site when SSL 2.0 and TLS 1.2 are selected

This article provides a solution for Internet Explorer unable to display HTTPS websites.

Original product version:   Internet Explorer 9 and later versions
Original KB number:   2851628

Symptoms

Assume that you select SSL 2.0 and TLS 1.2 in the Internet Explorer 11 security settings. When you try to access an HTTPS website in Internet Explorer, you receive the following error message:

Internet Explorer cannot display the webpage

Cause

The issue occurs because SSL 2.0 and TLS 1.2 are not compatible with each other in Internet Explorer 9 and later versions.

Resolution

To use client-side certificates to establish an HTTPS connection over TLS 1.2, you must disable SSL 2.0. For more information about how to do this, see Change security and privacy settings for Internet Explorer 11.

Note

SSL 2.0 is disabled by default.