Troubleshoot issues with forecasting
This article helps you troubleshoot and resolve issues related to forecasting.
Issue 1 - An error is displayed when you try to create a territory-based forecast
Symptom
When you try to create a territory-based forecast, an error is displayed. Also, the data in a territory-based forecast might not be refreshed.
Cause
When system updates are performed, the territory entity's hierarchy is disabled (though you've enabled it earlier), which causes this error.
Resolution
To resolve this issue, you must enable hierarchy in the territory_parent_territory relationship definition from Relationships. Follow these steps:
Go to Advance settings.
The advance settings page opens in a tab.
Select Settings > Customization > Customizations.
The Power Apps settings page opens.
Select Data > Entities, and then select Territory.
On the Territory page, select the Relationships tab, and then select Parent.
In the Many-to-one dialog box, select the Hierarchical check box, and then select Done.
Save and close the entity.
Issue 2 - Can't hide the forecast category field in opportunity forms
Cause
Sometimes, the app displays the Forecast category field in opportunity forms, even after it has been configured as invisible by default through form customizations.
Resolution
To resolve this error, you must delete the Forecast category field from the form. Follow these steps:
In your app, on the nav bar, select the Settings icon, and then select Advanced Settings.
The Business Management settings page opens in a new browser tab.
On the nav bar, select Settings, and then under Customization, select Customizations.
Select Customize the System.
Under Components in the solution explorer, expand Entities, expand Opportunity, and then select Forms.
Open the Opportunity form of form type Main.
The opportunity form opens in a new window.
In the Summary section, select the Forecast category field, and then select Remove.
Save and publish the configuration.
Issue 3 - Can't view forecasts
Cause
If you were using the previous version of forecasting and updated to the latest, the forecasting site map might not be updated. This can be caused by the presence of an unmanaged layer of the Sales Hub app, which would allow the forecasting site map to open the previous version of forecasting.
The following image is an example of the previous version of forecasting home page.
Resolution
To resolve this issue, update the forecasting site map entry to the latest forecast entry grid. For more information, see Add forecast grid and configuration options in site map.
Issue 4 - Can't load the forecast grid and an error is displayed
Cause
The ForecastInstanceActions process is deactivated. The reason might be that the owner of an organization has changed, which is causing the failure to load the forecast grid. The error shown in the following image is displayed.
Action (ForecastInstanceActions) for fetching forecasts has been disabled.
Resolution
To resolve this error, activate the ForecastInstanceActions process. Follow these steps:
Go to Advanced settings, and then select Settings > Process Center > Processes.
In the search box, enter ForecastInstanceActions. You can see that the process is in the Draft state.
Select the process, and then select Activate.
On the confirmation message, select Activate.
Verify that the process state is Activated, and then close Settings.
Issue 5 - Can't view drill down data in a forecast grid
Cause
You don’t have enough privileges for Forecast Configuration entity to view drill down data in the forecast grid. The error shown in the following image is displayed.
Something went wrong.
There was an error in retrieving the forecast records.
Please reload the browser page again.
Resolution
To resolve this error, your administrator must provide read privileges on Forecast Configuration entity to your security role. Follow these steps:
Go to Advanced settings, and then select Settings > Security > Security Roles.
Select the security role for which you want to apply the privileges.
On the security role page, select Custom Entities tab and go to Forecast Configuration row.
Select and provide the read privileges.
Close the settings.
Issue 6 - Forecast category fields aren't updated
Cause
In a forecast, after updating the forecast category field to Won or Lost, the opportunities are still appearing in the previous pipeline bucket. This error is occurring due to the Opportunity Forecast Category Mapping Process workflow is disabled in your organization.
Resolution
To resolve the error, activate the Opportunity Forecast Category Mapping Process workflow. Follow these steps:
Go to Advanced settings, and then select Settings > Customizations > Customize the System.
From the sitemap, select Processes.
Select the Opportunity Forecast Category Mapping Process workflow and select Activate.
The forecast categories in the opportunities will be updated properly. For opportunities that were changed before activating the workflow must be manually changed. Also, open the Opportunity Forecast Category Mapping Process workflow and verify that the conditions are properly defined for each forecast category.
Save and close the settings.