IAzAuthorizationStore3::IsFunctionalLevelUpgradeSupported method (azroles.h)

The IsFunctionalLevelUpgradeSupported method gets a Boolean value that indicates whether the version of this authorization store can be upgraded.

Syntax

HRESULT IsFunctionalLevelUpgradeSupported(
  LONG         lFunctionalLevel,
  VARIANT_BOOL *pbSupported
);

Parameters

lFunctionalLevel

The version to check. Set this parameter to AZ_AZSTORE_NT6_FUNCTION_LEVEL.

pbSupported

VARIANT_TRUE if the underlying authorization store supports version 2 functionality; otherwise, VARIANT_FALSE.

Return value

If the method succeeds, it returns S_OK.

If the method fails, it returns an error code. For a list of common error codes, see Common HRESULT Values.

Requirements

   
Minimum supported client Windows Vista [desktop apps only]
Minimum supported server Windows Server 2008 [desktop apps only]
Target Platform Windows
Header azroles.h

See also

IAzAuthorizationStore3

UpgradeStoresFunctionalLevel