AutomaticUpdatesPermissionType Enumeration

Defines the possible ways to set the NotificationLevel property of the IAutomaticUpdatesSettings interface or the IncludeRecommendedUpdates property of the IAutomaticUpdatesSettings2 interface.

Syntax

typedef enum tagAutomaticUpdatesPermissionType {
  auptSetNotificationLevel,
  auptDisableAutomaticUpdates,
  auptSetIncludeRecommendedUpdates,
  auptSetFeaturedUpdatesEnabled,
  auptSetNonAdministratorsElevated
} AutomaticUpdatesPermissionType;

Constants

auptSetNotificationLevel The ability to set the IAutomaticUpdatesSettings::NotificationLevel property.
auptDisableAutomaticUpdates The ability to set the IAutomaticUpdatesSettings::NotificationLevel property to aunlDisabled.
auptSetIncludeRecommendedUpdates The ability to set the IAutomaticUpdatesSettings2::IncludedRecommendedUpdates property.
auptSetFeaturedUpdatesEnabled The ability to set the IAutomaticUpdatesSettings3::FeaturedUpdatesEnabled property.
auptSetNonAdministratorsElevated The ability to set the IAutomaticUpdatesSettings3::NonAdministratorsElevated property.

Remarks

Featured update notifications are only supported on Windows Vista and above. On Windows XP systems running versions of the Windows Update Agent (WUA) that support IAutomaticUpdatesSettings3, the IAutomaticUpdatesSettings3::FeaturedUpdatesEnabled value will always be VARIANT_FALSE, and attempting to alter its value will result in an error.

Featured update notifications are only supported when Automatic Updates is turned on. If Automatic Updates is set to “Never check for updates (not recommended),” then the IAutomaticUpdatesSettings3::FeaturedUpdatesEnabled value will always be VARIANT_FALSE, and attempting to alter its value will result in an error.

Featured update notifications are only supported on certain update services. Currently, the only supported update service is Microsoft Update. If Automatic Updates is currently configured to receive updates from another service (from Windows Update, or from a WSUS server), then the IAutomaticUpdatesSettings3::FeaturedUpdatesEnabled value will always be VARIANT_FALSE, and attempting to alter its value will result in an error.

Requirements

   
Minimum supported client Windows XP, Windows 2000 Professional with SP3 [desktop apps only]
Minimum supported server Windows Server 2003, Windows 2000 Server with SP3 [desktop apps only]
Header wuapi.h