No se puede abrir una carpeta compartida en Outlook en la Web en Exchange Server

Síntomas

Considere los escenarios siguientes:

Escenario 1

  • Ha coexistido Microsoft Exchange Server 2016 o Exchange Server 2013 en un entorno de Exchange Server 2010.
  • User1 tiene un buzón en Exchange Server 2016 o Exchange Server 2013.
  • User2 tiene un buzón en Exchange Server 2010.
  • User1 tiene permisos de acceso completo al buzón para User2.

Escenario 2

  • Tiene un entorno híbrido de Microsoft 365.
  • User1 tiene un buzón en la nube.
  • User2 tiene un buzón de correo local.
  • User1 tiene permisos de acceso completo al buzón para User2.

En estos escenarios, User1 no puede expandir el buzón para User2 después de que User1 haya agregado el buzón mediante la opción Agregar carpeta compartida . Además, User1 recibe el siguiente mensaje de error:

No se puede completar la solicitud.
Es posible que no tenga permiso para realizar esta acción.

Nota En el escenario 2, si User1 tiene un buzón local y User2 tiene un buzón en la nube (es decir, independientemente del entorno que hospede el buzón), User1 no puede expandir el buzón para User2.

Causa

La solicitud AddSharedFolder se realiza correctamente y agrega el buzón compartido a la lista de carpetas. Sin embargo, la solicitud para expandir el buzón compartido se envía por proxy al servidor de buzones para el usuario. Esto desencadena un mensaje "WrongServerVersionException" y un estado de HTTP 500 . La respuesta HTTP puede incluir lo siguiente:

 {"Body":{"ErrorCode":500,"ExceptionName":"WrongServerVersionException","FaultMessage":"The Client Access server version doesn't match the Mailbox server version of the resource that was being accessed. To determine the correct URL to use to access the resource, use Autodiscover with the address of the resource.", "IsTransient":false,"StackTrace":"Microsoft.Exchange.Services.Core.Types.WrongServerVersionException: The Client Access server version doesn't match the Mailbox server version of the resource that was being accessed. To determine the correct URL to use to access the resource, use Autodiscover with the address of the resource. \u000d\u000a at Microsoft.Exchange.Services.Core.Types.StoreSessionCacheBase.ConnectOnce(ExchangePrincipal mailboxToAccess, CallContext callContext, Boolean unifiedLogon)\u000d\u000a at

Solución alternativa

Para solucionar este problema, use la opción Abrir otro buzón en Outlook en la Web para abrir un buzón compartido donde tenga permiso de acceso completo. Nota: Esto generará un vínculo de redirección y un símbolo del sistema de credenciales antes de poder acceder al buzón. Para obtener más información, lea la sección Permisos de buzón admitidos en entornos híbridos de este artículo.