Crear y depurar complementos de Office en Visual StudioCreate and debug Office Add-ins in Visual Studio

Este artículo explica cómo usar Visual Studio 2019 para crear un complemento de Office para Word, Excel, PowerPoint o Outlook y depurar el complemento en el cliente de escritorio de Office en Windows.This article describes how to use Visual Studio 2019 to create an Office Add-in for Excel, Word, PowerPoint, or Outlook and debug the add-in in the Office desktop client on Windows. Si usa otra versión de Visual Studio, los procedimientos pueden variar ligeramente.If you're using another version of Visual Studio, the procedures might vary slightly.

Nota

Visual Studio no admite la creación de complementos de Office para OneNote o Project, pero puede usar el generador Yeoman de complementos de Office para crear estos tipos de complementos.Visual Studio does not support creating Office Add-ins for OneNote or Project, but you can use the Yeoman generator for Office Add-ins to create these types of add-ins.

Requisitos previosPrerequisites

Crear un proyecto de complemento en Visual StudioCreate the add-in project in Visual Studio

Comience por seguir estos tres pasos y, a continuación, complete los pasos de la siguiente sección que corresponden al tipo de complemento que está creando.Start by completing these three steps, and then complete the steps in the following section that corresponds to the type of add-in you're creating.

  1. Abra Visual Studio y, en la barra de menu de Visual Studio, seleccione Crear un nuevo proyecto.Open Visual Studio and from the Visual Studio menu bar, choose Create a new project.

  2. Usando el cuadro de búsqueda, escribaComplementos y, después elija el tipo de proyecto de complemento que quiere crearUsing the search box, enter Add-ins, then choose the type of add-in project you want to create.

  3. Asigne un nombre al proyecto y luego seleccione Aceptar.Name the project, and then choose OK.

Complemento web de Word o complemento web de OutlookWord Web Add-in or Outlook Web Add-in

Si ha elegido crear un complemento web de Word o un complemento web de Outlook, Visual Studio crea una solución y sus dos proyectos aparecen en el Explorador de soluciones.If you've chosen to create a Word Web Add-in or an Outlook Web Add-in, Visual Studio creates a solution and its two projects appear in Solution Explorer. A continuación, puede explorar la solución de Visual Studio.Next, you can explore the Visual Studio solution.

Complemento web de PowerPointPowerPoint Web Add-in

Si ha elegido crear un complemento web de PowerPoint, aparecerá el cuadro de diálogo Crear complemento de Office.If you've chosen to create a PowerPoint Web Add-in, the Create Office Add-in dialog appears.

  • Para crear un complemento de panel de tareas, seleccione Agregar nuevas funcionalidades a PowerPoint y, a continuación, haga clic en el botón Finalizar para crear la solución de Visual Studio.To create a task pane add-in, select Add new functionalities to PowerPoint and then choose the Finish button to create the Visual Studio solution.

  • Para crear un complemento de contenido, seleccione Insertar contenido en diapositivas de PowerPoint y, a continuación, haga clic en el botón Finalizar para crear la solución de Visual Studio.To create a content add-in, select Insert content into PowerPoint slides and then choose the Finish button to create the Visual Studio solution.

A continuación, puede explorar la solución de Visual Studio.Next, you can explore the Visual Studio solution.

Complemento web de ExcelExcel Web Add-in

Si ha elegido crear un complemento web de Excel, aparecerá el cuadro de diálogo Crear complemento de Office.If you've chosen to create an Excel Web Add-in, the Create Office Add-in dialog appears.

  • Para crear un complemento de panel de tareas, seleccione Agregar nuevas funcionalidades a Excel y, a continuación, haga clic en el botón Finalizar para crear la solución de Visual Studio.To create a task pane add-in, select Add new functionalities to Excel and then choose the Finish button to create the Visual Studio solution.

  • Para crear un complemento de contenido, seleccione Insertar contenido en hojas de cálculo de Excel, haga clic en el botón Siguiente, elija una de las siguientes opciones y, a continuación, haga clic en el botón Finalizar para crear la solución de Visual Studio:To create a content add-in, select Insert content into Excel spreadsheets, choose the Next button, select one of the following options, and then choose the Finish button to create the Visual Studio solution:

    • Complemento básico: crear un proyecto de complemento de contenido con el mínimo código de iniciaciónBasic Add-in - to create a content add-in project with minimal starter code

    • Complemento de visualización de documentos: crear un proyecto de complemento de contenido con código de iniciación para visualizar y enlazar a datosDocument Visualization Add-in - to create a content add-in project with starter code to visualize and bind to data

Explorar la solución de Visual StudioExplore the Visual Studio solution

Una vez que haya completado el asistente, Visual Studio crea una solución que contiene dos proyectos.When you've completed the wizard, Visual Studio creates a solution that contains two projects.

ProyectoProject DescripciónDescription
Proyecto de complementoAdd-in project Contiene solo un archivo de manifiesto XML con todas las configuraciones que describen su complemento. Estas configuraciones ayudan al host de Office a determinar cuándo el complemento se debe activar y dónde debe aparecer. Visual Studio genera los contenidos de esta archivo para que usted pueda ejecutar el proyecto y usar el complemento inmediatamente. Puede cambiar la configuración en cualquier momento modificando el archivo XML.Contains only an XML manifest file, which contains all the settings that describe your add-in. These settings help the Office host determine when your add-in should be activated and where the add-in should appear. Visual Studio generates the contents of this file for you so that you can run the project and use your add-in immediately. You change these settings any time by modifying the XML file.
Proyecto de aplicación webWeb application project Contiene las páginas de contenido de su complemento, incluidos todos los archivos y referencias de archivos que necesita para desarrollar HTML compatible con Office y páginas de JavaScript. Mientras desarrolla su complemento, Visual Studio aloja la aplicación web en su servidor local IIS. Cuando esté listo para publicar el complemento, deberá implementar el proyecto de aplicación web en un servidor web.Contains the content pages of your add-in, including all the files and file references that you need to develop Office-aware HTML and JavaScript pages. While you develop your add-in, Visual Studio hosts the web application on your local IIS server. When you're ready to publish the add-in, you'll need to deploy this web application project to a web server.

Modificar las configuraciones de su complementoModify your add-in settings

Para modificar la configuración de su complemento, edite el archivo de manifiesto XML del proyecto del complemento.To modify the settings of your add-in, edit the XML manifest file in the add-in project. En el Explorador de soluciones, expanda el nodo del proyecto del complemento, expanda la carpeta que contiene el manifiesto XML y elija el manifiesto XML.In Solution Explorer, expand the add-in project node, expand the folder that contains the XML manifest, and choose the XML manifest. Puede apuntar a cualquier elemento en el archivo para ver una información sobre herramientas que describe la finalidad del elemento.You can point to any element in the file to view a tooltip that describes the purpose of the element. Para obtener más información sobre el archivo de manifiesto, consulte Manifiesto XML de complementos de Office.For more information about the manifest file, see Office Add-ins XML manifest.

Desarrollar el contenido del complementoDevelop the contents of your add-in

Mientras que el proyecto del complemento le permite modificar las configuraciones que describen su complemento, la aplicación web proporciona el contenido que aparece en el mismo.While the add-in project lets you modify the settings that describe your add-in, the web application provides the content that appears in the add-in.

El proyecto de aplicación web contiene un archivo HTML predeterminado, un archivo de JavaScript y un archivo CSS que puede usar para empezar.The web application project contains a default HTML file, JavaScript file, and CSS file that you can use to get started. Algunos de estos archivos contienen referencias a otras bibliotecas de JavaScript como la API de Javascript para Office.Some of these files contain references to other JavaScript libraries including the JavaScript API for Office. Puede desarrollar el complemento actualizando estos archivos y/o agregando archivos HTML y de JavaScript.You can develop your add-in by updating these files and/or adding more HTML and JavaScript files. La siguiente tabla describe los archivos predeterminados que el proyecto de aplicación web contiene cuando se crea la solución de Visual Studio.The following table describes the default files that the web application project contains when the Visual Studio solution is created.

Nombre de archivoFile name DescripciónDescription
Home.htmlHome.html
(Excel, PowerPoint, Word)(Excel, PowerPoint, Word)

MessageRead.htmlMessageRead.html
(Outlook)(Outlook)
Página HTML predeterminada del proyectoThe default HTML page of the add-in. Esta página aparece como la primera página dentro del complemento al activarlo en un elemento de cita, mensaje de correo electrónico o documento.This page appears as the first page inside of the add-in when it is activated in a document, email message, or appointment item. Este archivo contiene todas las referencias de archivo que necesita para empezar.This file contains all of the file references that you need to get started. Puede empezar a desarrollar el complemento agregando el código HTML a este archivo.You can start developing your add-in by adding your HTML code to this file.
Home.jsHome.js
(Excel, PowerPoint, Word)(Excel, PowerPoint, Word)

MessageRead.jsMessageRead.js
(Outlook)(Outlook)
El archivo de JavaScript asociado con la página Home.html (Excel, PowerPoint, Word) o la página MessageRead.html (Outlook).The JavaScript file associated with the Home.html page (Excel, PowerPoint, Word) or the MessageRead.html page (Outlook). Este archivo debería contener el código que sea específico para el comportamiento de la página Home.html (Excel, PowerPoint, Word) o la página MessageRead.html (Outlook).This file should contain any code that is specific to the behavior of the Home.html page (Excel, PowerPoint, Word) or the MessageRead.html page (Outlook). Este archivo contiene un código de ejemplo para empezar.This file contains some example code to get you started.
Home.cssHome.css
(Excel, PowerPoint, Word)(Excel, PowerPoint, Word)

MessageRead.cssMessageRead.css
(Outlook)(Outlook)
Define los estilos predeterminados para aplicar a su complemento.Defines the default styles to apply to your add-in. Se recomienda usar la Office UI Fabric para el diseño y los estilos.We recommend using the Office UI Fabric for design and styles. Para obtener más información, consulte Office UI Fabric en los complementos de Office.For more information see Office UI Fabric in Office Add-ins.

Nota

No tiene que usar estos archivos.You don't have to use these files. No dude en agregar otros archivos al proyecto y usarlos en su lugar.Feel free to add other files to the project and use those instead. Si desea que otro archivo HTML aparezca como la página inicial del complemento, abra el editor de manifiesto y, a continuación, establezca la propiedad SourceLocation en el nombre del archivo.If you want another HTML file to appear as the initial page of the add-in, open the manifest editor, and then set the SourceLocation property to the name of the file.

Depurar el complementoDebug your add-in

Puede usar Visual Studio para depurar el complemento en el cliente de escritorio de Office en Windows, como se describe en las secciones siguientes:You can use Visual Studio to debug your add-in in the Office desktop client on Windows, as described in the following sections:

Nota

No se puede usar Visual Studio para depurar complementos en Office en la web o en Mac.You cannot use Visual Studio to debug add-ins in Office on the web or Mac. Para obtener información acerca de la depuración en estas plataformas, consulte Depurar complementos de Office en Office Online o Depurar complementos de Office para iPad y MacFor information about debugging on these platforms, see Debug Office Add-ins in Office on the web or Debug Office Add-ins on iPad and Mac

Revisar las propiedades de compilación y depuraciónReview the build and debug properties

Antes de iniciar la depuración, revise las propiedades de cada proyecto para confirmar que Visual Studio abrirá la aplicación de host deseada y que las otras propiedades de compilación y depuración están configuradas correctamente.Before you start debugging, review the properties of each project to confirm that Visual Studio will open the desired host application and that other build and debug properties are set appropriately.

Propiedades de un proyecto de complementoAdd-in project properties

Abra la ventana propiedades del proyecto de complemento para revisar las propiedades del proyecto:Open the Properties window for the add-in project to review project properties:

  1. En el Explorador de soluciones, elija el proyecto del complemento (no el proyecto de la aplicación web).In Solution Explorer, choose the add-in project (not the web application project).

  2. En la barra de menús, elija Ver > Ventana Propiedades.From the menu bar, choose View > Properties Window.

En la tabla siguiente se describen las propiedades del proyecto de complemento.The following table describes the properties of the add-in project.

PropiedadProperty DescripciónDescription
Acción de inicioStart Action Especifica el modo de depuración para el complemento.Specifies the debug mode for your add-in. Actualmente, solo el modo del cliente de escritorio de Office es compatible con los proyectos de complementos de Office.Currently only Office Desktop Client mode is supported for Office Add-in projects.
Documento de inicioStart Document
(Solo complementos de Excel, PowerPoint y Word)(Excel, PowerPoint, and Word add-ins only)
Especifica qué documento debe abrirse cuando inicia el proyecto.Specifies what document to open when you start the project.
Proyecto webWeb Project Especifica el nombre del proyecto web asociado con el complemento.Specifies the name of the web project associated with the add-in.
Dirección de correo electrónicoEmail Address
(Solo complementos de Outlook)(Outlook add-ins only)
Especifica la dirección de correo electrónico de la cuenta de usuario en Exchange Server o Exchange Online con la que quiere probar el complemento de Outlook.Specifies the email address of the user account in Exchange Server or Exchange Online that you want to use to test your Outlook add-in.
Dirección Url de EWSEWS Url
(Solo complementos de Outlook)(Outlook add-ins only)
Dirección URL de Servicios web de Exchange (por ejemplo: https://www.contoso.com/ews/exchange.aspx).Exchange Web service URL (For example: https://www.contoso.com/ews/exchange.aspx).
Dirección Url de OWAOWA Url
(Solo complementos de Outlook)(Outlook add-ins only)
Dirección URL de Outlook en la web (por ejemplo:https://www.contoso.com/owa).Outlook on the web URL (For example: https://www.contoso.com/owa).
Usar la autenticación multifactorUse multi-factor auth
(Solo complementos de Outlook)(Outlook add-ins only)
Valor booleano que indica si se debe usar la autenticación multifactor.Boolean value that indicates whether multi-factor authentication should be used.
Nombre de usuarioUser Name
(Solo complementos de Outlook)(Outlook add-ins only)
Especifica el nombre de la cuenta de usuario en Exchange Server o Exchange Online con la que quiere probar el complemento de Outlook.Specifies the name of the user account in Exchange Server or Exchange Online that you want to use to test your Outlook add-in.
Archivo de proyectoProject File Especifica el nombre del archivo que contiene la compilación, configuración y otra información sobre el proyecto.Specifies the name of the file containing build, configuration, and other information about the project.
Carpeta de proyectoProject Folder La ubicación del archivo de proyecto.The location of the project file.

Nota

Para un complemento de Outlook, puede especificar uno o más valores de las propiedades solo para complementos de Outlook en la ventana Propiedades, pero no es necesario hacerlo.For an Outlook add-in, you may choose to specify values for one or more of the Outlook add-in only properties in the Properties window, but doing so is not required.

Propiedades del proyecto de aplicación webWeb application project properties

Abra la ventana Propiedades del proyecto de aplicación web para revisar las propiedades del proyecto:Open the Properties window for the web application project to review project properties:

  1. En el Explorador de soluciones, elija el proyecto de aplicación web.In Solution Explorer, choose the web application project.

  2. En la barra de menús, elija Ver > Ventana Propiedades.From the menu bar, choose View > Properties Window.

La siguiente tabla describe las propiedades del proyecto de aplicación web más relevantes para proyectos de complementos de Office.The following table describes the properties of the web application project that are most relevant to Office Add-in projects.

PropiedadProperty DescripciónDescription
SSL habilitadoSSL Enabled Especifica si SSL está habilitado en el sitio.Specifies whether SSL is enabled on the site. Debe establecer esta propiedad en True para proyectos de complementos de Office.This property should be set to True for Office Add-in projects.
Dirección URL de SSLSSL URL Especifica la dirección URL HTTPS segura para el sitio.Specifies the secure HTTPS URL for the site. Solo lectura.Read-only.
URLURL Especifica la dirección URL HTTP para el sitio.Specifies the HTTP URL for the site. Solo lectura.Read-only.
Archivo de proyectoProject File Especifica el nombre del archivo que contiene la compilación, configuración y otra información sobre el proyecto.Specifies the name of the file containing build, configuration, and other information about the project.
Carpeta de proyectoProject Folder Especifica la ubicación del archivo de proyecto.Specifies the location of the project file. Solo lectura.Read-only. El archivo de manifiesto que genera Visual Studio durante el tiempo de ejecución se escribe en la carpeta bin\Debug\OfficeAppManifests en esta ubicación.The manifest file that Visual Studio generates at runtime is written to the bin\Debug\OfficeAppManifests folder in this location.

Usar un documento existente para depurar el complementoUse an existing document to debug the add-in

Si tiene un documento que contiene datos de prueba que desea usar al depurar el complemento Excel, PowerPoint o Word, Visual Studio puede configurarse para abrir el documento al iniciar el proyecto.If you have a document that contains test data you want to use while debugging your Excel, PowerPoint, or Word add-in, Visual Studio can be configured to open that document when you start the project. Para especificar un documento existente para usar al depurar el complemento, siga los pasos siguientes.To specify an existing document to use while debugging the add-in, complete the following steps.

  1. En el Explorador de soluciones, elija el proyecto del complemento (no el proyecto de la aplicación web).In Solution Explorer, choose the add-in project (not the web application project).

  2. En la barra de menús, elija Proyecto > Agregar elemento existente.From the menu bar, choose Project > Add Existing Item.

  3. En el cuadro de diálogo Agregar elemento existente, busque y seleccione el documento que quiere agregar.In the Add Existing Item dialog box, locate and select the document that you want to add.

  4. Elija el botón Agregar para agregar el documento al proyecto.Choose the Add button to add the document to your project.

  5. En el Explorador de soluciones, elija el proyecto del complemento (no el proyecto de la aplicación web).In Solution Explorer, choose the add-in project (not the web application project).

  6. En la barra de menús, elija Ver > Ventana Propiedades.From the menu bar, choose View > Properties Window.

  7. En la ventana ** Propiedades**, elija la lista Documento de inicio y seleccione el documento que añadió al proyecto.In the Properties window, choose the Start Document list, and then select the document that you added to the project. El proyecto ya está configurado para iniciar el complemento en ese documento.The project is now configured to start the add-in in that document.

Iniciar el proyectoStart the project

Inicie el proyecto eligiendo Depurar > Iniciar depuración en la barra de menús.Start the project by choosing Debug > Start Debugging from the menu bar. Visual Studio generará automáticamente la solución e iniciará Office para hospedar el complemento.Visual Studio will automatically build the solution and start Office to host your add-in.

Nota

Al iniciar un proyecto de complemento de Outlook, se le pedirán las credenciales de inicio de sesión.When you start an Outlook add-in project, you'll be prompted for login credentials. Si se le pide que inicie sesión varias veces o recibe un error diciendo que no está autorizado, es posible que la autenticación básica esté deshabilitada para las cuentas de su espacio empresarial de Office 365.If you're asked to log in repeatedly or if you receive an error that you are unauthorized, then Basic Auth may be disabled for accounts on your Office 365 tenant. En este caso, intente usar una cuenta de Microsoft en su lugar.In this case, try using a Microsoft account instead. También puede que necesite establecer la propiedad "Usar la autenticación multifactor" como True en el diálogo de propiedades del proyecto Complemento de Outlook en la Web.You may also need to set the property "Use multi-factor auth" to True in the Outlook Web Add-in project properties dialog.

Cuando Visual Studio compila el proyecto lleva a cabo las siguientes tareas:When Visual Studio builds the project it performs the following tasks:

  1. Crea una copia del archivo de manifiesto XML y la agrega al directorio _ProjectName_\bin\Debug\OfficeAppManifests.Creates a copy of the XML manifest file and adds it to _ProjectName_\bin\Debug\OfficeAppManifests directory. La aplicación host consume esta copia cuando se inicia Visual Studio y se depura el complemento.The host application consumes this copy when you start Visual Studio and debug the add-in.

  2. Crea un conjunto de entradas de registro en el equipo que permiten que el complemento aparezca en la aplicación host.Creates a set of registry entries on your computer that enable the add-in to appear in the host application.

  3. Compila el proyecto de aplicación web y lo implementa en el servidor web IIS local (https://localhost).Builds the web application project, and then deploys it to the local IIS web server (https://localhost).

  4. Si es el primer proyecto de complemento que implementa en el servidor web IIS local, puede que se le pida que instale un certificado autofirmado en el almacén de Certificados raíz de confianza del usuario actual.If this is the first add-in project that you have deployed to local IIS web server, you may be prompted to install a Self-Signed Certificate to the current user's Trusted Root Certificate store. Esto es necesario para que IIS Express muestre el contenido de su complemento correctamente.This is required for IIS Express to display the content of your add-in correctly.

Nota

Es posible que la versión más reciente de Office use un control web más reciente para mostrar el contenido del complemento cuando se ejecuta en Windows 10.The latest version of Office may use a newer web control to display the add-in contents when running on Windows 10. Si es el caso, Visual Studio puede pedirle que agregue una exención de bucle de red local.If this is the case, Visual Studio may prompt you to add a local network loopback exemption. Esto es necesario para que el control web en la aplicación host de Office pueda acceder al sitio web que se implementa en el servidor web IIS local.This is required for the web control, in the Office host application, to be able to access the website deployed to the local IIS web server. También puede cambiar esta configuración en cualquier momento en Visual Studio en Herramientas > Opciones > Herramientas de Office (Web) > Depuración de complemento web.You can also change this setting anytime in Visual Studio under Tools > Options > Office Tools (Web) > Web Add-In Debugging.

Luego, Visual Studio lleva a cabo las acciones siguientes:Next, Visual Studio does the following:

  1. Modifica el elemento SourceLocation del archivo de manifiesto XML al reemplazar el token ~remoteAppUrl con la dirección completa de la página de inicio (por ejemplo, https://localhost:44302/Home.html).Modifies the SourceLocation element of the XML manifest file by replacing the ~remoteAppUrl token with the fully qualified address of the start page (for example, https://localhost:44302/Home.html).

  2. Inicia el proyecto de aplicación web en IIS Express.Starts the web application project in IIS Express.

  3. Abre la aplicación host.Opens the host application.

Visual Studio no muestra los errores de validación en la ventana OUTPUT al crear el proyecto.Visual Studio doesn't show validation errors in the OUTPUT window when you build the project. Visual Studio informa de errores y advertencias en la ventana ERRORLIST mientras se producen.Visual Studio reports errors and warnings in the ERRORLIST window as they occur. Visual Studio también informa de los errores de validación mostrando líneas onduladas de diferentes colores en el editor de texto y código.Visual Studio also reports validation errors by showing wavy underlines (known as squiggles) of different colors in the code and text editor. Estas marcas le notificarán sobre problemas que Visual Studio haya detectado en el código.These marks notify you of problems that Visual Studio detected in your code. Para obtener más información sobre cómo habilitar o deshabilitar la validación, consulte Opciones, Editor de texto, JavaScript, IntelliSense.For more information about how to enable or disable validation, see Options, Text Editor, JavaScript, IntelliSense.

Para revisar las reglas de validación del archivo de manifiesto XML en su proyecto, consulte Manifiesto XML de complementos para Office.To review the validation rules of the XML manifest file in your project, see Office Add-ins XML manifest.

Depurar el código de un complemento de Excel, PowerPoint o WordDebug the code for an Excel, PowerPoint, or Word add-in

Si el complemento no está visible en el documento que se muestra en la aplicación de host (Excel, PowerPoint o Word) una vez que haya iniciado el proyecto, inicie manualmente el complemento de la aplicación host.If your add-in isn't visible within the document that's displayed in the host application (Excel, PowerPoint, or Word) after you've started the project, manually launch the add-in in the host application. Por ejemplo, inicie el complemento de panel de tareas usado el botón Mostrar panel de tareas en la cinta de opciones de la pestaña Inicio. Una vez que el complemento se muestre en Excel, PowerPoint o Word, puede depurar el código con este procedimiento:For example, launch your task pane add-in by choosing the Show Taskpane button in the ribbon of the Home tab. After your add-in is displayed in Excel, PowerPoint, or Word, you can debug your code by doing the following:

  1. En Excel, PowerPoint o Word, seleccione la pestaña Insertar y, a continuación, haga clic en la flecha hacia abajo situada a la derecha de Mis complementos.In Excel, PowerPoint, or Word, choose the Insert tab and then choose the down-arrow located to the right of My Add-ins.

    Cinta de opciones Insertar en Excel en Windows con la flecha de Mis complementos resaltada

  2. En la lista de complementos disponibles, busque la sección de complementos para desarrolladores y seleccione el complemento para registrarlo.In the list of available add-ins, find the Developer Add-ins section and select the your add-in to register it.

  3. En Visual Studio, establezca los puntos de interrupción en el código.In Visual Studio, set breakpoints in your code.

  4. En Excel, PowerPoint o Word, interactúe con el complemento.In Excel, PowerPoint, or Word, interact with your add-in.

  5. Cuando se alcancen los puntos de interrupción en Visual Studio, recorra el código según sea necesario.As breakpoints are hit in Visual Studio, step through the code as needed.

Puede cambiar el código y revisar los efectos de esos cambios en el complemento sin tener que cerrar la aplicación host y reiniciar el proyecto.You can change your code and review the effects of those changes in your add-in without having to close the host application and restart the project. Después de guardar los cambios en el código, simplemente vuelva a cargar el complemento en la aplicación host.After you save changes to your code, simply reload the add-in in the host application. Por ejemplo, vuelva a cargar un complemento de panel de tareas, haciendo clic en la esquina superior derecha del panel de tareas para activar el Menú de personalidad y haciendo clic en Volver a cargar.For example, reload a task pane add-in by choosing the top-right corner of the task pane to activate the personality menu and then choose Reload.

Depurar el código de un complemento de OutlookDebug the code for an Outlook add-in

Una vez haya iniciado el proyecto y Visual Studio haya iniciado Outlook para hospedar el complemento, abra un elemento de cita o mensaje de correo electrónico.After you've started the project and Visual Studio launches Outlook to host your add-in, open an email message or appointment item.

Outlook activa la complemento para el elemento siempre que se cumplan los criterios de activación. La barra de la complemento aparece en la parte superior de la ventana del inspector o el panel de lectura, y el complemento de Outlook aparece como un botón en la barra de la complemento. Si el complemento tiene un comando de complemento, aparecerá un botón en la cinta de opciones, ya sea en la pestaña predeterminada o en una pestaña personalizada especificada, y el complemento no aparecerá en la barra del complemento.Outlook activates the add-in for the item as long as the activation criteria are met. The add-in bar appears at the top of the Inspector window or Reading Pane, and your Outlook add-in appears as a button in the add-in bar. If your add-in has an add-in command, a button will appear in the ribbon, either in the default tab or a specified custom tab, and the add-in will not appear in the add-in bar.

Para ver el complemento de Outlook, elija el botón para su complemento de Outlook.To view your Outlook add-in, choose the button for your Outlook add-in. Después de que el complemento se muestre en Outlook, puede depurar el código siguiendo este procedimiento:After your add-in is displayed in Outlook, you can debug your code by doing the following:

  1. En Visual Studio, establezca los puntos de interrupción en el código.In Visual Studio, set breakpoints in your code.

  2. En Outlook, interactúe con el complemento.In Outlook, interact with your add-in.

  3. Cuando se alcancen los puntos de interrupción en Visual Studio, recorra el código según sea necesario.As breakpoints are hit in Visual Studio, step through the code as needed.

Puede cambiar el código y revisar los efectos de esos cambios en el complemento sin tener que cerrar Outlook y reiniciar el proyecto.You can change your code and review the effects of those changes in your add-in without having to close Outlook and restart the project. Después de guardar los cambios en el código, basta con abrir el menú contextual para el complemento (en Outlook) y, después, hacer clic en Volver a cargar.After you save changes to your code, simply open the shortcut menu for the add-in (in Outlook), and then choose Reload.

Pasos siguientesNext steps

Una vez que el complemento funcione como quiere, vea Implementar y publicar el complemento de Office para ver las formas en las que puede distribuir el complemento a usuarios.After your add-in is working as desired, see Deploy and publish your Office Add-in to learn about the ways you can distribute the add-in to users.