Cómo funciona el Asistente para analizador de tablas

Nota

Office 365 ProPlus pasa a llamarse Microsoft 365 Apps para empresas. Para obtener más información sobre este cambio, lea esta publicación de blog.

Usuario inexperto: se requieren conocimientos de la interfaz de usuario en equipos de usuario único.

Este artículo solo se aplica a una base de datos de Microsoft Access (.mdb) o a Microsoft Office base de datos de Access 2007 (.accdb).

Resumen

El Asistente para analizador de tablas puede ayudarle a crear una base de datos relacional a partir de un conjunto de datos. Al usar el Asistente para analizador de tablas, no es necesario conocer los principios de diseño de bases de datos relacionales. En este artículo se explica cómo el Asistente para analizador de tablas descifrar una base de datos de una sola tabla y propone una forma de dividir la tabla original en un conjunto de tablas relacionadas.

Más información

El Asistente para analizador de tablas puede analizar automáticamente una base de datos no relacional y "normalizarla" automáticamente. La normalización es el proceso de tomar una base de datos de una sola tabla y dividirla en un conjunto de tablas más pequeñas relacionadas, con cada tabla centrada en un solo tema o agrupación de información.

Una base de datos relacional normalizada tiene varias ventajas sobre una no relacional. En primer lugar, actualizar la información es más rápido y fácil porque se requieren menos cambios en los datos. En segundo lugar, solo se almacena la información mínima; por lo tanto, la base de datos es más pequeña. Por último, una base de datos relacional mantiene los datos coherentes automáticamente porque los datos se almacenan una vez.

Aunque el Asistente para analizador de tablas puede ayudarle a crear una base de datos relacional, si tiene experiencia en la base de datos, el Asistente para analizador de tablas le permite modificar cualquier sugerencia que haga. Puede dividir tablas, reorganizar campos en tablas y crear relaciones entre tablas. Puede modificar las decisiones del Asistente para analizador de tablas durante cada paso del proceso de creación de la base de datos.

Cómo ejecutar el Asistente para analizador de tablas

Para ejecutar el Asistente para analizador de tablas, siga estos pasos:

  1. En Microsoft Office Access 2003 o en Microsoft Access 2002, elija Analizar en el menú Herramientas y, a continuación, haga clic en Tabla.

    En Microsoft Office Access 2007 o una versión posterior, haga clic en la pestaña Herramientas de base de datos y, a continuación, haga clic en Analizar tabla en el grupo Analizar.

  2. Siga las instrucciones del cuadro de diálogo Asistente para analizador de tablas. Tenga en cuenta que los dos primeros cuadros de diálogo explican qué es la normalización y por qué es útil. En el tercer cuadro de diálogo se pregunta si desea dividir manualmente una base de datos o si desea permitir que el asistente lo haga por usted.

Cómo funciona el Asistente para analizador de tablas

Si decide permitir que el Asistente para analizador de tablas divida una base de datos, el Asistente para analizador de tablas ejecuta el siguiente proceso:

  1. El Asistente para analizador de tablas comienza con una base de datos de una sola tabla, que puede ser cualquier conjunto de datos creados con Microsoft Access o importados en él. A continuación, el asistente divide la tabla en un conjunto de tablas más pequeñas. Cada una de estas tablas más pequeñas contiene el conjunto mínimo de información que se agrupa.
  2. El asistente busca valores únicos que puedan identificar una agrupación de datos. Estos valores únicos se etiquetan como claves principales para cada una de las agrupaciones. Si no se identifica ningún valor único, el asistente crea una clave principal mediante un campo entero largo de incremento automático. Además, el asistente crea una clave externa en tablas relacionadas.
  3. El asistente crea relaciones que controlan cómo funcionan conjuntamente las nuevas tablas. Estas relaciones aplican integridad referencial (coherencia de datos) con actualizaciones en cascada. El asistente no agrega automáticamente eliminaciones en cascada a las relaciones debido al riesgo de que se eliminen accidentalmente grandes partes de datos.
  4. El asistente crea una propuesta inicial y le pide que la confirme o cambie.
  5. Si confirma la propuesta, el asistente busca datos incoherentes en las nuevas tablas (por ejemplo, el mismo cliente con dos números de teléfono diferentes) y presenta una lista de registros que puede cambiar o aceptar.
  6. Por último, puede elegir crear una consulta que simule la base de datos original de tabla única. El asistente primero hace una copia de seguridad de la tabla original y la cambia de nombre anexando "_OLD" a su nombre. A continuación, el asistente crea una consulta con el nombre de tabla original. Esto garantiza que los formularios o informes existentes basados en la tabla original funcionarán con la nueva estructura de tabla.