Algunas reglas están deshabilitadas y recibe un mensaje de error cuando intenta crear o habilitar reglas en Outlook

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Síntomas

Después de actualizar a Office Outlook 2003 (o posterior), puede observar que algunas de las reglas están deshabilitadas y no se pueden habilitar. Otras reglas funcionan correctamente. Si intenta habilitar las reglas deshabilitadas, recibirá el siguiente mensaje de error:

No se pudo cargar una o varias reglas en Exchange servidor y se desactivaron. Esto puede deberse a que algunos de los parámetros no son compatibles o no hay suficiente espacio para almacenar todas las reglas.

Causa

  • Buzones en Microsoft Exchange Server 2007, Exchange Server 2010 o Exchange Server 2013

    Este comportamiento se produce si las reglas que están en el buzón superan la cuota de reglas establecida para el buzón. El límite de tamaño de reglas para buzones de Exchange Server 2007 (y versiones posteriores) tiene un tamaño predeterminado de 64 KB por buzón. El límite de tamaño total de las reglas también es un límite personalizable de hasta 256 KB por buzón.

  • Buzones en Exchange Server 2003

    Este comportamiento se produce si las reglas que están en el buzón superan un tamaño de 32 kilobytes (KB). El límite de tamaño total de las reglas para los buzones Exchange Server 2003 es de 32 KB. El límite de reglas Exchange 2003 no se puede cambiar.

En Outlook 2003 y posteriores, el tamaño de las reglas ha aumentado principalmente para proporcionar compatibilidad con el formato Unicode.

Solución alternativa

Si el buzón está en Exchange Server 2007 o posterior, puede pedir al administrador de Exchange que aumente la cuota de reglas para el buzón.

El siguiente comando de ejemplo establece la cuota de reglas en el valor máximo de 256 KB.

Set-Mailbox john@contoso.com -RulesQuota:256kb

El siguiente comando de ejemplo permite ver la cuota de reglas actual de un buzón.

Get-Mailbox john@contoso.com |FL displayname, rulesquota

Si el Exchange no puede aumentar la cuota de reglas para el buzón de correo, pruebe una de las siguientes soluciones alternativas que se aplican a todas las versiones de Exchange.

Para evitar este comportamiento de modo que se restablezcan las reglas, use uno o varios de los métodos siguientes para reducir el tamaño de las reglas existentes.

Método 1

Cambie el nombre de las reglas por un nombre más corto. Para cambiar el nombre de una regla Outlook, siga estos pasos.

Para Outlook 2010 y versiones posteriores:

  1. En la pestaña Archivo, haga clic en información.
  2. Haga clic en Administrar reglas y alertas.
  3. En la pestaña Reglas de correo electrónico, haga clic en la regla que desea cambiar.
  4. Haga clic en Cambiar reglas y, a continuación, en Cambiar nombre de regla.
  5. Escriba un nombre nuevo y más corto para la regla y, a continuación, haga clic en Aceptar.
  6. Haga clic en Aceptar para cerrar el cuadro de diálogo Reglas y alertas.

Para Outlook 2007 y Outlook 2003:

  1. En el menú Herramientas, haga clic en Reglas y alertas.
  2. En la pestaña Reglas de correo electrónico, haga clic en la regla que desea cambiar.
  3. En la lista Cambiar regla, haga clic en Cambiar nombre de regla.
  4. Escriba un nombre nuevo y más corto para la regla y, a continuación, haga clic en Aceptar.
  5. Haga clic en Aceptar para cerrar el cuadro de diálogo Reglas y alertas.

Método 2

Elimine las reglas antiguas. Para eliminar una regla en Outlook, siga estos pasos:

Para Outlook 2010 y versiones posteriores:

  1. En la pestaña Archivo, haga clic en información.
  2. Haga clic en Administrar reglas y alertas.
  3. En la pestaña Reglas de correo electrónico, haga clic en la regla que desea cambiar.
  4. Haga clic en el botón Eliminar y, a continuación, haga clic en para confirmar la eliminación.
  5. Haga clic en Aceptar para cerrar el cuadro de diálogo Reglas y alertas.

Para Outlook 2007 y Outlook 2003:

  1. En el menú Herramientas, haga clic en Reglas y alertas.
  2. En la pestaña Reglas de correo electrónico, haga clic en la regla que desea eliminar.
  3. Haga clic en Eliminar y, a continuación, en para confirmar la eliminación.
  4. Haga clic en Aceptar para cerrar el cuadro de diálogo Reglas y alertas.

Método 3

Combine reglas similares para reducir el tamaño general de las reglas. Si es posible, combine reglas similares para reducir el tamaño general de las reglas. Después de combinar reglas similares, elimine las reglas que ya no necesite. Para editar una regla existente en Outlook, siga estos pasos.

Para Outlook 2010 y versiones posteriores:

  1. En la pestaña Archivo, haga clic en Información.
  2. Haga clic en Administrar reglas y alertas.
  3. En la pestaña Reglas de correo electrónico, haga clic en la regla que desea cambiar.
  4. Haga clic en Cambiar regla y, a continuación, en Editar regla Configuración.
  5. Modifique la regla según corresponda.
  6. Haga clic en Aceptar para cerrar el cuadro de diálogo Reglas y alertas.

Para Outlook 2007 y Outlook 2003:

  1. En el menú Herramientas, haga clic en Reglas y alertas.

  2. En la pestaña Reglas de correo electrónico, haga clic en la regla que desea editar.

  3. En la lista Cambiar regla, haga clic en Editar regla Configuración.

    Modifique la regla según corresponda.

  4. Cuando haya terminado, haga clic en Finalizar y, a continuación, haga clic en Aceptar para cerrar el cuadro de diálogo Reglas y alertas.

Nota

Si la regla es una regla de solo cliente, debe hacer clic en Aceptar dos veces para cerrar el cuadro de diálogo Reglas y alertas.

Método 4

Mueva el archivo de carpetas personales (.pst) a una ubicación que tenga el nombre de ruta de acceso más corto. Si tiene reglas que mueven mensajes de correo electrónico a un archivo .pst, mueva el archivo .pst a una ubicación que tenga el nombre de ruta de acceso más corto posible. Por ejemplo, mueva el archivo .pst a una ubicación como C: \<file_name>.pst. Para mover el archivo .pst en Outlook, siga estos pasos:

  1. En el panel de navegación, haga clic con el botón secundario en Carpetas personales o en el nombre de carpeta que aparece para el archivo .pst y, a continuación, haga clic en Propiedades para <folder_name>.

    Nota

    Esta carpeta siempre será una carpeta de nivel superior en el panel de navegación, en Mail.

  2. En la ficha General, haga clic en Avanzadas.

  3. En el cuadro de texto Nombre de archivo, anote la ruta de acceso completa y el nombre de archivo del archivo .pst.

  4. Haga clic en Aceptar dos veces para cerrar el cuadro de diálogo<folder_name> propiedades.

  5. Salga Outlook.

  6. Use Microsoft Windows Explorer para mover el archivo .pst a la nueva ubicación.

    De forma predeterminada, la ubicación de un archivo .pst es la carpeta drive:\Documents y \ Configuración<user_name>\Local Configuración\Application Data\Microsoft\Outlook. La ubicación predeterminada es una carpeta oculta. Para usar Windows explorer para buscar esta carpeta, primero debe activar la presentación de carpetas ocultas. Para ello, siga estos pasos:

    1. En Windows, haga clic en Opciones de carpeta en el menú Herramientas.

    2. Haga clic en la pestaña Ver.

    3. En la sección Opciones Configuración, haga clic en Mostrar archivos y carpetas ocultos en Archivos y carpetas ocultos.

    4. Si desea ver todas las extensiones de nombre de archivo, haga clic para borrar la casilla Ocultar extensiones para tipos de archivo conocidos en Archivos y carpetas.

      Nota

      Las carpetas ocultas aparecen atenuadas para indicar que no son carpetas típicas.

    5. Haga clic en Aceptar.

  7. Use uno de los siguientes métodos para abrir el elemento de correo en el Panel de control:

    • Para ello en un equipo basado en Windows XP o en un equipo basado en Windows Server 2003, haga clic en Inicio , haga clic en Panel de control, haga clic en Cuentas de usuario y, a continuación, haga clic en Correo.

      Nota

      Si usa la vista Clásica, haga clic en Inicio, haga clic en Panel de control y, a continuación, haga doble clic en Correo.

    • Para ello en un equipo basado en Microsoft Windows 2000, haga clic en Inicio , elija Configuración , haga clic en Panel de control y, a continuación, haga doble clic en Correo.

  8. Haga clic en Mostrar perfiles y, a continuación, haga clic en el perfil que contiene el archivo .pst.

  9. Haga clic en Propiedades y, a continuación, en Archivos de datos.

  10. Haga clic en el archivo de datos .pst que movió y, a continuación, haga clic Configuración.

  11. Cuando se le pida que no se pudo encontrar el archivo de datos en la ubicación anterior, haga clic en Aceptar.

  12. Busque y, a continuación, haga clic en el archivo .pst en la nueva ubicación de carpeta y, a continuación, haga clic en Abrir.

  13. Haga clic en Aceptar y, a continuación, en Cerrar dos veces.

  14. Haga clic en Aceptar.

  15. Salga del Panel de control.

  16. Reinicie Outlook.

Método 5

Desactive la casilla solo en esta máquina. Si usa una regla para mover mensajes de correo electrónico a un archivo .pst, haga clic para borrar la casilla solo en este equipo, a menos que tenga acceso a su correo electrónico Exchange Server desde distintos equipos cliente. Para hacerlo en Outlook, siga estos pasos:

Para Outlook 2010 y versiones posteriores:

  1. En la pestaña Archivo, haga clic en Información.
  2. Haga clic en Administrar reglas y alertas.
  3. En la pestaña Reglas de correo electrónico, haga clic en la regla que desea cambiar.
  4. Haga clic en Cambiar regla y, a continuación, en Editar regla Configuración.
  5. Haga clic para borrar la casilla Solo en este equipo si la casilla está activada.
  6. Complete el Asistente para reglas. Haga clic en Aceptar para cerrar el cuadro de diálogo Reglas y alertas.

Para Outlook 2007 y Outlook 2003:

  1. En el menú Herramientas, haga clic en Reglas y alertas.

  2. En la pestaña Reglas de correo electrónico, haga clic en la regla que desea editar.

  3. En la lista Cambiar regla, haga clic en Editar regla Configuración.

  4. Si está seleccionada, haga clic para borrar la casilla solo en esta máquina.

  5. Complete el Asistente para reglas.

  6. Haga clic en Aceptar para cerrar el cuadro de diálogo Reglas y alertas.

    Nota

    Si usa reglas de solo cliente que apuntan a archivos de recursos locales, por ejemplo, al mover elementos a una carpeta de un archivo .pst y usa varios equipos para obtener acceso a Microsoft Outlook, pueden producirse conflictos de reglas. Por lo tanto, algunas reglas de solo cliente pueden deshabilitarse.