Una cita se cancela o elimina inesperadamente durante la sincronización del lado servidor

En este artículo se proporciona una solución a un problema en el que una cita se cancela o elimina inesperadamente cuando se usa la sincronización del lado servidor.

Se aplica a: Microsoft Dynamics 365
Número de KB original: 4345686

Síntomas

Cuando se usa la sincronización del lado servidor para sincronizar citas entre Microsoft Dynamics 365 y Exchange, una cita se cancela o elimina inesperadamente.

Causa

Este problema puede producirse si la cita ya no cumple las condiciones de los filtros de sincronización del usuario. Como se mencionó en Omitir elementos eliminados lógicamente durante la sincronización, hay varias razones por las que una cita ya no puede coincidir con los filtros de sincronización, como el organizador de la cita que se va a cambiar, los filtros de sincronización que se modifican o el usuario ya no tiene acceso al registro debido a cambios en los roles de seguridad o el uso compartido. De forma predeterminada, la sincronización del lado servidor envía una operación de eliminación a Exchange en este escenario, lo que da lugar a una cancelación de cita.

Solución

Se introdujo una configuración configurable que le permite cambiar este comportamiento. Puede usar una de las herramientas siguientes para cambiar la DistinctPhysicalAndLogicalDeletesForExchangeSync configuración a True:

  1. Configuración de la organización Editor
  2. Herramienta OrgDBOrgSettings para Microsoft Dynamics CRM