Las vistas de actividad duplicadas pueden aparecer al ver una lista de vistas de actividad en Microsoft Dynamics CRM 2011

En este artículo se proporciona una solución a un problema en el que pueden aparecer vistas de actividad duplicadas al ver una lista de vistas de actividad en Microsoft Dynamics CRM 2011.

Se aplica a: Microsoft Dynamics CRM 2011
Número de KB original: 2637480

Síntomas

Al ver una lista de vistas de actividad en Microsoft Dynamics CRM 2011, las vistas pueden mostrarse como duplicadas. Al navegar a Configuración, seleccionar Personalizaciones y seleccionar Personalizar el sistema, muestra la solución predeterminada. A continuación, seleccione Entidades, elija la entidad donde se muestra la vista duplicada y seleccione Vistas, se mostrará la lista completa de vistas del sistema. Las vistas duplicadas tendrán una etiqueta de descripción de (que se usará de forma asincrónica).

Causa

En algún momento, las vistas tenían el valor querytype modificado. Que podría haber estado en el sistema actual o haberse actualizado durante una importación de personalizaciones desde un entorno independiente. El valor querytype del archivo customization.xml se mostrará como 0 en lugar de 1024.

Resolución

Para resolver este problema, sigue los pasos a continuación:

  1. Vaya a Configuración y seleccione Soluciones en la sección Personalización .
  2. Seleccione Nuevo para una nueva solución y proporcione valores para todos los campos necesarios. A continuación, guarde la solución.
  3. Seleccione Agregar existente y agregue la entidad o entidades que muestran los síntomas.
  4. Guarde la solución y, a continuación, seleccione Exportar solución y guarde el archivo.
  5. Extraiga el contenido del archivo ZIP creado y abra el archivo customizations.xml.
  6. A continuación, busque las vistas duplicadas. Lo que se puede hacer fácilmente si se busca que se use de forma asincrónica.
  7. A continuación, modifique el valor del tipo de consulta para leer 1024 en lugar de 0.
  8. Repita los pasos 6 y 7 para todas las vistas que se muestran como duplicados.
  9. Guarde el archivo customizations.xml.
  10. Vuelva a comprimir los archivos extraídos e impórtelos de nuevo en Microsoft Dynamics CRM.
  11. Publique los cambios en todas las entidades afectadas.

Más información

El sistema está diseñado para pasar por alto las vistas con un tipo de consulta 1024 en la interfaz de usuario.