GeneralIncomingEmailServerError al intentar instalar Microsoft Dynamics 365 App para Outlook

En este artículo se proporciona una solución para el problema que puede recibir el error GeneralIncomingEmailServerError al intentar instalar Microsoft Dynamics 365 App para Outlook.

Se aplica a: Microsoft Dynamics CRM
Número de KB original: 4019040

Síntomas

Al intentar instalar Microsoft Dynamics 365 App para Outlook, se produce el siguiente error:

Se produjo un problema al intentar agregar la aplicación a Outlook.

SoapException : GeneralIncomingEmailServerError

Si selecciona el vínculo Detalles , aparecerán los siguientes detalles adicionales:

Error: System.Web.Services.Protocols.SoapException: La versión del servidor especificada no es válida. at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, Respuesta de WebResponse, Stream responseStream, Boolean asyncCall) en System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult) en Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndInstallApp(IAsyncResult asyncResult) en Microsoft.Crm.Asynchronous.EmailConnector.OfficeAppsDeploymentStep.EndCall() at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeIncomingEmailProviderStep.EndOperation()

Causa

Este error puede producirse si usa Exchange local y la versión no cumple los requisitos.

Resolución

Compruebe que la versión de Exchange local que usa cumple los requisitos documentados en Configuraciones admitidas con Microsoft Exchange.

Nota:

Si el buzón del usuario está en una versión compatible de Microsoft Exchange, pero su organización ha migrado desde una versión anterior de Exchange como Exchange Server 2010, este error puede producirse si no ha migrado los buzones del sistema. Para obtener más información sobre cómo mover buzones del sistema, vea Mover el buzón del sistema de Exchange 2010 a Exchange 2013.