Es posible que el servicio de SQL Server no se inicie después de instalar la revisión

Este artículo le ayuda a resolver el problema que se produce después de que el programa de instalación de la revisión Instale una revisión e intente reiniciar el sistema.

Versión del producto original:   SQL Server
Número de KB original:   961301

Síntoma

Es posible que reciba un mensaje que indica que no se pudo iniciar un servicio de SQL Server. SQL Server no se inicia después de que el programa de instalación de la revisión Instale una revisión e intente reiniciar el sistema. El mensaje de error se mostrará en la pantalla o aparecerá en el registro de Summary.txt .

Causa

Esto puede deberse a que un servicio SQL se está ejecutando, pero la contraseña ha expirado. Cuando el programa de instalación de la revisión intente reiniciar el servicio de SQL, se producirá un error en el reinicio.

Solución

Pasos para la solución de problemas:

Si recibe un mensaje que indica que no se pudo iniciar un servicio de SQL Server, para solucionar el problema, compruebe lo siguiente:

  • Determine el error. Un mensaje se mostraría en la interfaz de usuario o en el registro de summary.txt ubicado en %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log .

  • Compruebe si el tipo de servicio de inicio es automático o manual.

  • Compruebe que la cuenta y la contraseña son válidas y no han expirado. Un servicio podría haber estado ejecutándose previamente con una cuenta o contraseña no válida.

  • Si el servicio de motor de base de datos no se iniciará después de comprobar las credenciales del servicio y el inicio, compruebe el registro de errores. El ERRORLOG se puede encontrar en C:\Program Files\Microsoft SQL Server\<Instance ID>\MSSQL\LOG .