Los interbloqueos de base de datos se producen al intentar ver un informe de SSRS en el modo integrado de SharePoint después de actualizar un origen de datos.

En este artículo se proporcionan soluciones para los interbloqueos que se producen al intentar ver un informe de SQL Server Reporting Services (SSRS) en modo integrado de SharePoint.

Versión del producto original: SQL Server
Número de KB original: 2691331

Síntomas

Imagine la siguiente situación:

  • Configure una instancia de Microsoft SSRS para usar el modo integrado de SharePoint.

  • Cree un informe que tenga varios orígenes de datos.

  • El informe se implementa en un sitio web de SharePoint.

  • Actualice uno de los orígenes de datos.

  • Intenta ver el informe desde una página personalizada de SharePoint. El informe se inserta en un control IFrame de la página mediante el acceso de dirección URL directa al punto de conexión de proxy de SSRS como se indica a continuación:

    < http:// Nombre> del servidor/<Nombre> del sitio/_vti_bin/ReportServer/<Nombre del> informe.rdl?<Parámetros de dirección URL de informe>

En este escenario, puede experimentar uno o varios de los síntomas siguientes.

  • Síntoma 1

    Los interbloqueos de base de datos se producen en uno de los procedimientos almacenados siguientes en la base de datos del servidor de informes de back-end:

    • [dbo].[GetDataSources]
    • [dbo].[DeleteDataSources]
  • Síntoma 2

    Recibe uno de los siguientes mensajes de error:

    • Mensaje de error 1

      Error en la base de datos del servidor de informes. Esto puede deberse a un error de conexión, tiempo de espera o condición de disco bajo dentro de la base de datos. (rsReportServerDatabaseError)

    • Mensaje de error 2

      Se agotó el tiempo de espera. El período de tiempo de espera se agotó antes de la finalización de la operación o el servidor no responde.

  • Síntoma 3

    Las páginas de SharePoint son muy lentas de cargar al intentar acceder al contenido del sitio de SharePoint.

Causa

Este problema se produce porque el origen de datos no se sincroniza correctamente después de actualizarlo.

Solución

Para resolver este problema, use uno de los métodos siguientes:

  • Método 1

    Vea el informe directamente desde la biblioteca de documentos de SharePoint después de actualizar el origen de datos del informe. Esto garantiza que el origen de datos se sincronice correctamente antes de ver el informe a través del punto de conexión de proxy de SSRS.

  • Método 2

    Use un elemento web Visor de informes para mostrar el informe.