Se producen interbloqueos de base de datos cuando intenta ver un informe de SSRS en el modo integrado de SharePoint después de actualizar un origen de datos

En este artículo se proporcionan soluciones para los interbloqueos que se producen al intentar ver un informe de SQL Server Reporting Services (SSRS) en el modo integrado de SharePoint.

Versión del producto original:   SQL Server
Número de KB original:   2691331

Síntomas

Imagine la siguiente situación:

  • Configure una instancia de Microsoft SSRS para usar el modo integrado de SharePoint.

  • Crea un informe que tiene varios orígenes de datos.

  • El informe se implementa en un sitio web de SharePoint.

  • Actualiza uno de los orígenes de datos.

  • Intenta ver el informe desde una página de SharePoint personalizada. El informe está incrustado en un control IFrame de la página mediante el acceso directo de dirección URL al extremo del proxy de SSRS de la siguiente manera:

    http://<nombre del servidor nombre del >/< sitio>/_vti_bin/ReportServer/<nombre del informe>. RDL? <parámetros de dirección URL del informe>

En este escenario, puede experimentar uno o varios de los síntomas siguientes.

  • Síntoma 1

    Los bloqueos de base de datos se producen en uno de los siguientes procedimientos almacenados en la base de datos del servidor de informes back-end:

    • [dbo].[GetDataSources]
    • [dbo].[DeleteDataSources]
  • Síntoma 2

    Recibe uno de los mensajes de error siguientes:

    • Mensaje de error 1

      Se ha producido un error en la base de datos del servidor de informes. Esto puede deberse a un error de conexión, a un tiempo de espera o a poca condición de disco dentro de la base de datos. (rsReportServerDatabaseError)

    • Mensaje de error 2

      Tiempo de espera agotado. El período de tiempo de espera ha transcurrido antes de la finalización de la operación o el servidor no responde.

  • Síntoma 3

    Las páginas de SharePoint tardan mucho en cargarse cuando intenta obtener acceso al contenido del sitio de SharePoint.

Causa

Este problema se produce porque el origen de datos no está sincronizado correctamente después de actualizarlo.

Solución

Para solucionar este problema, use uno de los métodos siguientes:

  • Método 1

    Ver el informe directamente desde la biblioteca de documentos de SharePoint después de actualizar el origen de datos del informe. Esto garantiza que el origen de datos esté sincronizado correctamente antes de ver el informe a través del extremo del proxy de SSRS.

  • Método 2

    Usar un elemento Web del visor de informes para mostrar el informe.