El sistema deja de responder, el rendimiento del servidor de archivos es lento o se producen retrasos cuando se trabaja con archivos ubicados en un servidor de archivos.

En este artículo se proporciona una solución a los problemas de rendimiento que se producen al trabajar con archivos ubicados en un servidor de archivos.

Versión original del producto:   Windows 10: todas las ediciones, Windows Server 2012 R2
Número KB original:   822219

Síntomas

Puede experimentar uno o varios de los síntomas siguientes al trabajar con archivos a través de la red:

  • Un servidor de archivos basado en Windows que está configurado como un servidor de archivos e impresión deja de responder y la funcionalidad del servidor de archivos e impresión se detiene temporalmente.

  • Se experimenta un retraso inesperado largo al abrir, guardar, cerrar, eliminar o imprimir archivos ubicados en un recurso compartido.

  • Experimenta una disminución temporal del rendimiento al usar un programa a través de la red. El rendimiento normalmente se ralentiza durante aproximadamente 40 a 45 segundos. Sin embargo, algunos retrasos pueden durar hasta 5 minutos.

  • Experimenta un retraso al realizar operaciones de copia de seguridad o copia de seguridad de archivos.

  • El Explorador de Windows deja de responder cuando te conectas a un recurso compartido o ves una X roja en la unidad de red conectada en el Explorador de Windows.

  • Al iniciar sesión en el servidor de archivos, después de escribir su nombre y contraseña en el cuadro de diálogo Iniciar sesión en Windows, aparecerá una pantalla en blanco. El escritorio no aparece.

  • Un programa que usa llamada a procedimiento remoto (RPC) o canalizaciones con nombre para conectarse a un servidor de archivos deja de responder.

  • El servidor deja de responder temporalmente y uno o más mensajes de identificador de evento similares a los mensajes siguientes aparecen en el registro del sistema en el servidor de archivos.

  • Recibe un mensaje de error similar a uno de los siguientes mensajes cuando intenta conectarse a un recurso compartido:

    • Mensaje de error 1

      Error del sistema 53. No se encontró la ruta de acceso de red.

    • Mensaje de error 2

      Error del sistema 64. El nombre de red especificado ya no está disponible.

  • Está desconectado de forma intermitente de los recursos de red y no puede volver a conectarse a los recursos de red en el servidor de archivos. Sin embargo, puede hacer ping al servidor y puede usar una sesión de Terminal Services para conectarse al servidor.

  • Si varios usuarios intentan obtener acceso Microsoft Office documentos en el servidor, el cuadro de diálogo Archivo está bloqueado para edición no siempre aparece cuando el segundo usuario abre el archivo.

  • Un seguimiento de red indica un retraso de 30 a 40 segundos entre un comando de cliente de servicio SMB y una respuesta del servidor de archivos.

  • Cuando intenta abrir un archivo de base de datos de Access 2.0 (archivo .mdb) en Microsoft Access 97, en Access 2000 o en Access 2002, es posible que reciba un mensaje de error similar al siguiente:

    Error de disco o de red.

  • Al intentar abrir un archivo de Microsoft Word, es posible que reciba el siguiente mensaje de error:

    Word no pudo leer desde este archivo file_name. Restaure la conexión de red o reemplace el disco duro y vuelva a intentarlo.

Causa

Este problema puede producirse si un programa que no es de Microsoft que está instalado en el equipo usa un controlador de filtro de modo kernel obsoleto. El controlador de filtro de modo kernel puede estar obsoleto si se cumplen las siguientes condiciones:

  • Uno de los siguientes programas está instalado en el equipo:

    • ArCserve Backup Agent for Open Files o ARCserve Open File Agent from Computer Associates International, Inc. está instalado en el equipo y el controlador Ofant.sys para el programa no está actualizado.

    • El Administrador de transacciones abierto está instalado en el equipo y el controlador Otman.sys para el programa está obsoleto.

      Nota

      Open Transaction Manager se incluye con determinados programas de VERITAS Software Corporation, pero también se puede instalar independientemente del programa VERITAS. Por ejemplo, Open Transaction Manager puede incluirse con la opción Abrir archivo. Este programa puede incluirse con VERITAS Backup Exec.

    • Un programa VERITAS que usa el controlador Otman4.sys o Otman5.sys (como la opción Abrir archivo) está instalado en el equipo y el controlador Otman4.sys o Otman5.sys del programa está obsoleto.

  • El controlador del programa no es compatible con el controlador de filtro instalado en el equipo por un programa antivirus que no es de Microsoft. Como resultado, el controlador de filtro del servidor puede devolver un código de estado incorrecto al servicio de servidor. Por ejemplo, el controlador de filtro puede devolver un STATUS_SUCCESS en lugar de un STATUS_OPLOCK_BREAK_IN_PROGRESS código.

Solución

Para resolver este problema, póngase en contacto con el fabricante del programa para consultar la disponibilidad de una actualización de controladores de filtro. Para obtener más información acerca de cómo ponerse en contacto con Computer Associates para obtener la actualización más reciente para el controlador Ofant.sys, visite Asociados de equipo.

Si ha instalado Open Transaction Manager por separado, póngase en contacto con Productos de Datos de Colombia, Inc. para consultar la disponibilidad de una actualización que pueda resolver este problema. Para ponerse en contacto con Productos de Datos de Colombia,visite Productos de Datos de Colombia .

Para obtener más información acerca de cómo ponerse en contacto con VERITAS, visite el soporte técnico de VERITAS

Más información

Importante

Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. En consecuencia, asegúrese de seguir estos pasos cuidadosamente. Para mayor protección, cree una copia de seguridad del registro antes de modificarlo. Después, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo hacer una copia de seguridad y restaurar el Registro, vea Cómo hacer una copia de seguridad y restaurar el Registro en Windows.

Para evitar temporalmente este problema, reinicie los servicios de servidor en el servidor. Para reiniciar los servicios del servidor, siga estos pasos:

  1. Haga clic en Inicio y, a continuación, en Ejecutar.

  2. En el cuadro Abrir, escriba cmd y, a continuación, haga clic en Aceptar.

  3. En el símbolo del sistema, escriba las siguientes líneas y presione ENTRAR después de cada línea:

    net stop server
    net start server
    

Para solucionar este problema, use cualquiera de los métodos siguientes:

  • Use registros de rendimiento y alertas para supervisar el contador de longitud media de cola de disco del objeto de rendimiento PhysicalDisk. En condiciones normales, el número de solicitudes de entrada y salida (E/S) en espera no suele ser superior a 1,5 a 2 veces el número de ejes que tiene el disco físico. La mayoría de los discos tienen un eje, aunque la matriz redundante de dispositivos de discos independientes (RAID) suele tener más de un eje. Cuando un programa ejecuta pequeñas operaciones de E/S sucesivas, se ve un pico en el contador longitud de cola de disco actual cuando se ponen en cola las operaciones enlazadas a E/S. También puede ver un aumento en el contador de modificadores de contexto/s del objeto de rendimiento del sistema.

  • Deshabilite el bloqueo oportunista en el cliente o en el servidor. Para deshabilitar el bloqueo oportunista en el cliente, establezca el siguiente valor del Registro en 1:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MRXSmb\Parameters\OplocksDisabled

    Para deshabilitar el bloqueo oportunista en el servidor, establezca el siguiente valor del Registro en 0:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\EnableOplocks

    Para obtener más información acerca de cómo deshabilitar el bloqueo oportunista, consulta Configurar el bloqueo oportunista en Windows.

  • Edite el Registro para desactivar temporalmente el controlador de filtro.

    Para obtener más información acerca de cómo desactivar temporalmente el controlador de filtro de modo kernel, consulta Cómo desactivar temporalmente el controlador de filtro de modo kernel en Windows.

    La clave del Registro que almacena información para el controlador Ofant.sys es Ofadriver.

Referencias

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