Introducción a C++ en Visual StudioGet started with C++ in Visual Studio

Tras completar este inicio rápido, estará familiarizado con muchas de las herramientas y cuadros de diálogo que puede usar para desarrollar aplicaciones en C++ con Visual Studio.Complete this quickstart to become familiar with many of the tools and dialog boxes that you can use when you develop applications in C++ with Visual Studio. Crearemos una aplicación de consola de tipo "Hello, World" mientras aprende más sobre cómo trabajar en el entorno de desarrollo integrado (IDE).Create a "Hello, World"-style console application while you learn more about working in the integrated development environment (IDE).

Requisitos previosPrerequisites

No es necesario estar familiarizado con C++ para completar este inicio rápido, pero sí conviene estar al tanto de algunos conceptos generales de depuración y programación.You don't need to be familiar with C++ to complete this quickstart, but you should be familiar with some general programming and debugging concepts. La documentación de Visual Studio no sirve para aprender a programar en C++.The Visual Studio documentation doesn't teach you how to program in C++. Una buena guía de recursos de aprendizaje de C++ es la página de introducción del sitio web de ISO C++.A good guide to C++ learning resources is the Get started page on the ISO C++ website.

Para seguir este inicio rápido, se necesita una copia de Visual Studio 2017 versión 15.3 o posterior que tenga instalada la carga de trabajo Desarrollo de escritorio con C++.To follow along, you need a copy of Visual Studio 2017 version 15.3 or later, with the Desktop development with C++ workload installed. Para obtener una guía rápida de instalación, vea Install C++ support in Visual Studio (Instalar la compatibilidad con C++ en Visual Studio).For a fast guide to installation, see Install C++ support in Visual Studio.

Crear una aplicación de consolaCreate a console app

Inicie Visual Studio si aún no se está ejecutando.If it's not running yet, start Visual Studio.

IDE con la configuración de Visual C++ aplicada

Después de abrir Visual Studio, puede ver las tres partes básicas del IDE: ventanas de herramientas, menús y barras de herramientas, así como el espacio de la ventana principal.After you open Visual Studio, you can see the three basic parts of the IDE: tool windows, menus and toolbars, and the main window space. Las ventanas de herramientas se acoplan a los lados izquierdo y derecho de la ventana de la aplicación.Tool windows are docked on the left and right sides of the app window. El cuadro Inicio rápido, la barra de menús y la barra de herramientas estándar se sitúan en la parte superior.The Quick Launch box, the menu bar, and the standard toolbar are found at the top. El centro de la ventana contiene la Página de inicio.The center of the window contains the Start Page. Cuando se abre una solución o un proyecto, los editores y diseñadores aparecen en este espacio.When you open a solution or project, editors and designers appear in this space. Al desarrollar una aplicación, la mayor parte del tiempo se invierte en esta área central.When you develop an app, most of your time is spent in this central area.

Visual Studio usa proyectos para organizar el código de una aplicación y soluciones para organizar los proyectos.Visual Studio uses projects to organize the code for an app, and solutions to organize your projects. Un proyecto contiene todas las opciones, las configuraciones y las reglas que se usan para compilar las aplicaciones.A project contains all the options, configurations, and rules used to build your apps. También sirve para administrar la relación entre todos los archivos del proyecto y cualquier archivo externo.It also manages the relationship between all the project's files and any external files. Para crear la aplicación, hay que crear en primer lugar un proyecto y una solución.To create your app, first, you create a new project and solution.

Para crear un proyecto de aplicación de consolaTo create a console app project

  1. En la barra de menús, elija Archivo > Nuevo > Proyecto para abrir el cuadro de diálogo Nuevo proyecto.On the menu bar, choose File > New > Project to open the New Project dialog box.

    En la barra de menús, seleccione Archivo > Nuevo > Proyecto

  2. En el cuadro de diálogo Nuevo proyecto, seleccione Instalado > Visual C++ si aún no se ha seleccionado.In the New Project dialog, select Installed > Visual C++ if it isn't selected already. En el panel central, seleccione la plantilla Aplicación de consola Windows.In the center pane, select the Windows Console Application template. En el cuadro de edición Nombre, escriba HelloApp.In the Name edit box, enter HelloApp.

    Use el cuadro de diálogo Nuevo proyecto para crear el proyecto de la aplicación

    El cuadro de diálogo puede contener opciones diferentes en función de las cargas de trabajo de Visual Studio y los componentes que se hayan instalado.Your dialog box may have different choices, depending on the Visual Studio workloads and components you've installed. Si no ve las plantillas de proyecto de Visual C++, será necesario volver a ejecutar el Instalador de Visual Studio e instalar la carga de trabajo Desarrollo de escritorio con C++.If you don't see Visual C++ project templates, you need to run the Visual Studio installer again and install the Desktop development with C++ workload. Puede hacerlo directamente desde el cuadro de diálogo Nuevo proyecto.You can do this directly from the New Project dialog. Para iniciar el Instalador, seleccione el vínculo Abrir el instalador de Visual Studio en el cuadro de diálogo.To launch the installer, choose the Open Visual Studio Installer link on the dialog.

  3. Seleccione el botón Aceptar para crear el proyecto y la solución de la aplicación.Choose the OK button to create your app project and solution.

    El proyecto y la solución HelloApp, así como los archivos básicos de una aplicación de consola Windows, se crean y se cargan automáticamente en el Explorador de soluciones.The HelloApp project and solution, with the basic files for a Windows console app, are created and automatically loaded into Solution Explorer. El archivo HelloApp.cpp se abre en el editor de código.The HelloApp.cpp file is opened in the code editor. Estos elementos aparecen en el Explorador de soluciones:These items appear in Solution Explorer:

    Archivos para la solución en el Explorador de soluciones

Agregar código a la aplicaciónAdd code to the app

El siguiente paso es agregar código para mostrar la palabra "Hello" en la ventana de consola.Next, add code to display the word "Hello" in the console window.

Para editar el código en el editorTo edit code in the editor

  1. En el archivo HelloApp.cpp, escriba una línea en blanco antes de la línea return 0; y, después, escriba este código:In the HelloApp.cpp file, enter a blank line before the line return 0; and then enter this code:

    cout << "Hello\n";
    

    Aparece una línea ondulada roja debajo de cout.A red squiggly line appears under cout. Si mantiene el puntero sobre ella, aparece un mensaje de error.If you hover the pointer over it, an error message appears.

    Texto de error para cout

    El mensaje de error también aparece en la ventana Lista de errores .The error message also appears in the Error List window. Para abrir esta ventana, seleccione Vista > Lista de errores en la barra de menús.You can display this window by choosing View > Error List on the menu bar.

    Error en la ventana Lista de errores

    El código no tiene una declaración para std::cout, que se encuentra en el archivo de encabezado <iostream>.Your code is missing a declaration for std::cout, which is found in the <iostream> header file.

  2. Para incluir el archivo de encabezado de iostream, escriba el siguiente código después de #include "stdafx.h":To include the iostream header, enter this code after #include "stdafx.h":

    #include <iostream>
    using namespace std;
    

    Probablemente haya observado que, al escribir código, ha aparecido un cuadro.You probably noticed that a box appeared as you entered code. Este cuadro contiene sugerencias para completar automáticamente los caracteres a medida que se van escribiendo.This box contains auto-completion suggestions for the characters that you enter. Este cuadro forma parte de IntelliSense de C++, que proporciona indicaciones de codificación, incluida información sobre miembros de interfaz o clase y parámetros.It's part of C++ IntelliSense, which provides coding prompts, including class or interface members and parameter information. También puede usar fragmentos de código, que son bloques de código predefinidos.You can also use code snippets, which are pre-defined blocks of code. Para obtener más información, vea Uso de IntelliSense y Fragmentos de código.For more information, see Using IntelliSense and Code snippets.

    Código corregido en el editor

    La línea ondulada roja bajo cout desaparece cuando se corrige el error.The red squiggly line under cout disappears when you fix the error.

  3. Para guardar los cambios en el archivo, presione CTRL+S.To save the changes to the file, press Ctrl+S.

Compilar la aplicaciónBuild the app

El código es fácil de compilar.It's easy to build your code. En la barra de menús, elija Compilar > Compilar solución.On the menu bar, choose Build > Build Solution. Visual Studio compila la solución HelloApp e informa del progreso en la ventana Salida.Visual Studio builds the HelloApp solution, and reports progress in the Output window.

Compilar la solución HelloApp

Depurar y probar la aplicaciónDebug and test the app

Puede depurar HelloApp para ver si aparece la palabra "Hello" en la ventana de consola.You can debug HelloApp to see whether the word "Hello" appears in the console window.

Para depurar la aplicaciónTo debug the app

Para iniciar el depurador, elija Depurar > Iniciar depuración en la barra de menús.To start the debugger, choose Debug > Start Debugging on the menu bar.

Comando Iniciar depuración del menú Depurar

El depurador inicia y ejecuta el código.The debugger starts and runs the code. La ventana de consola (una ventana independiente que se parece a un símbolo del sistema) aparece durante unos segundos, pero se cierra rápidamente cuando el depurador deja de ejecutarse.The console window (a separate window that looks like a command prompt) appears for a few seconds but closes quickly when the debugger stops running. Para ver el texto, deberá establecer un punto de interrupción para detener la ejecución del programa.To see the text, you need to set a breakpoint to stop program execution.

Para agregar un punto de interrupciónTo add a breakpoint

  1. En el editor, coloque el cursor sobre la línea return 0;.In the editor, put the cursor on the line return 0;. En la barra de menús, elija Depurar > Alternar punto de interrupción.On the menu bar, choose Debug > Toggle Breakpoint. También puede hacer clic en el margen izquierdo para establecer un punto de interrupción.You can also click in the left margin to set a breakpoint.

    Comando Alternar puntos de interrupción del menú Depurar

    Aparece un círculo rojo al lado de la línea de código en el margen izquierdo de la ventana del editor.A red circle appears next to the line of code in the far left margin of the editor window.

    Punto de interrupción indicado en el margen de la ventana

  2. Presione F5 para iniciar la depuración.To start debugging, press F5.

    El depurador se inicia y aparece una ventana de consola con la palabra Hola.The debugger starts, and a console window appears showing the word Hello.

    Texto Hello en la ventana de la consola

  3. Presione MAYÚS+F5 para detener la depuración.To stop debugging, press Shift+F5.

Para más información sobre la depuración de proyectos de consola, vea Proyectos de consola.For more information about console project debugging, see Console projects.

Compilar una versión de lanzamiento de la aplicaciónBuild a release version of the app

Ahora que ha comprobado que todo funciona, puede preparar una versión de lanzamiento de la aplicación.Now that you've verified that everything works, you can prepare a release build of the application. Las versiones de lanzamiento prescinden de la información de depuración y usan opciones de optimización de compilador para crear un código más breve y rápido.Release builds leave out the debugging information, and use compiler optimization options to create smaller, faster code.

Para limpiar los archivos de solución y crear una versión de lanzamientoTo clean the solution files and build a release version

  1. En la barra de menús, elija Compilar > Limpiar solución para eliminar los archivos intermedios y de salida que se han creado durante las compilaciones anteriores.On the menu bar, choose Build > Clean Solution to delete intermediate files and output files that were created during previous builds.

    El comando Limpiar solución del menú Compilar

  2. Para cambiar la configuración de solución de HelloApp de Debug a Release, en la barra de herramientas, seleccione la lista desplegable del control Configuraciones de soluciones y, después, elija Release.To change the solution configuration for HelloApp from Debug to Release, in the toolbar, select the dropdown on the Solution Configurations control and then choose Release.

    Compilar una versión de lanzamiento de la aplicación

  3. Compile la solución.Build the solution. En la barra de menús, elija Compilar > Compilar solución.On the menu bar, choose Build > Build Solution.

Cuando esta compilación acabe, habrá creado una aplicación que se puede copiar y ejecutar en cualquier ventana de símbolo del sistema.When this build completes, you've created an app that you can copy and run in any command prompt window. Puede que no sea mucho, pero abre la puerta a cosas mucho más grandes.It may not do much, but it's the gateway to greater things.

¡Enhorabuena por completar este tutorial de inicio rápido!Congratulations on completing this quickstart!

Vea tambiénSee also