No puede iniciar SQL Server Reporting Services después de aplicar la actualización que se describe en KB 2677070

Este artículo le ayuda a resolver un error de tiempo de espera y un problema en el que los identificadores de evento 7000, 7009 y 1530 se registran al iniciar SQL Server Reporting Services (SSRS).

Versión del producto original: SQL Server
Número de KB original: 2745448

Síntomas

Supongamos que aplica la actualización que se describe en el artículo de Microsoft Knowledge Base (KB) 2677070 en un equipo que ejecuta SSRS. Al intentar iniciar SSRS, recibe un error de tiempo de espera y el identificador de evento 7000 y el identificador de evento 7009 se registran en el registro de aplicación.

Además, se registra el identificador de evento 1530 y se registra información similar a la siguiente en el registro de aplicación:

Nota:

El marcador de posición < Tiempo >de evento representa la hora en que se produce el evento. El marcador de posición < Nombre > del servidor SSRS representa el nombre del servidor SSRS.

Causa

Este problema se produce debido a la incapacidad de recuperar listas de confianza y de confianza de confianza de certificados (CTL). Si el sistema no tiene acceso a Windows Update, ya sea porque el sistema no está conectado a Internet o porque Windows Update está bloqueado por reglas de firewall, la recuperación de red agota el tiempo de espera antes de que el servicio pueda continuar con su procedimiento de inicio. En algunos casos, este tiempo de espera de recuperación de red puede superar el tiempo de espera de inicio del servicio de 30 segundos. Si un servicio no puede notificar que el inicio se completó después de 30 segundos, el administrador de control de servicios (SCM) detiene el servicio.

Las direcciones URL para actualizar el CTL cambiaron con esta actualización. Por lo tanto, si las direcciones URL anteriores se codificaron de forma rígida como excepciones en el firewall o proxy, o si no hay acceso a Internet en el equipo, el CTL no se puede actualizar.

Para descargar las CTL más recientes, use las siguientes direcciones URL actualizadas:

Solución alternativa

Para solucionar este problema, configure el equipo para que la red no recupere las CTL de confianza y que no sean de confianza. Para ello, use uno de los métodos siguientes:

  • Método 1

    Valide que los firewalls de límites, las reglas de acceso del enrutador o los servidores proxy de nivel inferior permiten que los sistemas que tienen 2677070 de actualización instalados se pongan en contacto con Microsoft Update. Para obtener más información sobre este requisito, vea:Un actualizador automático de certificados revocados está disponible para Windows Vista, Windows Server 2008, Windows 7 y Windows Server 2008 R2 (esto incluye las direcciones URL a las que tiene acceso la actualización CTL).

  • Método 2

    Cambie la configuración de directiva de grupo. Para ello, siga estos pasos:

    1. En el nodo Configuración del equipo del directiva de grupo Editor Local, haga doble clic en Directivas.
    2. Haga doble clic en Configuración de Windows, haga doble clic en Configuración de seguridady, a continuación, haga doble clic en Directivas de clave pública.
    3. En el panel de detalles, haga doble clic en Configuración de validación de ruta de acceso de certificado.
    4. Seleccione la pestaña Recuperación de red , haga clic para activar la casilla Definir esta configuración de directiva y, a continuación, haga clic para desactivar la casilla Actualizar automáticamente certificados en el Programa de certificados raíz de Microsoft (recomendado ).
    5. Seleccione Aceptar y, a continuación, cierre la directiva de grupo Editor Local.
  • Método 3

    Modifique el registro. Para ello, siga estos pasos.

    Importante

    Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. En consecuencia, asegúrese de seguir estos pasos cuidadosamente. Para mayor protección, cree una copia de seguridad del registro antes de modificarlo. Después, puede restaurar el registro si se produce un problema. Para obtener más información sobre cómo hacer una copia de seguridad y restaurar el Registro, vea: Cómo hacer una copia de seguridad y restaurar el registro en Windows.

    1. Seleccione Inicio, seleccione Ejecutar, escriba regedit en el cuadro Abrir y, a continuación, haga clic en Aceptar.

    2. Busque la siguiente subclave del Registro y selecciónela:

      HKLM\Software\Policies\Microsoft\SystemCertificates.

    3. Haga clic con el botón derecho en AuthRoot, seleccione Nuevo y, a continuación, haga clic en DWORD.

    4. Escriba DisableRootAutoUpdate y presione Entrar.

    5. Haga clic con el botón derecho en DisableRootAutoUpdatey, a continuación, haga clic en Modificar.

    6. En el cuadro Datos de valor , escriba 1 y, a continuación, haga clic en Aceptar.

    7. En el menú Archivo, haga clic en Salir.

  • Método 4

    Aumente el tiempo de espera predeterminado del servicio.

    Importante

    Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. En consecuencia, asegúrese de seguir estos pasos cuidadosamente. Para mayor protección, cree una copia de seguridad del registro antes de modificarlo. Después, puede restaurar el registro si se produce un problema. Para obtener más información sobre cómo hacer una copia de seguridad y restaurar el Registro, vea: Cómo hacer una copia de seguridad y restaurar el registro en Windows.

    Para aumentar el tiempo de espera predeterminado del servicio, siga estos pasos:

    1. Haga clic en Inicio, Ejecutar, escriba regedit en el cuadro Abrir y, después, haga clic en Aceptar.

    2. Busque y seleccione la siguiente subclave del Registro: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control.

    3. Haga clic con el botón derecho en Control, seleccione Nuevoy, a continuación, haga clic en DWORD.

    4. En el cuadro Nuevo valor , escriba ServicesPipeTimeout y presione Entrar.

    5. Haga clic con el botón derecho en ServicesPipeTimeouty, a continuación, haga clic en Modificar.

    6. Haga clic en Decimal, escriba el número de milisegundos que desea esperar hasta que el servicio agote el tiempo de espera y, a continuación, haga clic en Aceptar. Por ejemplo, para esperar 60 segundos antes de que el servicio agote el tiempo de espera, escriba 60000.

    7. En el menú Archivo , haga clic en Salir y reinicie el equipo.

Más información

Para obtener más información sobre el programa de certificados raíz de Windows, los certificados, la confianza de certificados y la lista de confianza de certificados, consulte la sección Más información del artículo en Microsoft Knowledge Base: An-automatic-updater-of-untrusted-certificates-is-available-for-window.