Creación de un proyecto de modelos tabularesCreate a tabular model project

Se aplica a: SQL Server 2019 y versiones posteriores Analysis Services Azure Analysis Services Power BI Premium

En esta lección, usará Visual Studio con proyectos de Microsoft Analysis Services para crear un nuevo proyecto de modelo tabular.In this lesson, you use Visual Studio with Microsoft Analysis Services projects to create a new tabular model project. Una vez creado el proyecto, puede empezar a agregar datos y a crear el modelo.Once your new project is created, you can begin adding data and authoring your model. En esta lección también se le proporciona una breve introducción al entorno de creación de modelos tabulares en Visual Studio.This lesson also gives you a brief introduction to the tabular model authoring environment in Visual Studio.

Tiempo estimado para completar esta lección: 10 minutosEstimated time to complete this lesson: 10 minutes

Requisitos previosPrerequisites

Este artículo es la primera lección de un tutorial de creación de modelos tabulares.This article is the first lesson in a tabular model authoring tutorial. Para llevar a cabo esta lección, hay una serie de requisitos previos que debe cumplir.To complete this lesson, there are several prerequisites you need to have in-place. Para obtener más información, consulte Analysis Services: tutorial de Adventure Works.To learn more, see Analysis Services - Adventure Works tutorial.

Crear un nuevo proyecto de modelo tabularCreate a new tabular model project

Para crear un proyecto de modelo tabularTo create a new tabular model project

  1. En Visual Studio, en Introducción, hagaclic en crear un nuevo proyecto.In Visual Studio, in Get started, click Create a new project.

  2. En crear un nuevo proyecto, busque y, a continuación, seleccione Analysis Services proyecto tabular.In Create a new project, search for and then select Analysis Services Tabular Project.

  3. En configurar el nuevo proyecto, en nombre del proyecto, escriba ventas por Internet de AW.In Configure your new project, in Project name, type AW Internet Sales. Especifique una ubicación para los archivos de proyecto.Specify a location for the project files. Deje el marco de trabajo predeterminado.Leave Framework the default.

    De forma predeterminada, el Nombre de la solución será el mismo que el del proyecto, aunque puede escribir uno distinto.By default, Solution Name is the same as the project name; however, you can type a different solution name.

  4. Haga clic en Crear.Click Create.

  5. En el cuadro de diálogo Diseñador de modelos tabulares, seleccione Área de trabajo integrada.In the Tabular model designer dialog box, select Integrated workspace.

    El área de trabajo hospeda una base de datos de modelos tabulares con el mismo nombre que el proyecto durante la creación del modelo.The workspace hosts a tabular model database with the same name as the project during model authoring. Por área de trabajo integrada se entiende que Visual Studio usa una instancia integrada, sin tener que instalar una instancia de servidor de Analysis Services independiente solo para la creación de modelos.Integrated workspace means Visual Studio uses a built-in instance, eliminating the need to install a separate Analysis Services server instance just for model authoring. Para obtener más información, vea base de datos del área de trabajo.To learn more, see Workspace database.

  6. En nivel de compatibilidad, seleccione SQL Server 2019/Azure Analysis Services (1500) y, a continuación, haga clic en Aceptar.In Compatibility level, select SQL Server 2019 / Azure Analysis Services (1500), and then click OK.

    Captura de pantalla del cuadro de diálogo diseñador de modelos tabulares con la opción de área de trabajo integrada y la lista desplegable nivel de compatibilidad denominada.

Cuando haya finalizado, el nuevo proyecto de modelo tabular se abrirá en Visual Studio.When complete, your new tabular model project will open in Visual Studio.

Descripción del entorno de creación de modelos tabularesUnderstanding the tabular model authoring environment

Ahora que ha creado un nuevo proyecto de modelo tabular, dedique un momento a explorar el entorno de creación de modelos tabulares en Visual Studio.Now that you've created a new tabular model project, let's take a moment to explore the tabular model authoring environment in Visual Studio.

Una vez creado el proyecto, se abrirá en Visual Studio.After your project is created, it opens in Visual Studio. En el lado derecho, en Explorador de modelos tabulares, aparece una vista de árbol de los objetos presentes en el modelo.On the right side, in Tabular Model Explorer, you see a tree view of the objects in your model. Como todavía no se han importado datos, las carpetas están vacías.Since you haven't yet imported data, the folders are empty. Puede hacer clic con el botón derecho en una carpeta de objetos para llevar a cabo acciones, de manera similar a una barra de menús.You can right-click an object folder to perform actions, similar to the menu bar. Durante este tutorial se usa el Explorador de modelos tabulares para navegar por los distintos objetos del proyecto de modelo.As you step through this tutorial, you use the Tabular Model Explorer to navigate different objects in your model project.

Captura de pantalla del cuadro de diálogo explorador de modelos tabulares.

Haga clic en la pestaña Explorador de soluciones . Aquí verá el archivo Model. BIM .Click the Solution Explorer tab. Here, you see your Model.bim file. Si no ve la ventana del diseñador a la izquierda (la ventana vacía con la pestaña Model. BIM), en Explorador de soluciones, en el proyecto de ventas por Internet de AW, haga doble clic en el archivo Model. BIM .If you don't see the designer window to the left (the empty window with the Model.bim tab), in Solution Explorer, under AW Internet Sales Project, double-click the Model.bim file. El archivo Model.bim contiene los metadatos del proyecto de modelo.The Model.bim file contains the metadata for your model project.

Captura de pantalla de la sección Explorador de soluciones con el archivo Model. BIM resaltado.

Haga clic en Model.bim.Click Model.bim. En la ventana Propiedades aparecen las propiedades del modelo; la más importante es la propiedad Modo DirectQuery.In the Properties window, you see the model properties, most important of which is the DirectQuery Mode property. Esta propiedad especifica si el modelo se implementa en modo en memoria (desactivado) o en modo DirectQuery (activado).This property specifies if the model is deployed in In-Memory mode (Off) or DirectQuery mode (On). En este tutorial se crea y se implementa el modelo en modo en memoria.For this tutorial, you author and deploy your model in In-Memory mode.

Captura de pantalla de la ventana Propiedades con la opción de nivel de compatibilidad resaltada y la configuración de SQL Server 2019/Azure Analysis Services (1500) que se ha llamado.

Al crear un proyecto de modelo, algunas de las propiedades del modelo se establecen automáticamente según las opciones del modelado de datos que se pueden especificar en el menú Herramientas > cuadro de diálogo Opciones.When you create a model project, certain model properties are set automatically according to the Data Modeling settings that can be specified in the Tools menu > Options dialog box. Las propiedades Copia de seguridad de datos, Retención de área de trabajo y Servidor del área de trabajo especifican cómo y dónde se realiza una copia de seguridad, se conserva en memoria y se crea la base de datos del área de trabajo (la base de datos de creación del modelo).Data Backup, Workspace Retention, and Workspace Server properties specify how and where the workspace database (your model authoring database) is backed up, retained in-memory, and built. Si es necesario, puede cambiar estas opciones más adelante, pero de momento las dejaremos tal como están.You can change these settings later if necessary, but for now, leave these properties as they are.

En el Explorador de soluciones, haga clic con el botón derecho en Ventas por Internet AW (proyecto) y haga clic en Propiedades.In Solution Explorer, right-click AW Internet Sales (project), and then click Properties. Aparecerá el cuadro de diálogo Páginas de propiedades de Ventas por Internet AW.The AW Internet Sales Property Pages dialog box appears. Al implementar el modelo más adelante, se establecen algunas de estas propiedades.You set some of these properties later when you deploy your model.

Al instalar la extensión de proyectos de Analysis Services, se agregaron varios elementos de menú nuevos al entorno de Visual Studio.When you installed the Analysis Services projects extension, several new menu items were added to the Visual Studio environment. Haga clic en el menú extensiones .Click the Extensions menu. Desde aquí puede importar datos, actualizar los datos del área de trabajo, examinar el modelo en Excel, crear perspectivas y roles, seleccionar la vista de modelo y establecer opciones de cálculo.From here, you can import data, refresh workspace data, browse your model in Excel, create perspectives and roles, select the model view, and set calculation options. Haga clic en el menú Tabla.Click the Table menu. Desde aquí puede crear y administrar las relaciones, especificar la configuración de las tablas de fecha, crear particiones y editar las propiedades de las tablas.From here, you can create and manage relationships, specify date table settings, create partitions, and edit table properties. Al hacer clic en el menú Columna, puede agregar y eliminar columnas de una tabla, inmovilizar columnas y especificar el criterio de ordenación.If you click the Column menu, you can add and delete columns in a table, freeze columns, and specify sort order. La extensión también agrega algunos botones a la barra.The extension also adds some buttons to the bar. Más útil es la característica Autosuma, que sirve para crear una medida de agregación estándar para una columna seleccionada.Most useful is the AutoSum feature to create a standard aggregation measure for a selected column. Otros botones de la barra de herramientas proporcionan acceso rápido a características y comandos usados con frecuencia.Other toolbar buttons provide quick access to frequently used features and commands.

Examine algunos de los cuadros de diálogo y ubicaciones de las distintas características específicas de la creación de modelos tabulares.Explore some of the dialogs and locations for various features specific to authoring tabular models. Aunque algunos elementos aún no están activos, puede hacerse una idea del entorno de creación de modelos tabulares.While some items are not yet active, you can get a good idea of the tabular model authoring environment.

Paso siguienteNext step

Lección 2: obtener datosLesson 2: Get data