Uso de cuadernos

Un cuaderno es una colección de celdas que se pueden ejecutar (comandos). Cuando se usa un cuaderno, se desarrollan y ejecutan principalmente celdas.

Todas las tareas del cuaderno son compatibles con las acciones de la interfaz de usuario, pero también puede realizar muchas tareas mediante métodos abreviados de teclado. Para alternar la presentación del acceso directo, haga clic en Icono de teclado .

Métodos abreviados de teclado

Desarrollo de cuadernos

En esta sección se describe cómo desarrollar celdas de cuaderno y navegar por un cuaderno.

En esta sección:

Acerca de los cuadernos

Un cuaderno tiene una barra de herramientas que le permite administrar el cuaderno y realizar acciones dentro del cuaderno:

Barra de herramientas de los cuaderno

y una o varias celdas (o comandos) que puede ejecutar:

Celdas del cuaderno

En el extremo derecho de una celda, las acciones de celda Acciones de celda contienen tres  menús: Ejecutar, Panel y Editar:

Icono ejecutarPanelEditar

y dos acciones: Ocultar Minimización de celdas y Delete Icono de eliminación.

Adición de una celda

Para agregar una celda, mueva el mouse sobre una celda de la parte superior o inferior y haga clic en el icono Agregar celda, o bien acceda al menú de celdas del cuaderno en el extremo derecho, haga clic en Símbolo de cuidado hacia abajo y seleccione Agregar celda encima o Agregar celda debajo  de  .

Eliminación de una celda

Vaya al menú de acciones de celda. Acciones de celda en el extremo derecho y haga clic en Icono de eliminación (Eliminar).

Cuando se elimina una celda, de forma predeterminada se muestra un cuadro de diálogo de confirmación de eliminación. Para deshabilitar los cuadros de diálogo de confirmación futuros, active la casilla No volver a mostrar esto y haga clic en Confirmar. También puede alternar la configuración del cuadro de diálogo de confirmación con la opción De confirmación de eliminación del comando Activar en Icono de cuenta> Configuración de usuario  > Notebook.

Para restaurar las celdas eliminadas, seleccione Editar > Eliminar celdas o use el método abreviado de teclado ( Z ).

Cortar una celda

Vaya al menú acciones de celda Acciones de celda en el extremo derecho, haga clic en El icono de   careta hacia abajo y seleccione Cortar celda.

También puede usar el método abreviado de teclado ( X ).

Para restaurar las celdas eliminadas, seleccione Editar > Deshacer celdas de corte o use el método abreviado de teclado ( Z ).

Seleccionar varias celdas o todas las celdas

Puede seleccionar celdas de cuaderno adyacentes mediante Mayús Arriba o Abajo para la celda anterior y la siguiente + respectivamente. Las celdas seleccionadas múltiples se pueden copiar, cortar, eliminar y pegar.

Para seleccionar todas las celdas, seleccione Editar > Seleccionar todas las celdas o use el método abreviado de modo de comando Cmd+A.

Idioma predeterminado

El idioma predeterminado de cada celda se muestra en un vínculo ( ) junto al nombre del cuaderno. En el cuaderno siguiente, el idioma predeterminado es SQL.

Idioma predeterminado del cuaderno

Para cambiar el idioma predeterminado:

  1. Haga clic en el vínculo ( ). Se muestra el cuadro de diálogo Cambiar idioma predeterminado.

    Cambio del idioma predeterminado

  2. Seleccione el nuevo idioma en la lista desplegable Idioma predeterminado.

  3. Haga clic en Cambiar.

  4. Para asegurarse de que los comandos existentes siguen funcionando, los comandos del idioma predeterminado anterior tienen automáticamente el prefijo de un comando magic de lenguaje.

Combinación de idiomas

Puede invalidar el idioma predeterminado especificando el comando magic del %<language> lenguaje al principio de una celda. Los comandos magic admitidos son: %python , %r , y %scala %sql .

Nota

Al invocar un comando magic de lenguaje, el comando se envía a REPL en el contexto de ejecución del cuaderno. Las variables definidas en un idioma (y, por tanto, en el REPL para ese idioma) no están disponibles en el REPL de otro idioma. Las REPL solo pueden compartir el estado a través de recursos externos, como archivos en DBFS u objetos del almacenamiento de objetos.

Los cuadernos también admiten algunos comandos magic auxiliares:

  • %sh: permite ejecutar código de shell en el cuaderno. Para producir un error en la celda si el comando de shell tiene un estado de salida distinto de cero, agregue la -e opción . Este comando solo se ejecuta en el controlador Apache Spark y no en los trabajadores. Para ejecutar un comando de shell en todos los nodos, use un script init.
  • %fs: permite usar comandos dbutils del sistema de archivos. Consulte la CLI de Databricks.
  • %md: permite incluir varios tipos de documentación, como texto, imágenes y fórmulas matemáticas y ecuaciones. Consulte la sección siguiente.

Incluir documentación

Para incluir documentación en un cuaderno, puede usar el %md comando magic para identificar el marcado de Markdown. El marcado Markdown incluido se representa en HTML. Por ejemplo, este fragmento de código de Markdown contiene marcado para un encabezado de nivel uno:

%md # Hello This is a Title

Se representa como un título HTML:

Título HTML del cuaderno

Encabezados que pueden contraerse

Las celdas que aparecen después de las celdas que contienen encabezados markdown se pueden contraer en la celda de encabezado. En la imagen siguiente se muestra un encabezado de nivel uno denominado Encabezado 1 con las dos celdas siguientes contrayéndola.

Celdas contraídas

Para expandir y contraer encabezados, haga clic en + y - .

Consulte también Ocultar y mostrar contenido de celda.

Puede vincular a otros cuadernos o carpetas en celdas de Markdown mediante rutas de acceso relativas. Especifique el atributo de una etiqueta delimitadora como ruta de acceso relativa, empezando por y, a continuación, siga href el mismo patrón que en los sistemas de archivos $ Unix:

%md
<a href="$./myNotebook">Link to notebook in same folder as current notebook</a>
<a href="$../myFolder">Link to folder in parent folder of current notebook</a>
<a href="$./myFolder2/myNotebook2">Link to nested notebook</a>

Mostrar imágenes

Para mostrar imágenes almacenadas en FileStore,use la sintaxis :

%md
![test](files/image.png)

Por ejemplo, supongamos que tiene el archivo de imagen del logotipo de Databricks en FileStore:

dbfs ls dbfs:/FileStore/
databricks-logo-mobile.png

Al incluir el código siguiente en una celda de Markdown:

Imagen en la celda de Markdown

la imagen se representa en la celda:

Imagen representada

Visualización de ecuaciones matemáticas

Los cuadernos admiten KaTeX para mostrar fórmulas matemáticas y ecuaciones. Por ejemplo,

%md
\\(c = \\pm\\sqrt{a^2 + b^2} \\)

\\(A{_i}{_j}=B{_i}{_j}\\)

$$c = \\pm\\sqrt{a^2 + b^2}$$

\\[A{_i}{_j}=B{_i}{_j}\\]

se representa como:

Ecuación representada 1

y

%md
\\( f(\beta)= -Y_t^T X_t \beta + \sum log( 1+{e}^{X_t\bullet\beta}) + \frac{1}{2}\delta^t S_t^{-1}\delta\\)

where \\(\delta=(\beta - \mu_{t-1})\\)

se representa como:

Ecuación representada 2

Incluir HTML

Puede incluir HTML en un cuaderno mediante la función displayHTML . Consulte HTML, D3 y SVG en cuadernos para obtener un ejemplo de cómo hacerlo.

Nota

El displayHTML iframe se sirve desde el dominio databricksusercontent.com y el espacio aislado de iframe incluye el atributo allow-same-origin . Debe ser capaz de acceder a la dirección databricksusercontent.com desde el explorador. Si actualmente está bloqueada por la red corporativa, se debe agregar a la lista de permitidos.

Comentarios de comandos

Puede tener conversaciones con colaboradores mediante comentarios de comandos.

Para alternar la barra lateral Comentarios, haga clic en el botón Comentarios situado en la parte superior derecha de un cuaderno.

Alternar comentarios de cuadernos

Para agregar un comentario a un comando:

  1. Resalte el texto del comando y haga clic en la burbuja de comentario:

    Abrir comentarios

  2. Agregue el comentario y haga clic en Comentario.

    Agregar commenty

Para editar, eliminar o responder a un comentario, haga clic en el comentario y elija una acción.

Editar comentario

Cambiar la visualización de la celda

Hay tres opciones de visualización para los cuadernos:

  • Vista estándar: los resultados se muestran inmediatamente después de las celdas de código
  • Solo resultados: solo se muestran los resultados
  • En paralelo: las celdas de código y resultados se muestran en paralelo, con resultados a la derecha

Vaya al menú Ver. Menú Ver para seleccionar la opción de presentación.

vista en paralelo

Mostrar números de línea y de comandos

Para mostrar números de línea o números de comando, vaya al menú Ver Menú Ver y seleccione Mostrar números  de línea o Mostrar números de comando. Una vez que se muestran, puede ocultarlos de nuevo en el mismo menú. También puede habilitar los números de línea con el método abreviado de teclado Control+L.

Mostrar números de línea o de comandos a través del menú ver

Números de línea y comandos habilitados en el cuaderno

Si habilita números de línea o de comandos, Databricks guarda sus preferencias y las muestra en todos los demás cuadernos de ese explorador.

Los números de comando encima de las celdas se vinculan a ese comando específico. Si hace clic en el número de comando de una celda, actualiza la dirección URL para delimitarse a ese comando. Si desea vincular a un comando específico en el cuaderno, haga clic con el botón derecho en el número de comando y elija copiar dirección de vínculo.

Buscar y reemplazar texto

Para buscar y reemplazar texto dentro de un cuaderno, seleccione Editar > Buscar y reemplazar. La coincidencia actual se resalta en naranja y todas las demás coincidencias se resaltan en amarillo.

Texto correspondiente

Para reemplazar la coincidencia actual, haga clic en Reemplazar. Para reemplazar todas las coincidencias del cuaderno, haga clic en Reemplazar todo.

Para moverse entre coincidencias, haga clic en los botones Anterior y Siguiente. También puede presionar Mayús+Entrar y entrar para ir a las coincidencias anterior y siguiente, respectivamente.

Para cerrar la herramienta de búsqueda y reemplazo, haga clic  en Eliminar icono o presione esc.

Autocompletar

Puede usar Azure Databricks autocompletar para completar automáticamente los segmentos de código a medida que los escribe. Azure Databricks admite dos tipos de autocompletar: local y servidor.

Autocompletar local completa las palabras que se definen en el cuaderno. La función autocompletar del servidor tiene acceso al clúster para tipos, clases y objetos definidos, así como nombres de tabla y base de datos SQL. Para activar la función autocompletar del servidor, adjunte el cuaderno a un clúster y ejecute todas las celdas que definen objetos completables.

Importante

La función autocompletar del servidor en cuadernos de R se bloquea durante la ejecución del comando.

Para desencadenar la función autocompletar, presione Tab después de escribir un objeto completable. Por ejemplo, después de definir y ejecutar las celdas que contienen las definiciones de y , los métodos de son completables y se muestra una lista de finalizaciones válidas al presionar MyClass instance instance tab.

Autocompletar del desencadenador

La finalización de tipos y la finalización de nombres de tabla y base de datos SQL funcionan de la misma manera.

Finalización de tipos — — Finalización de SQL

En Databricks Runtime 7.4 y posteriores, puede mostrar sugerencias de docstring de Python presionando Mayús+Tab después de escribir un objeto de Python completable. Las docstrings contienen la misma información que la help() función de un objeto .

Docstring de Python

Dar formato a SQL

Azure Databricks proporciona herramientas que le permiten dar formato al código SQL en las celdas del cuaderno de forma rápida y sencilla. Estas herramientas reducen el esfuerzo de mantener el código con formato y ayudan a aplicar los mismos estándares de codificación en los cuadernos.

Puede desencadenar el formateador de las maneras siguientes:

  • Celdas únicas

    • Método abreviado de teclado: presione Cmd+Mayús+F.

    • Menú contextual de comandos: seleccione Format SQL (Formato sql) en el menú desplegable del contexto del comando de una celda SQL. Este elemento solo es visible en las celdas del cuaderno de SQL y en las que tienen una %sql instrucción mágica del lenguaje.

      Aplicar formato a SQL desde el contexto de comando

  • Varias celdas

    Seleccione varias celdas SQL y, a continuación, seleccione Editar > formato de celdas SQL. Si selecciona celdas de más de un idioma, solo se formatearán las celdas SQL. Esto incluye aquellos que usan %sql .

    Aplicar formato a SQL desde el menú Editar

Esta es la primera celda del ejemplo anterior después del formato:

Después de aplicar formato a SQL

Ver tabla de contenido

Para mostrar una tabla de contenido generada automáticamente, haga clic en la flecha situada en la parte superior izquierda del cuaderno (entre la barra lateral y la celda superior). La tabla de contenido se genera a partir de los encabezados de Markdown que se usan en el cuaderno.

Abrir TOC

Para cerrar la tabla de contenido, haga clic en la flecha orientada a la izquierda.

Cierre de TOC

Visualización de cuadernos en modo oscuro

Puede optar por mostrar cuadernos en modo oscuro. Para activar o desactivar el modo oscuro, seleccione Ver > tema del cuaderno y seleccione Tema claro u Tema oscuro.

Modo claro u oscuro del cuaderno

Ejecución de cuadernos

En esta sección se describe cómo ejecutar una o varias celdas del cuaderno.

En esta sección:

Requisitos

El cuaderno debe estar asociado a un clúster. Si el clúster no se está ejecutando, el clúster se inicia cuando se ejecutan una o varias celdas.

Ejecución de una celda

En el menú acciones de celda Acciones de celda en el extremo derecho, haga clic en Icono de ejecución y seleccione  Ejecutar celda o presione  Mayús+Entrar.

Importante

El tamaño máximo de una celda del cuaderno, tanto el contenido como la salida, es de 16 MB.

Por ejemplo, intente ejecutar este fragmento de código de Python que haga referencia a la spark variable predefinida.

spark

y, a continuación, ejecute código real:

1+1 # => 2

Nota

Los cuadernos tienen una serie de configuraciones predeterminadas:

  • Al ejecutar una celda, el cuaderno se asocia automáticamente a un clúster en ejecución sin preguntar.
  • Al presionar mayús+entrar, el cuaderno se desplaza automáticamente a la celda siguiente si la celda no está visible.

Para cambiar esta configuración, seleccione Icono de cuenta> usuario > configuración del cuaderno y  configure las casillas correspondientes.

Ejecutar todo por encima o por debajo

Para ejecutar todas las celdas antes o después de una celda, vaya al menú acciones de celda Acciones de celda en el extremo derecho, haga clic en Menú Ejecutar y seleccione Ejecutar todo por encima o Ejecutar  todo  debajo de .

Ejecutar todo a continuación incluye la celda en la que se encuentra. Ejecutar todo lo anterior no lo hace.

Ejecutar todas las celdas

Para ejecutar todas las celdas de un cuaderno, seleccione Ejecutar todo en la barra de herramientas del cuaderno.

Importante

No realice una ejecución de todo si los pasos de montaje y desmontaje están en el mismo cuaderno. Podría provocar una condición de carrera y posiblemente dañar los puntos de montaje.

Visualización de varias salidas por celda

Los cuadernos y las celdas de Python en cuadernos que no son de %python Python admiten varias salidas por celda.

Varias salidas en una celda

Esta característica requiere Databricks Runtime 7.1 o posterior y se puede habilitar en Databricks Runtime 7.1-7.3 estableciendo spark.databricks.workspace.multipleResults.enabled true . Está habilitada de forma predeterminada en Databricks Runtime 7.4 y posteriores.

Resaltado de errores de Python y Scala

Los cuadernos de Python y Scala admiten el resaltado de errores. Es decir, la línea de código que produce el error se resaltará en la celda. Además, si la salida del error es un stacktrace, la celda en la que se produce el error se muestra en stacktrace como un vínculo a la celda. Puede hacer clic en este vínculo para ir al código de ofenso.

Resaltado de errores de Python

Resaltado de errores de Scala

Notificaciones

Las notificaciones le alertan de determinados eventos, como qué comando se está ejecutando actualmente durante la ejecución de todas las celdas y qué comandos están en estado de error. Cuando el cuaderno muestra varias notificaciones de error, la primera tendrá un vínculo que le permite borrar todas las notificaciones.

Notificaciones del cuaderno

Las notificaciones del cuaderno están habilitadas de forma predeterminada. Puede deshabilitarlos en Icono de cuenta > configuración de usuario > Notebook Settings (Configuración del cuaderno).

Databricks Advisor

Databricks Advisor analiza automáticamente los comandos cada vez que se ejecutan y muestra los consejos adecuados en los cuadernos. Los avisos de consejos proporcionan información que puede ayudarle a mejorar el rendimiento de las cargas de trabajo, reducir los costos y evitar errores comunes.

Ver consejos

Un cuadro azul con un icono de bombilla indica que hay consejos disponibles para un comando. El cuadro muestra el número de consejos distintos.

Consejos de Databricks

Haga clic en la bombilla para expandir el cuadro y ver los consejos. Uno o varios consejos se volverán visibles.

Ver consejos

Haga clic en el vínculo Más información para ver la documentación que proporciona más información relacionada con los consejos.

Haga clic en el vínculo No volver a mostrarme este para ocultar el aviso. Ya no se mostrarán los consejos de este tipo. Esta acción se puede invertir en Configuración del cuaderno.

Vuelva a hacer clic en la bombilla para contraer el cuadro de consejos.

Configuración de consejos

Para acceder a la página Configuración del cuaderno, seleccione Icono de cuenta> Configuración de usuario > Configuración del cuaderno o haga clic en el icono de engranaje en el  cuadro de consejos expandido.

Configuración del cuaderno

Active la opción Activar Databricks Advisor para habilitar o deshabilitar los consejos.

El vínculo Restablecer consejos ocultos se muestra si uno o varios tipos de consejos están ocultos actualmente. Haga clic en el vínculo para que ese tipo de consejos vuelva a ser visible.

Ejecución de un cuaderno desde otro cuaderno

Puede ejecutar un cuaderno desde otro cuaderno mediante el %run <notebook> comando magic. Esto equivale aproximadamente a un comando en un REPL de Scala en :load el equipo local o a una instrucción en import Python. Todas las variables definidas en <notebook> estarán disponibles en el cuaderno actual.

%run debe estar en una celda por sí misma, porque ejecuta todo el cuaderno en línea.

Nota

No puede usar %run para ejecutar un archivo de Python y las entidades import definidas en ese archivo en un cuaderno. Para importar desde un archivo de Python, debe empaquetar el archivo en una biblioteca de Python, crear una biblioteca de Azure Databricks a partir de esa biblioteca de Python e instalar la biblioteca en el clúster que usa para ejecutar el cuaderno.

Ejemplo

Supongamos que tiene notebookA y notebookB . notebookA contiene una celda que tiene el siguiente código de Python:

x = 5

Aunque no definió en x , puede acceder a en después de ejecutar notebookB x notebookB %run notebookA .

%run /Users/path/to/notebookA

print(x) # => 5

Para especificar una ruta de acceso relativa, preceda a ./ o ../ . Por ejemplo, si notebookA y están en el mismo notebookB directorio, también puede ejecutarlos desde una ruta de acceso relativa.

%run ./notebookA

print(x) # => 5
%run ../someDirectory/notebookA # up a directory and into another

print(x) # => 5

Para interacciones más complejas entre cuadernos, consulte Flujos de trabajo de cuadernos.

Administración del estado y los resultados del cuaderno

Después de adjuntar un cuaderno a un clúster y ejecutar una ovarias celdas, el cuaderno tiene estado y muestra los resultados. En esta sección se describe cómo administrar el estado y los resultados del cuaderno.

En esta sección:

Borrar el estado y los resultados de los cuadernos

Para borrar el estado y los resultados del cuaderno, haga clic en Borrar en la barra de herramientas del cuaderno y seleccione la acción:

Borrar el estado y los resultados

Descarga de resultados

De forma predeterminada, los resultados de descarga están habilitados. Para alternar esta configuración, consulte Administración de la capacidad de descargar resultados de cuadernos. Si la descarga de resultados está deshabilitada, el  botón Descargar resultado no está visible.

Descarga de un resultado de celda

Puede descargar un resultado de celda que contenga la salida tabular en la máquina local. Haga clic en la pestaña Resultado de descarga en la parte inferior de una celda.

Descarga de los resultados de la celda

Un archivo CSV denominado export.csv se descarga en el directorio de descarga predeterminado.

Descarga de resultados completos

De forma Azure Databricks devuelve 1000 filas de un dataframe. Cuando hay más de 1000 filas, una flecha hacia abajo Botón abajo se agrega a Resultado de descarga . Para descargar todos los resultados de una consulta:

  1. Haga clic en la flecha abajo situada junto  a Descargar resultado y seleccione Descargar resultados completos.

    Descarga de resultados completos

  2. Seleccione Volver a ejecutar y descargar.

    Volver a ejecutar y descargar los resultados

    Después de descargar los resultados completos, se descarga un archivo CSV denominado en el equipo local y la carpeta tiene una carpeta generada que contiene todos los resultados export.csv /databricks-results de la consulta.

    Resultados descargados

Ocultar y mostrar contenido de celda

El contenido de la celda consta de código de celda y el resultado de ejecutar la celda. Puede ocultar y mostrar el código de celda y el resultado mediante el menú de acciones de celda. Acciones de celda en la parte superior derecha de la celda.

Para ocultar el código de celda:

  • Haga clic  en El icono de careta hacia abajo y seleccione Ocultar código.

Para ocultar y mostrar el resultado de la celda, realice una de las acciones siguientes:

  • Haga clic  en El icono de careta hacia abajo y seleccione Ocultar resultado.
  • Seleccionar Minimización de celdas
  • Escriba Esc > Mayús + o

Para mostrar el código o los resultados de celdas ocultas, haga clic en Mostrar vínculos:

Mostrar código oculto y resultados

Consulte también Encabezados contraíbles.

Aislamiento de cuadernos

El aislamiento de cuadernos hace referencia a la visibilidad de variables y clases entre cuadernos. Azure Databricks admite dos tipos de aislamiento:

  • Aislamiento de variables y clases
  • Aislamiento de sesión de Spark

Nota

Puesto que todos los cuadernos asociados al mismo clúster se ejecutan en las mismas máquinas virtuales de clúster, incluso con el aislamiento de sesión de Spark habilitado no hay ningún aislamiento de usuario garantizado dentro de un clúster.

Aislamiento de variables y clases

Las variables y clases solo están disponibles en el cuaderno actual. Por ejemplo, dos cuadernos asociados al mismo clúster pueden definir variables y clases con el mismo nombre, pero estos objetos son distintos.

Para definir una clase que sea visible para todos los cuadernos asociados al mismo clúster, defina la clase en una celda de paquete. A continuación, puede acceder a la clase mediante su nombre completo, que es el mismo que el acceso a una clase en una biblioteca de Scala o Java adjunta.

Aislamiento de sesión de Spark

Todos los cuadernos asociados a un clúster Apache Spark 2.0.0 y posteriores tienen una variable predefinida denominada que spark representa un SparkSession . SparkSession es el punto de entrada para usar las API de Spark, así como para establecer configuraciones en tiempo de ejecución.

El aislamiento de sesión de Spark está habilitado de forma predeterminada. También puede usar vistas temporales globales para compartir vistas temporales entre cuadernos. Vea Crear vista o CREATE VIEW. Para deshabilitar el aislamiento de sesión de Spark, establezca spark.databricks.session.share en en la configuración de true Spark.

Importante

Establecer spark.databricks.session.share true interrumpe la supervisión que usan las celdas de cuadernos de streaming y los trabajos de streaming. Concretamente:

  • No se muestran los gráficos de las celdas de streaming.
  • Los trabajos no se bloquean mientras se ejecuta una secuencia (simplemente finalizan "correctamente", deteniendo la secuencia).
  • Las secuencias de los trabajos no se supervisan para la terminación. En su lugar, debe llamar manualmente a awaitTermination() .
  • Llamar a la función de visualización en dataframes de streaming no funciona.

Las celdas que desencadenan comandos en otros lenguajes (es decir, las celdas que usan , , y ) y las celdas que incluyen otros %scala %python %r %sql cuadernos (es decir, las celdas que usan ) forman parte del cuaderno %run actual. Por lo tanto, estas celdas están en la misma sesión que otras celdas del cuaderno. Por el contrario, un flujo de trabajo de cuaderno ejecuta un cuaderno con un aislado , lo que significa que las vistas temporales definidas en dicho cuaderno no son SparkSession visibles en otros cuadernos.

Control de versiones

Azure Databricks control de versiones básico para cuadernos. Puede realizar las siguientes acciones en las revisiones: agregar comentarios, restaurar y eliminar revisiones y borrar el historial de revisiones.

Para acceder a las revisiones del cuaderno, haga clic en Historial de revisiones en la parte superior derecha de la barra de herramientas del cuaderno.

En esta sección:

Adición de un comentario

Para agregar un comentario a la revisión más reciente:

  1. Haga clic en la revisión.

  2. Haga clic en el vínculo Guardar ahora.

    Guardar comentario

  3. En el cuadro de diálogo Guardar revisión del cuaderno, escriba un comentario.

  4. Haga clic en Save(Guardar). La revisión del cuaderno se guarda con el comentario especificado.

Restauración de una revisión

Para restaurar una revisión:

  1. Haga clic en la revisión.

  2. Haga clic en Restaurar esta revisión.

    Revisión de restauración

  3. Haga clic en Confirmar. La revisión seleccionada se convierte en la revisión más reciente del cuaderno.

Eliminación de una revisión

Para eliminar la entrada de revisión de un cuaderno:

  1. Haga clic en la revisión.

  2. Haga clic en el icono de papelera. Enviar a la papelera.

    Eliminar revisión

  3. Haga clic en Sí y borre. La revisión seleccionada se elimina del historial de revisiones del cuaderno.

Borrar un historial de revisiones

Para borrar el historial de revisiones de un cuaderno:

  1. Seleccione File > Clear Revision History (Borrar historial de revisiones).

  2. Haga clic en Sí y desactive. Se borra el historial de revisiones del cuaderno.

    Advertencia

    Una vez borrado, el historial de revisiones no se puede recuperar.

Control de versiones de Git

Nota

Para sincronizar el trabajo en Azure Databricks con un repositorio de Git remoto, Databricks recomienda usar Repositorios para la integración de Git.

Azure Databricks también se integra con estas herramientas de control de versiones basadas en Git: