Azure DevOps de cliente

Azure DevOps Services | Azure DevOps Server 2020 | Azure DevOps Server 2019 | TFS 2018- TFS 2013

Nota

Azure DevOps Server anteriormente se denominaba Visual Studio Team Foundation Server.

Varias herramientas y clientes se conectan a Azure DevOps Services y a la plataforma local, Azure DevOps Server, anteriormente denominada Visual Studio Team Foundation Server (TFS). Aquí puede obtener información sobre qué versiones de exploradores y clientes pueden Azure DevOps, así como el servidor de compilación Azure DevOps local.

Para obtener más información sobre los clientes admitidos, vea Qué herramientas y clientes se conectan a Azure DevOps.

Exploradores compatibles con el portal web

Para conectarse con el portal web, puede usar los siguientes exploradores con Azure DevOps Services y Azure DevOps local. Edge, Firefox y Chrome se actualizan automáticamente, por lo Azure DevOps admite la versión más reciente.

Versión Borde Internet Explorer Safari (Mac) Firefox Chrome
Azure DevOps Services
Azure DevOps Server 2020.1
Más recientes No compatible 14.1 y versiones posteriores Más recientes Más recientes
Azure DevOps Server 2020 Más recientes 11 y versiones posteriores 14.1 y versiones posteriores Más recientes Más recientes
Azure DevOps Server 2019
TFS 2018
TFS 2017
Más recientes 11 y versiones posteriores 14.1 y versiones posteriores Más recientes Más recientes
TFS 2015 Más recientes 9 y versiones posteriores 5 y versiones posteriores Más recientes Más recientes
TFS 2013 9 y versiones posteriores 5 y versiones posteriores Más recientes Más recientes

Visual Studio y Team Explorer

Hay tres niveles de compatibilidad de cliente con diferentes versiones de Visual Studio y Team Explorer. Solo la versión más reciente tiene compatibilidad completa con la versión Azure DevOps servidor local porque es el único cliente:

  • Esto incluye componentes que pueden interfaces con nuevas características para esa versión.
  • Puede usar para ejecutar determinadas tareas administrativas, como la creación de nuevos proyectos.

Las versiones anteriores tienen distintos niveles de compatibilidad en función de su antigüedad.

En la tabla siguiente se describe el nivel de compatibilidad garantizado con cada versión de cliente. Una funcionalidad adicional que no sea la que se muestra aquí podría seguir funcionando si usa clientes más antiguos. A menudo funciona, pero está fuera del ámbito de lo que se ha probado y admitido oficialmente.

Visual Studio/Team Explorer Azure DevOps Services
Azure DevOps Server 2020 y 2019
TFS 2018
TFS 2017 y notas de soporte técnico
Notas de soporte técnico de TFS 2015 Notas de compatibilidad con TFS 2013 Notas de compatibilidad con TFS 2012 Notas de compatibilidad con TFS 2010
Visual Studio 2019/Team Explorer 2019 Compatibilidad completa Alto nivel de compatibilidad Alto nivel de compatibilidad Alto nivel de compatibilidad Alto nivel de compatibilidad
Visual Studio 2017/Team Explorer 2017 Compatibilidad completa Alto nivel de compatibilidad Alto nivel de compatibilidad Alto nivel de compatibilidad Alto nivel de compatibilidad
Visual Studio 2015/Team Explorer 2015 Alto nivel de compatibilidad Compatibilidad completa Alto nivel de compatibilidad Alto nivel de compatibilidad Alto nivel de compatibilidad
Visual Studio/Team Explorer 2013 Compatibilidad general Alto nivel de compatibilidad Compatibilidad completa Alto nivel de compatibilidad Alto nivel de compatibilidad
Visual Studio/Team Explorer 2012 Soporte general. Compatible con Git con la extensión de Visual Studio Tools para Git. Soporte general. Compatible con Git con la extensión de Visual Studio Tools para Git. Alto nivel de compatibilidad. Compatible con Git con la extensión de Visual Studio Tools para Git. Totalmente compatible. Compatible con Git con la extensión de Visual Studio Tools para Git. Alto nivel de compatibilidad
Visual Studio/Team Explorer 2010 Compatibilidad general (SP1 y GDR de compatibilidad) Compatibilidad general (SP1 y GDR de compatibilidad) Compatibilidad general (SP1 y GDR de compatibilidad) Alto nivel de compatibilidad (SP1 y GDR de compatibilidad) Compatibilidad completa (SP1 y GDR de compatibilidad)
Visual Studio/Team Explorer 2008 Control de versiones disponible mediante el proveedor de MSSCCI Control de versiones disponible mediante el proveedor de MSSCCI Control de versiones disponible mediante el proveedor de MSSCCI Control de versiones disponible mediante el proveedor de MSSCCI Control de versiones disponible mediante el proveedor de MSSCCI
Visual Studio 2005 Control de versiones disponible mediante el proveedor de MSSCCI Control de versiones disponible mediante el proveedor de MSSCCI Control de versiones disponible mediante el proveedor de MSSCCI Control de versiones disponible mediante el proveedor de MSSCCI Control de versiones disponible mediante el proveedor de MSSCCI

Cualquier Azure DevOps Server o funcionalidad orientada a TFS expuesta en la interfaz de usuario de Visual Studio y Team Explorer deben funcionar. Se garantiza la compatibilidad con todas las características entre cliente y servidor de la misma versión.

Nota

Si usa la versión más reciente de Visual Studio pero planea seguir usando la versión anterior más reciente de Team Foundation Server, ya sea temporal o permanentemente, puede esperar un alto nivel de compatibilidad. Se admiten todos los escenarios no administrativos.

Alto nivel de compatibilidad

Si está en TFS 2015 y ejecuta la versión anterior más reciente de Visual Studio o Team Explorer, por ejemplo, Visual Studio 2013, puede esperar soporte técnico de Visual Studio para la mayoría de las características. Es posible que tenga que instalar la actualización más reciente. Después de la instalación, se admiten escenarios de línea principal para todos los roles que no son de administrador.

Esta compatibilidad es para las características que los desarrolladores y evaluadores necesitan para continuar con su trabajo diario. Estas características se usan para poner en cola compilaciones, ejecutar consultas, ver documentos y obtener, editar y comprobar archivos. Los administradores de programas también deben poder seguir usando la mayoría de las características pertinentes para ellos. Es posible que deba basarse en el acceso web para algunos escenarios. Estos escenarios se producen cuando administran áreas e iteraciones y escriben nuevas consultas.

Si usa versiones más recientes de Visual Studio versiones anteriores de Team Foundation Server, puede esperar que se admiten la mayoría de las características.

Las plantillas de proceso anteriores que se usaban con la versión anterior de Team Foundation Server deberían seguir siendo compatibles con el nuevo servidor.

Compatibilidad general

Si un cliente tiene dos versiones anteriores al servidor, puede esperar soporte técnico general después de instalar un GDR de compatibilidad. Esta compatibilidad es similar al alto nivel de compatibilidad que se ve cuando Visual Studio es una versión anterior a Azure DevOps Server o TFS. La experiencia de algunos escenarios que no son de línea principal podría degradarse, pero no bloquearse por completo. Los usuarios que no son administradores deben poder continuar sin intervención en su trabajo diario. Las plantillas de proceso anteriores deben seguir siendo compatibles con el nuevo servidor.

Compatibilidad con MSSCCI

Visual Studio/Team Explorer 2008 y Visual Studio 2005 ya no son compatibles oficialmente. Para conectarse al servidor, estos clientes deben hacerlo a través de MSSCCI Provider. La compatibilidad con MSSCCI solo incluye compatibilidad con la integración del control de código fuente y los comandos de MSSCCI. El objetivo es permitir que los desarrolladores sigan trabajando con aplicaciones heredadas en un servidor actualizado.

Team Explorer Everywhere

Las nuevas versiones de Team Explorer Everywhere se lanzan a través de GitHub y eclipse Marketplace. Para maximizar la compatibilidad con la versión más reciente de Azure DevOps Server o TFS, use la versión más reciente de Team Explorer Everywhere. Si necesita compatibilidad con una versión anterior de Eclipse, Java o un sistema operativo, use una versión anterior de Team Explorer Everywhere que abarque el intervalo que necesita. También se pueden instalar varias versiones de Team Explorer Everywhere en paralelo si ejecuta varias versiones de Eclipse.

Team Explorer Everywhere Versión de Eclipse Azure DevOps Services
Azure DevOps Server 2020 y 2019
TFS 2012 - TFS 2018
TFS 2010 TFS 2008 TFS 2005
Team Explorer Everywhere 14.114.0+ Eclipse 4.2-4.7
Team Explorer Everywhere 2015 Eclipse 3.5-4.3
Team Explorer Everywhere 2013 Eclipse 3.5-4.3
Team Explorer Everywhere 2012 Eclipse 3.4-4.3
Team Explorer Everywhere 2010 SP1 Eclipse 3.2-3.6
Team Explorer Everywhere 2010 Eclipse 3.0-3.5

Microsoft Office integración

Microsoft Office integración con Azure DevOps admite los siguientes clientes:

Importante

A partir de Azure DevOps Server 2019 y Visual Studio 2019, el complemento Team Foundation para Office está desusando la compatibilidad con Microsoft Project y Microsoft PowerPoint con storyboard. Project integración y el comando TFSFieldMapping no se admiten para Azure DevOps Server 2019 y versiones posteriores, ni para Azure DevOps Services. El complemento sigue siendo compatible con Microsoft Excel.

Azure DevOps versión Versiones Office compatibles
Azure DevOps Services Office 2016
Office 2013
Office 2010
Azure DevOps Server 2020 Office 2016
Office 2013
Office 2010
Azure DevOps Server 2019 Office 2016
Office 2013
Office 2010
TFS 2018 Office 2016
Office 2013
Office 2010
TFS 2017 Office 2016
Office 2013
Office 2010
TFS 2015 Office 2013
Office 2010
Office 2007
TFS 2013 Office 2013
Office 2010
Office 2007
TFS 2012 Office 2010
Office 2007
TFS 2010 Office 2010
Office 2007
  • Si usa SharePoint con TFS 2017 o versiones anteriores, debe agregar SP2 a Office 2007 y SP1 a Office 2010 para la integración entre Office y SharePoint.
  • SharePoint 2010 no admite Office 2013.

Controladores y agentes de compilación de TFS

Un nuevo sistema de compilación que permite scripts es basado en web y multiplataforma.

Versión Versiones de compilación de TFS admitidas
Azure DevOps Server 2020 Agente de compilación de TFS 2018
Agente de compilación de TFS 2017
Controlador XAML de TFS 2015
Controlador XAML de TFS 2013
Controlador XAML de TFS 2010
Nota: Debe actualizar a TFS 2018.2 o posterior para usar compilaciones XAML.
Azure DevOps Server 2019 Agente de compilación de TFS 2018
Agente de compilación de TFS 2017
Controlador XAML de TFS 2015
Controlador XAML de TFS 2013
Controlador XAML de TFS 2010
Nota: Debe actualizar a TFS 2018.2 o posterior para usar compilaciones XAML.
TFS 2018 Agente de compilación de TFS 2018
Agente de compilación de TFS 2017
Controlador XAML de TFS 2015
Controlador XAML de TFS 2013
Controlador XAML de TFS 2010
Nota: Debe actualizar a TFS 2018.2 o posterior para usar compilaciones XAML.
TFS 2017 Agente de compilación de TFS 2017
Agente de compilación de TFS 2015
Controlador XAML de TFS 2015
Controlador XAML de TFS 2013
Controlador XAML de TFS 2010
TFS 2015 Agente de compilación de TFS 2015
Controlador XAML de TFS 2015
Controlador XAML de TFS 2013
Controlador XAML de TFS 2010
TFS 2013 Controlador XAML de TFS 2013
Controlador XAML de TFS 2012
Controlador XAML de TFS 2010
TFS 2012 Controlador XAML de TFS 2012
Controlador XAML de TFS 2010
TFS 2010 Controlador XAML de TFS 2010

Es posible que quiera usar una versión anterior de Build si tiene previsto seguir usando:

  • El sistema de compilación XAML.
  • Compile servidores en varias versiones de TFS.
  • Servidores con sistemas operativos antiguos en la implementación de TFS.

Los controladores XAML de TFS 2010 admiten sistemas operativos hasta Windows XP y Windows Server 2003.