Configuración de BFD a través de ExpressRouteConfigure BFD over ExpressRoute

ExpressRoute admite la detección de reenvío bidireccional (BFD) a través del emparejamiento privado y el emparejamiento de Microsoft.ExpressRoute supports Bidirectional Forwarding Detection (BFD) both over private and Microsoft peering. Al habilitar BFD en ExpressRoute, puede acelerar la detección de errores de los vínculos entre los dispositivos perimetrales de Microsoft Enterprise (MSEE) y los enrutadores que el circuito de ExpressRoute haya configurado (CE/PE).When you enable BFD over ExpressRoute, you can speed up the link failure detection between Microsoft Enterprise edge (MSEE) devices and the routers that your ExpressRoute circuit gets configured (CE/PE). Puede configurar ExpressRoute a través de los dispositivos de enrutamiento perimetrales o los dispositivos de enrutamiento perimetrales asociados (si ha optado por usar el servicio administrado de conexión de nivel 3).You can configure ExpressRoute over your edge routing devices or your Partner Edge routing devices (if you went with managed Layer 3 connection service). Este documento explica en detalle la necesidad de BFD y cómo habilitar BFD a través de ExpressRoute.This document walks you through the need for BFD, and how to enable BFD over ExpressRoute.

Necesidad de BFDNeed for BFD

El siguiente diagrama muestra la ventaja de habilitar BFD a través del circuito de ExpressRoute: 1The following diagram shows the benefit of enabling BFD over ExpressRoute circuit: 1

Puede habilitar el circuito de ExpressRoute mediante conexiones de nivel 2 o de nivel 3 administradas.You can enable ExpressRoute circuit either by Layer 2 connections or managed Layer 3 connections. En ambos casos, si hay más de un dispositivo de nivel 2 en la ruta de acceso de conexión de ExpressRoute, la responsabilidad de detectar los errores de los vínculos en la ruta de acceso es de la sesión BGP superpuesto.In both cases, if there are more than one Layer-2 devices in the ExpressRoute connection path, the responsibility of detecting any link failures in the path lies with the overlying BGP session.

En los dispositivos MSEE, el protocolo de puerta de enlace de borde para mantener la conexión y de tiempo de espera, generalmente se configura en 60 y 180 segundos respectivamente.On the MSEE devices, BGP keep-alive and hold-time are typically configured as 60 and 180 seconds respectively. Por esa razón, cuando se produce un error de vínculo, el proceso puede tardar hasta tres minutos en detectar cualquier error de vínculo y cambiar el tráfico a una conexión alternativa.For that reason when a link failure happens it can take up to three minutes to detect any link failure and switch traffic to alternate connection.

Puede controlar los temporizadores de BGP mediante una configuración con valores inferiores de BGP para mantener la conexión y de tiempo de espera en el dispositivo de emparejamiento perimetral.You can control the BGP timers by configuring a lower BGP keep-alive and hold-time on your edge peering device. Si los temporizadores de BGP no son los mismos entre los dos dispositivos de emparejamiento, la sesión BGP se establecerá con el valor de hora más bajo.If the BGP timers aren't the same between the two peering devices, the BGP session will establish using the lower time value. El tipo de BGP para mantener la conexión se puede establecer con un valor tan bajo como tres segundos, y el de tipo de tiempo de espera, en unos diez segundos.The BGP keep-alive can be set as low as three seconds, and the hold-time as low as 10 seconds. Sin embargo, no se recomienda establecer un temporizador de BGP demasiado agresivo, ya que el protocolo requiere un uso intensivo del proceso.However, setting a very aggressive BGP timer is not recommended because the protocol is process intensive.

En este escenario, BFD puede ayudar.In this scenario, BFD can help. BFD proporciona detección de errores de vínculo de baja sobrecarga en un intervalo de tiempo de subsegundos.BFD provides low-overhead link failure detection in a subsecond time interval.

Habilitación del BFDEnabling BFD

BFD está configurado de forma predeterminada en todas las recién creadas interfaces de emparejamiento privadas de ExpressRoute en los MSEE.BFD is configured by default under all the newly created ExpressRoute private peering interfaces on the MSEEs. Por lo tanto, para habilitar BFD, solo tiene que configurar BFD en los dispositivos principal y secundario.As such, to enable BFD, you only need to configure BFD on both your primary and secondary devices. Tenga en cuenta que la configuración de BFD es un proceso de dos pasos.Configuring BFD is two-step process. Tiene que configurar BFD en la interfaz y luego vincularlo a la sesión de BGP.You configure the BFD on the interface and then link it to the BGP session.

A continuación se muestra un ejemplo de configuración de CE/PE (con Cisco IOS XE).An example CE/PE (using Cisco IOS XE) configuration is shown below.

interface TenGigabitEthernet2/0/0.150
   description private peering to Azure
   encapsulation dot1Q 15 second-dot1q 150
   ip vrf forwarding 15
   ip address 192.168.15.17 255.255.255.252
   bfd interval 300 min_rx 300 multiplier 3


router bgp 65020
   address-family ipv4 vrf 15
      network 10.1.15.0 mask 255.255.255.128
      neighbor 192.168.15.18 remote-as 12076
      neighbor 192.168.15.18 fall-over bfd
      neighbor 192.168.15.18 activate
      neighbor 192.168.15.18 soft-reconfiguration inbound
   exit-address-family

Nota

Para habilitar BFD en un emparejamiento privado ya existente; tiene que restablecer el emparejamiento.To enable BFD under an already existing private peering; you need to reset the peering. Consulte Restablecimiento de emparejamientos de ExpressRoute.See Reset ExpressRoute peerings

Negociación de temporizador BFDBFD Timer Negotiation

Entre pares BFD, el más lento de los dos pares determina la velocidad de transmisión.Between BFD peers, the slower of the two peers determine the transmission rate. Los intervalos de transmisión y recepción de los MSEE BFD se establecen en 300 milisegundos.MSEEs BFD transmission/receive intervals are set to 300 milliseconds. En determinados escenarios, el intervalo puede establecerse en un valor superior a 750 milisegundos.In certain scenarios, the interval may be set at a higher value of 750 milliseconds. Al configurar un valor mayor, puede forzar que estos intervalos sean más largos, pero no es posible hacerlos más cortos.By configuring a higher value, you can force these intervals to be longer but it's not possible to make them shorter.

Nota

Si ha configurado circuitos de ExpressRoute con redundancia geográfica o usa la conectividad VPN de IPSec de sitio a sitio como copia de seguridad,If you have configured Geo-redundant ExpressRoute circuits or use Site-to-Site IPSec VPN connectivity as backup. habilitar BFD le permitirá realizar la conmutación por error más rápido después de que se haya producido un error de conectividad de ExpressRoute.Enabling BFD would help failover quicker following an ExpressRoute connectivity failure.

Pasos siguientesNext Steps

Para obtener más información, consulte los siguientes artículos:For more information or help, check out the following links: