Tutorial: Implementar el programa (C++)Walkthrough: Deploying Your Program (C++)

Ahora que ha creado la aplicación completando los tutoriales relacionados anteriores, el último paso es crear un instalador para que otros usuarios puedan instalar el programa en sus equipos.Now that you've created your application by completing the earlier related walkthroughs, the last step is to create an installer so that other users can install the program on their computers. Para el instalador, agregue un nuevo proyecto a la solución existente.For the installer, you'll add a new project to your existing solution. El resultado de este nuevo proyecto es un archivo setup.exe que instalará la aplicación en otro equipo.The output of this new project is a setup.exe file that will install your app on another computer.

En este tutorial se muestra cómo utilizar Windows Installer para implementar la aplicación.The walkthrough shows how to use Windows Installer to deploy your application. También puede utilizar ClickOnce para implementar una aplicación.You can also use ClickOnce to deploy an application. Para obtener más información, vea ClickOnce Deployment for Visual C++ Applications.For more information, see ClickOnce Deployment for Visual C++ Applications. Para obtener más información sobre el desarrollo en general, vea Implementar aplicaciones, servicios y componentes.For more information about deployment in general, see Deploying Applications, Services, and Components.

Requisitos previosPrerequisites

  • En el tutorial se da por supuesto que conoce los fundamentos del lenguaje C++.The walkthrough assumes that you understand the fundamentals of the C++ language.

  • También se presupone que ha completado los tutoriales relacionados anteriores que se enumeran en Usar el IDE de Visual Studio para desarrollo de escritorio de C++.It also assumes that you've completed the earlier related walkthroughs that are listed in Using the Visual Studio IDE for C++ Desktop Development.

  • El tutorial no se puede completar en las ediciones Express de Visual Studio.The walkthrough can't be completed in Express editions of Visual Studio.

Instalar la plantilla de proyecto de implementación y configuración de Visual StudioInstall the Visual Studio setup and deployment project template

Los pasos descritos en esta sección varían según la versión de Visual Studio que tenga instalada.The steps in this section vary depending on which version of Visual Studio you have installed. Para ver la documentación de su versión preferida de Visual Studio, use el control de selector Versión.To see the documentation for your preferred version of Visual Studio, use the Version selector control. Se encuentra en la parte superior de la tabla de contenido de esta página.It's found at the top of the table of contents on this page.

Para instalar la plantilla de proyecto de implementación y configuración de Visual Studio 2019To install the setup and deployment project template for Visual Studio 2019

  1. Si aún no lo ha hecho, descargue la extensión de proyectos del Instalador de Microsoft Visual Studio.If you haven't already done so, download the Microsoft Visual Studio Installer Projects extension. La extensión es gratis para desarrolladores de Visual Studio y agrega la funcionalidad de las plantillas de proyecto de instalación e implementación a Visual Studio.The extension is free for Visual Studio developers and adds the functionality of the setup and deployment project templates to Visual Studio. Cuando esté conectado a Internet, en Visual Studio, elija Extensiones > Administrar extensiones.When you're connected to the Internet, in Visual Studio, choose Extensions > Manage Extensions. En el cuadro de diálogo Extensiones y actualizaciones , seleccione la pestaña En línea y escriba Proyectos del instalador de Microsoft Visual Studio en el cuadro de búsqueda.Under the Extensions and Updates dialog, select the Online tab and type Microsoft Visual Studio Installer Projects in the search box. Presione ENTRAR , seleccione Microsoft Visual Studio <version> Proyectos del instalador y haga clic en Descargar.Hit Enter , select Microsoft Visual Studio <version> Installer Projects , and click Download. Opte por ejecutar e instalar la extensión y, a continuación, reinicie Visual Studio.Choose to run and install the extension, then restart Visual Studio.

  2. En la barra de menús de Visual Studio, seleccione Archivo > Proyectos y soluciones recientes y, después, elija la opción para volver a abrir el proyecto.On the Visual Studio menu bar, choose File > Recent Projects and Solutions , and then choose to reopen your project.

  3. En la barra de menús, seleccione Archivo > Nuevo > Proyecto para abrir el cuadro de diálogo Crear nuevo proyecto.On the menu bar, choose File > New > Project to open the Create a New Project dialog box. En el cuadro de búsqueda, escriba "Setup" y, en la lista de resultados, elija Proyecto de instalación.In the search box, type "Setup" and from the results list choose Setup Project.

  4. Escriba un nombre para el proyecto de instalación en el cuadro Nombre.Enter a name for the setup project in the Name box. En la lista desplegable Solución , seleccione Agregar a la solución.In the Solution drop-down list, select Add to solution. Haga clic en el botón Aceptar para crear el proyecto de instalación.Choose the OK button to create the setup project. Se abre una pestaña Asistente de archivos (ProjectName) en la ventana del editor.A File Assistant (ProjectName) tab opens in the editor window.

  5. Haga clic con el botón derecho en el nodo Carpeta de la aplicación y seleccione Agregar > Resultados del proyecto para abrir el cuadro de diálogo Agregar grupo de resultados del proyecto.Right-click the Application Folder node and select Add > Project Output to open the Add Project Output Group dialog box.

  6. En el cuadro de diálogo, seleccione Resultado principal y haga clic en Aceptar.In the dialog box, select Primary Output and click OK. Aparece un nuevo elemento denominado Resultado principal de Game (activo).A new item named Primary Output from Game (Active) appears.

  7. Seleccione el elemento Resultado principal de Game (activo) , haga clic con el botón derecho y elija Crear acceso directo al resultado principal de Game (activo).Select the item Primary Output from Game (Active) , right-click and choose Create Shortcut to Primary Output from Game (Active). Aparece un nuevo elemento denominado Acceso directo al resultado principal de Game (activo).A new item named Shortcut to Primary Output from Game (Active) appears.

  8. Cambie el nombre del elemento de acceso directo por Game , arrastrar y colocar el elemento en el nodo Menú Programas del usuario en el lado izquierdo de la ventana.Rename the shortcut item to Game , then drag and drop the item into the User's Programs Menu node on the left side of the window.

  9. En el Explorador de soluciones , seleccione el proyecto Game Installer y elija Ver > Ventana Propiedades o presione F4 para abrir la ventana Propiedades.In Solution Explorer , select the Game Installer project and choose View > Properties Window or hit F4 to open the Properties window.

  10. Especifique detalles adicionales como desee que aparezcan en el instalador.Specify additional details as you want them to appear in the installer. Por ejemplo, use Contoso para Fabricante , Game Installer para Nombre de producto y https://www.contoso.com para Dirección URL de soporte.For example, use Contoso for Manufacturer , Game Installer for Product Name , and https://www.contoso.com for SupportUrl.

  11. En la barra de menús, elija Compilar > Administrador de configuración.On the menu bar, choose Build > Configuration Manager. En la tabla Proyecto , en la columna Compilar , marque la casilla Game Installer.In the Project table, under the Build column, check the box for Game Installer. Haga clic en Cerrar.Click Close.

  12. En la barra de menús, seleccione Compilar > Compilar solución para compilar los proyectos Game y Game Installer.On the menu bar, choose Build > Build Solution to build the Game project and the Game Installer project.

  13. En la carpeta de soluciones, busque el programa setup.exe compilado del proyecto de instalador de juego y después ejecútelo para instalar la aplicación de juego en el equipo.In the solution folder, locate the setup.exe program that was built from the Game Installer project, and then run it to install the Game application on your computer. Puede copiar este archivo, y también el archivo GameInstaller.msi, para instalar la aplicación y sus archivos de biblioteca necesarios en otro equipo.You can copy this file (and GameInstaller.msi) to install the application and its required library files on another computer.

Para instalar la plantilla de proyecto de implementación y configuración de Visual Studio 2017 y versiones anterioresTo install the setup and deployment project template for Visual Studio 2017 and earlier

  1. Cuando esté conectado a Internet, en Visual Studio, elija Herramientas > Extensiones y actualizaciones.When you're connected to the Internet, in Visual Studio, choose Tools > Extensions and Updates.

  2. En Extensiones y actualizaciones , seleccione la pestaña En línea y escriba Proyectos del instalador de Microsoft Visual Studio en el cuadro de búsqueda.Under Extensions and Updates , select the Online tab and type Microsoft Visual Studio Installer Projects in the search box. Presione ENTRAR , seleccione Microsoft Visual Studio <version> Proyectos del instalador y haga clic en Descargar.Hit Enter , select Microsoft Visual Studio <version> Installer Projects , and click Download.

  3. Opte por instalar la extensión y, a continuación, reinicie Visual Studio.Choose to install the extension, then restart Visual Studio.

  4. En la barra de menús, seleccione Archivo > Proyectos y soluciones recientes y, después, elija la solución Game para volver a abrirla.On the menu bar, choose File > Recent Projects and Solutions , and then choose the Game solution to reopen it.

Para crear un proyecto de instalación e instalar su programaTo create a setup project and install your program

  1. Cambie la configuración de soluciones activa a Lanzamiento.Change the active solution configuration to Release. En la barra de menús, elija Compilar > Administrador de configuración.On the menu bar, choose Build > Configuration Manager. En el cuadro de diálogo Administrador de configuración , en la lista desplegable Configuración de soluciones activas , seleccione Release.In the Configuration Manager dialog box, on the Active solution configuration drop-down list, select Release. Haga clic en el botón Cerrar para guardar la configuración.Choose the Close button to save the configuration.

  2. En la barra de menús, seleccione Archivo > Nuevo > Proyecto para abrir el cuadro de diálogo Nuevo proyecto.On the menu bar, choose File > New > Project to open the New Project dialog box.

  3. En el panel de la izquierda del cuadro de diálogo, expanda los nodos Instalado > Otros tipos de proyectos y después seleccione Instalador de Visual Studio.In the left pane of the dialog box, expand the Installed > Other Project Types nodes, and then select Visual Studio Installer. En el panel central, seleccione Proyecto de instalación.In the center pane, select Setup Project.

  4. Escriba un nombre para el proyecto de instalación en el cuadro Nombre.Enter a name for the setup project in the Name box. Para este ejemplo, escriba Game Installer.For this example, enter Game Installer. En la lista desplegable Solución , seleccione Agregar a la solución.In the Solution drop-down list, select Add to solution. Haga clic en el botón Aceptar para crear el proyecto de instalación.Choose the OK button to create the setup project. Se abrirá una pestaña Asistente para archivos (Game Installer) en la ventana del editor.A File Assistant (Game Installer) tab opens in the editor window.

  5. Haga clic con el botón derecho en el nodo Carpeta de la aplicación y seleccione Agregar > Resultados del proyecto para abrir el cuadro de diálogo Agregar grupo de resultados del proyecto.Right-click the Application Folder node and select Add > Project Output to open the Add Project Output Group dialog box.

  6. En el cuadro de diálogo, seleccione Resultado principal y haga clic en Aceptar.In the dialog box, select Primary Output and click OK. Aparece un nuevo elemento denominado Resultado principal de Game (activo).A new item named Primary Output from Game (Active) appears.

  7. Seleccione el elemento Resultado principal de Game (activo) , haga clic con el botón derecho y elija Crear acceso directo al resultado principal de Game (activo).Select the item Primary Output from Game (Active) , right-click and choose Create Shortcut to Primary Output from Game (Active). Aparece un nuevo elemento denominado Acceso directo al resultado principal de Game (activo).A new item named Shortcut to Primary Output from Game (Active) appears.

  8. Cambie el nombre del elemento de acceso directo por Game , arrastrar y colocar el elemento en el nodo Menú Programas del usuario en el lado izquierdo de la ventana.Rename the shortcut item to Game , then drag and drop the item into the User's Programs Menu node on the left side of the window.

  9. En el Explorador de soluciones , seleccione el proyecto Game Installer y elija Ver > Ventana Propiedades o presione F4 para abrir la ventana Propiedades.In Solution Explorer , select the Game Installer project and choose View > Properties Window or hit F4 to open the Properties window.

  10. Especifique detalles adicionales como desee que aparezcan en el instalador.Specify additional details as you want them to appear in the installer. Por ejemplo, use Contoso para Fabricante , Game Installer para Nombre de producto y https://www.contoso.com para Dirección URL de soporte.For example, use Contoso for Manufacturer , Game Installer for Product Name , and https://www.contoso.com for SupportUrl.

  11. En la barra de menús, elija Compilar > Administrador de configuración.On the menu bar, choose Build > Configuration Manager. En la tabla Proyecto , en la columna Compilar , marque la casilla Game Installer.In the Project table, under the Build column, check the box for Game Installer. Haga clic en Cerrar.Click Close.

  12. En la barra de menús, seleccione Compilar > Compilar solución para compilar los proyectos Game y Game Installer.On the menu bar, choose Build > Build Solution to build the Game project and the Game Installer project.

  13. En la carpeta de soluciones, busque el programa setup.exe compilado del proyecto de instalador de juego y después ejecútelo para instalar la aplicación de juego en el equipo.In the solution folder, locate the setup.exe program that was built from the Game Installer project, and then run it to install the Game application on your computer. Puede copiar este archivo, y también el archivo GameInstaller.msi, para instalar la aplicación y sus archivos de biblioteca necesarios en otro equipo.You can copy this file (and GameInstaller.msi) to install the application and its required library files on another computer.

Pasos a seguirNext Steps

Anterior: Tutorial: Depurar un proyecto (C++)Previous: Walkthrough: Debugging a Project (C++)

Vea tambiénSee also

Referencia del lenguaje C++C++ Language Reference
Proyectos y sistemas de compilaciónProjects and build systems
Implementar aplicaciones de escritorioDeploying Desktop Applications