Plataformas compatibles con aplicaciones MAUI de .NET

Las aplicaciones de interfaz de usuario de aplicaciones multiplataforma (.NET MAUI) de .NET se pueden escribir para las siguientes plataformas:

  • Android 5.0 (API 21) o superior.
  • iOS 10 o superior.
  • macOS 10.15 o superior, usando Mac Catalyst.
  • Windows 11 y Windows 10 versión 1809 o posterior, con la Biblioteca de interfaz de usuario de Windows (WinUI) 3.

Las aplicaciones blazor de .NET MAUI tienen los siguientes requisitos de plataforma adicionales:

  • Se requiere Android 7.0 (API 24) o superior
  • Se requiere iOS 14 o superior.
  • macOS 11 o superior, usando Mac Catalyst.

Las aplicaciones blazor de .NET MAUI también requieren un control WebView específico de la plataforma actualizada. Para más información, consulte Plataformas compatibles con Blazor.

Las aplicaciones MAUI de .NET para Android, iOS y Windows se pueden compilar en Visual Studio. Sin embargo, se requiere un equipo Mac en red para el desarrollo de iOS.

Compatibilidad con plataforma adicional

.NET MAUI admite plataformas adicionales más allá de Android, iOS, macOS y Windows:

  • Tizen, compatible con Samsung.
  • Linux, compatible con la comunidad.