Guía de problemas de red

En esta guía se muestra cómo detectar problemas de red o oportunidades de optimización en el panel red de Microsoft Edge DevTools.

Consulte Introducción a los conceptos básicos del panel red .

Solicitudes en cola o detenidas

Síntomas

Se están descargando seis solicitudes al mismo tiempo. Después de eso, una serie de solicitudes se ponen en cola o se detienen. Una vez finalizada una de las primeras seis solicitudes, se inicia una de las solicitudes de la cola.

En la cascada de la siguiente ilustración, las seis primeras solicitudes del edge-iconx1024.msft.png activo se inician simultáneamente. Las siguientes solicitudes se detienen hasta que se haya completado una de seis originales.

Ejemplo de una serie en cola o detenida en el panel red

Causas

Se están realizando demasiadas solicitudes en un solo dominio. En las conexiones HTTP/1.0 o HTTP/1.1, Microsoft Edge permite un máximo de seis conexiones TCP simultáneas por host.

Arreglos

  • Implemente la particionamiento del dominio si necesita usar HTTP/1.0 o HTTP/1.1.
  • Use HTTP/2. No use el particionamiento del dominio con HTTP/2.
  • Quite o aplaza las solicitudes innecesarias para que las solicitudes críticas se descarguen anteriormente.

Tiempo lento para el primer byte (TTFB)

Síntomas

Una solicitud dedica mucho tiempo a esperar a recibir el primer byte del servidor.

En la siguiente ilustración, la larga barra verde en la cascada indica que la solicitud estaba esperando mucho tiempo. Esto se ha simulado usando un perfil para restringir la velocidad de la red y agregar un retraso.

Ejemplo de una serie en cola o detenida en el panel red

Causas

  • La conexión entre el cliente y el servidor es lenta.
  • El servidor tarda en responder. Aloje el servidor de forma local para determinar si es la conexión o el servidor que es lento. Si sigue demorando el primer byte \ (TTFB ) durante el acceso a un servidor local, entonces el servidor es lento.

Arreglos

  • Si la conexión es lenta, considere la posibilidad de hospedar el contenido en una red CDN o de cambiar los proveedores de hospedaje.
  • Si el servidor es lento, considere la posibilidad de optimizar las consultas de la base de datos, implementar una caché o modificar la configuración del servidor.

Descarga de contenido lento

Síntomas

Una solicitud tarda mucho tiempo en descargarse.

En la siguiente ilustración, la larga barra azul en la cascada que se encuentra junto al formato PNG significa que se ha tardado mucho tiempo en descargarlo.

Ejemplo de una serie en cola o detenida en el panel red

Causas

  • La conexión entre el cliente y el servidor es lenta.
  • Se está descargando una gran cantidad de contenido.

Arreglos

  • Considere la posibilidad de hospedar el contenido en una red CDN o de cambiar proveedores de hospedaje.
  • Reenvíes menos bytes optimizando las solicitudes.

Contactar al equipo de Microsoft Edge DevTools

Use las siguientes opciones para discutir las nuevas características y cambios de la publicación, o cualquier otro tema relacionado con DevTools.

  • Envíe sus comentarios con el icono Enviar comentarios o seleccione Alt + Shift + I \ (Windows, Linux ) o Option + Shift + I \ (MacOS ) en DevTools.
  • Tweet a @EdgeDevTools.
  • Enviar una sugerencia a la webque queremos.
  • Para archivar errores sobre este artículo, use la siguiente sección de comentarios .

El icono enviar comentarios en el DevTools de Microsoft Edge

Nota

Algunas partes de esta página son modificaciones basadas en el trabajo creado y compartido por Google y se usan según las condiciones descritas en la licencia internacional de Creative Commons Atribution 4,0.
La página original se encuentra aquí y está modificada por Kayce vascos \ (redactor técnico, Chrome DevTools \ & Lighthouse ) y Jonathan confuso \ (Google Developer Expert para tecnología web ).

Licencia de Creative Commons
Este trabajo dispone de licencia conforme a Licencia internacional de Creative Commons Attribution 4.0.