Cómo solucionar problemas de documentos dañados en Word

Nota

Office 365 ProPlus pasa a llamarse Microsoft 365 Apps para empresas. Para obtener más información sobre este cambio, lea esta publicación de blog.

Resumen

Este artículo describe cómo identificar un documento dañado en Word 2007 y versiones posteriores. También incluye pasos que explican cómo recuperar el texto y los datos contenidos en un documento después de haber identificado el documento como dañado.

Este artículo está destinado a los usuarios principiantes o de nivel medio. Puede encontrar más fácil seguir los pasos si imprime este artículo primero.

Actualizar Microsoft Office y Windows

Muchos problemas de software pueden resolverse actualizando los programas Microsoft Office y Windows. 

P+F de Windows Update

Instalar actualizaciones de Office

Actualizar Office con Microsoft Update

¿Un documento dañado o un problema de software?

Un documento de Word puede estar dañado por varias razones que le impedirán abrirlo. Este comportamiento se puede relacionar con daños en el documento o en la plantilla en la que se basa el documento. Este comportamiento puede incluir lo siguiente:

  • Se vuelven a numerar las páginas existentes en el documento varias veces
  • Se rehacen los saltos de página en el documento varias veces
  • Diseño y formato del documento incorrectos
  • Caracteres ilegibles en la pantalla
  • Mensajes de error durante los procesos
  • Un equipo que deja de responder al abrir el archivo
  • Cualquier otro comportamiento inesperado no atribuible al funcionamiento normal del programa

A veces, este comportamiento puede deberse a otros factores distintos a los daños en el documento. Es importante determinar si el documento está dañado o si el problema se debe al software. Para eliminar estos otros factores, siga estos pasos:

  1. Busque un comportamiento similar en otros documentos. Intente abrir otros documentos de Word para ver si se produce el mismo problema. Si abren correctamente, el problema puede tener que ver con el documento de Word.
  2. Busque un comportamiento similar en otros programas de Microsoft Office. En este caso, el problema podría darse con otra aplicación o el sistema operativo.

Si alguno de estos pasos indica que el problema no está en el documento, tendrá que investigar si hay problemas en Word, el conjunto de aplicaciones de Office o el sistema operativo que se estén ejecutando en el equipo.

Procedimiento de solución de problemas para probar si el documento dañado no se abre

Pruebe los métodos en el orden indicado. Si uno no funciona, pruebe el siguiente.

Paso 1: configure Word

  1. Inicie Word.
  2. En la pestaña Ver, haga clic en Borrador en el grupo Vistas.
  3. Haga clic en el menú Archivo, en Opciones y luego en Opciones avanzadas.
  4. En la sección Mostrar contenido del documento, seleccione Utilizar fuente de borrador en vistas Borrador y Esquema y Mostrar marcadores de imagen.
  5. Desplácese hacia abajo hasta la sección General, desactive la casilla Actualizar vínculos automáticos al abrir, seleccione Aceptar y luego cierre Word.

Paso 2: abra el documento dañado

  1. Inicie Word.
  2. Seleccione el menú Archivo y haga clic en Abrir.
  3. Haga clic en el documento dañado y luego en Abrir.

Si puede abrir el documento, puede cerrarlo y, a continuación, puede volverlo a abrir utilizando el método 6 y repararlo. De lo contrario, vaya al método 2.

Método 2: inserte el documento como un archivo en otro documento

Paso 1: cree un documento en blanco nuevo

  1. Seleccione el menú Archivo y, a continuación, seleccione Nuevo.

  2. Haga clic en Documento en blanco y después en Crear.

    Nota

    Quizás tenga que volver a aplicar algún formato a la última sección del documento nuevo.

Paso 2: inserte el documento dañado en el documento nuevo

  1. En la pestaña Insertar, haga clic en Insertar objeto y, después, en Insertar texto de archivo.

  2. En el cuadro de diálogo Insertar archivo, busque el documento dañado y haga clic en él. A continuación, seleccione Insertar.

    Nota

    Quizás tenga que volver a aplicar algún formato a la última sección del documento nuevo.

Paso 1: cree un documento en blanco

  1. En Word, haga clic en el menú Archivo y en Nuevo.
  2. Haga clic en Documento en blanco y después en Crear.
  3. En el documento nuevo, escriba "Esto es una prueba".
  4. Haga clic en el menú Archivo y, después, haga clic en Guardar como
  5. Escriba "Rescatar vínculo" y haga clic en Guardar.
  1. Seleccione el texto que escribió en el paso 1-3.
  2. En la pestaña Inicio, haga clic en Copiar en el grupo Portapapeles.
  3. Seleccione el menú Archivo y, a continuación, seleccione Nuevo.
  4. Haga clic en Documento en blanco y después en Crear.
  5. En la pestaña Inicio, haga clic en la flecha del botón Pegar en el grupo Portapapeles y, después, haga clic en Pegado especial.
  6. Haga clic en Pegar vínculo y en Texto con formato (RTF).
  7. Seleccione Aceptar.
  1. Haga clic con el botón derecho en el texto vinculado del documento, seleccione Objeto de documento vinculado y haga clic en Vínculos.

  2. En el cuadro de diálogo Vínculos, haga clic en el nombre de archivo del documento vinculado y, después, en Cambiar origen.

  3. En el cuadro de diálogo Cambiar origen, haga clic en el documento que no puede abrir y después en Abrir.

  4. Haga clic en Aceptar para cerrar el cuadro de diálogo Vínculos.

    Nota

    La información del documento dañado aparecerá si había datos o texto recuperables.

  5. Haga clic con el botón derecho en el texto vinculado, seleccione Objeto de documento vinculado y haga clic en Vínculos.

  6. En el cuadro de diálogo Vínculos, haga clic en Romper vínculo.

  7. Cuando aparezca el mensaje siguiente, haga clic en : ¿Está seguro de que desea cancelar los vínculos seleccionados?

Método 4: use el convertidor Recuperar texto de cualquier archivo

Nota

El convertidor "Recuperar texto de cualquier archivo" tiene algunas limitaciones. Por ejemplo, se pierde el formato del documento. Además, se pierden los gráficos, los campos, los objetos de dibujo y cualquier otro elemento que no sea texto. Sin embargo, el texto de los campos, los encabezados, los pies de página, las notas al pie y las notas al final se conservan como texto simple.

  1. En Word, haga clic en el menú Archivo y en Abrir.
  2. En el cuadro Tipo de archivos, seleccione Recuperar texto de cualquier archivo (.).
  3. Seleccione en el documento del que desea recuperar el texto.
  4. Seleccione Abrir.

Una vez recuperado el documento con el convertidor Recuperar texto de cualquier archivo, hay texto con datos binarios que no se convierten. Este texto está principalmente al principio y al final del documento. Debe eliminar este texto con datos binarios antes de volver a aplicar formato y, a continuación, guardar el archivo como un documento de Word.

Nota

En Word 2007 no hay botón de archivo en la interfaz de usuario. En este caso, elija el botón de Office y siga las indicaciones cuando sea necesario.

Procedimiento de solución de problemas para probar si se puede abrir el documento dañado

Método 1: copie todo excepto la última marca de párrafo a otro documento

Paso 1: cree un documento nuevo

  1. En Word, haga clic en Archivo en la cinta de opciones y después haga clic en Nuevo.
  2. Haga clic en Documento en blanco y después en Crear.

Paso 2: abra el documento dañado

  1. En Word, haga clic en Archivo en la cinta de opciones y después haga clic en Abrir.
  2. Haga clic en el documento dañado y luego en Abrir.

Paso 3: copie el contenido del documento y, a continuación, péguelo en el otro documento

Nota

si el documento contiene saltos de sección, copie únicamente el texto que hay entre dichos saltos. No copie los saltos de sección, ya que puede llevar el daño al nuevo documento. Cambie la vista de documento a la vista de borrador cuando copie y pegue entre los documentos para evitar transferir los saltos de sección. Para cambiar a la vista de borrador, en la pestaña Ver, haga clic en Borrador en el grupo Vistas de documento.

  1. En el documento dañado, presione CTRL+FIN y, a continuación, presione CTRL+MÁYUS+INICIO.
  2. En la pestaña Inicio, haga clic en Copiar en el grupo Portapapeles.
  3. En la pestaña Ver, haga clic en Cambiar ventanas en el grupo Ventana.
  4. Haga clic en el nuevo documento que creó en el paso 1.
  5. En la pestaña Inicio, haga clic en Pegar en el grupo Portapapeles.

Si el comportamiento extraño persiste, vaya al método 8.

Método 2: cambie la plantilla que el documento utiliza

Paso 1: averigüe la plantilla que el documento utiliza

  1. Abra el documento dañado en Word.
  2. Haga clic en Archivo en la cinta de opciones y después haga clic en Opciones.
  3. Seleccione Complementos.
  4. En el cuadro Administrar, haga clic en Plantillas bajo Ver y administrar complementos de Office.
  5. Seleccione Ir.

El cuadro Plantilla de documento mostrará la plantilla que el documento utiliza. Si la plantilla mostrada es Normal, vaya al paso 2. De lo contrario, vaya al paso 3.

Paso 2: cambie el nombre de la plantilla global (Normal.dotm).

  1. Salga de Word.
  2. Haga clic en el botón Inicio.
  3. En el sistema operativo, busque normal.dotm. Normalmente se encuentra en esta ubicación: %userprofile%\appdata\roaming\microsoft\templates
  4. Haga clic con el botón derecho en Normal.dotm y, después, haga clic en Cambiar nombre.
  5. Escriba "Oldword.old" y presione ENTRAR.
  6. Cierre el Explorador de Windows.
  7. Inicie Word y, a continuación, abra el documento.

Paso 3: cambie la plantilla de documento

  1. Abra el documento dañado en Word.
  2. Haga clic en Archivo en la cinta de opciones y después haga clic en Opciones.
  3. Seleccione Complementos.
  4. En el cuadro Administrar, haga clic en Plantillas y en Ir.
  5. Seleccione Adjuntar.
  6. En la carpeta Plantillas, haga clic en Normal.dotm y en Abrir.
  7. Haga clic en Aceptar para cerrar el cuadro de diálogo Plantillas y complementos.
  8. Salga de Word.

Paso 4: compruebe que las plantillas cambiadas funcionaban.

  1. Inicie Word.
  2. Haga clic en Archivo en la cinta de opciones y después haga clic en Opciones.
  3. Haga clic en el documento dañado y luego en Abrir.

Si el comportamiento extraño persiste, vaya al método 3.

Método 3: inicie Word utilizando su configuración predeterminada.

Puede utilizar el modificador /a para iniciar Word al usar únicamente la configuración predeterminada. Cuando utilice el modificador /a, Word no cargará ningún complemento. Además, Word no utiliza su plantilla Normal.dotm existente. Reinicie Word con el modificador /a.

Paso 1: inicie Word con el modificador /a

  1. Salga de Word.

  2. Haga clic en el botón Inicio y busque Ejecutar. En el cuadro de diálogo Ejecutar escriba el comando siguiente:

    winword.exe /a

Paso 2: abra el documento

  1. En Word, haga clic en Archivo en la cinta de opciones y después haga clic en Abrir.
  2. Haga clic en el documento dañado y luego en Abrir.

Si el comportamiento extraño persiste, vaya al método 4.

Método 4: cambie los controladores de impresora

Paso 1: pruebe un controlador de impresora diferente

  1. En el sistema operativo, busque Dispositivos e impresoras.
  2. Haga clic en Agregar una impresora.
  3. En el cuadro de diálogo Agregar impresora, haga clic en Agregar una impresora local.
  4. Haga clic en Usar un puerto existente y en Siguiente.
  5. En la lista Fabricantes, haga clic en Microsoft.
  6. Haga clic en Escritor de documentos XPS de Microsoft y en Siguiente.
  7. Haga clic en Usar el controlador actualmente instalado (recomendado) y en Siguiente.
  8. Active la casilla Establecer como impresora predeterminada y, después, haga clic en Siguiente.
  9. Seleccione Finalizar.

Paso 2: compruebe que los controladores de impresora que se han cambiado corrigen el problema

  1. Inicie Word.
  2. En Word, haga clic en Archivo en la cinta de opciones y después haga clic en Abrir.
  3. Haga clic en el documento dañado y luego en Abrir.

Si el comportamiento extraño persiste, vaya al paso 3.

Paso 3: reinstale el controlador de impresora original

Windows 10 y Windows 7

  1. En el sistema operativo, busque Impresoras.

  2. Haga clic con el botón derecho en la impresora predeterminada original y luego haga clic en Eliminar.

    Si tiene que escribir una contraseña de administrador o una confirmación, escriba la contraseña o haga clic en Continuar.

  3. Si se le pregunta si desea quitar todos los archivos asociados a la impresora, haga clic en .

  4. Haga clic en Agregar una impresora y siga las instrucciones del Asistente para agregar impresoras con el fin de volver a instalar el controlador de impresora.

Paso 4: compruebe que los controladores de impresora que se han cambiado corrigen el problema

  1. Inicie Word.
  2. En Word, haga clic en Archivo en la cinta de opciones y después haga clic en Abrir.
  3. Haga clic en el documento dañado y luego en Abrir.

Si el comportamiento extraño persiste, vaya al método 5.

Método 5: haga que Word intente reparar un archivo

Paso 1: repare el documento

En Word, haga clic en Archivo en la cinta de opciones y después haga clic en Abrir.

  1. En el cuadro de diálogo Abrir, haga clic para resaltar su documento de Word.
  2. Haga clic en la flecha situada junto al botón Abrir y luego en Abrir y reparar.

Paso 2: compruebe que al reparar el documento se corrige el problema

Compruebe que el comportamiento extraño ya no se produce. Si dicho comportamiento persiste, reinicie Windows y, a continuación, vaya al método 6.

Método 6: cambie el formato del documento y después conviértalo de nuevo al formato de Word

Paso 1: abra el documento

  1. Inicie Word.
  2. En Word, haga clic en Archivo en la cinta de opciones y después haga clic en Abrir.
  3. Haga clic en el documento dañado y luego en Abrir.

Paso 2: guarde el documento en un formato de archivo diferente

  1. Haga clic en Archivo en la cinta y, a continuación, en Guardar como.
  2. Seleccione Otros formatos.
  3. En la lista Guardar como tipo de archivo, haga clic en Formato de texto enriquecido (*.rtf).
  4. Seleccione Guardar.
  5. En Word, haga clic en Archivo en la cinta de opciones y después haga clic en Cerrar.

Paso 3: abra el documento y, a continuación, conviértalo de nuevo al formato de archivo de Word

  1. En Word, seleccione Archivo y, después, haga clic en Abrir.
  2. Haga clic en el documento convertido y después en Abrir.
  3. Seleccione Archivo y haga clic en Guardar como.
  4. Seleccione Documento de Word como tipo en Guardar como.
  5. Cambie el nombre de archivo del documento y, después, haga clic en Guardar.

Paso 4: compruebe que al convertir el formato de archivo del documento, se corrige el problema

Compruebe que el comportamiento extraño ya no se produce. Si el comportamiento persiste, intente guardar el archivo en otro formato de archivo. Repita los pasos 1 a 4 y, a continuación, intente guardar el archivo en los formatos de archivo siguientes, en el orden indicado:

  • Página web (.htm; .html)
  • Cualquier otro formato de procesamiento de textos
  • Texto sin formato (.txt)

Nota

Guardar un archivo en formato Texto sin formato (.txt) podría reparar el daño en el documento. Sin embargo, se pierde todo el formato, los códigos de macro y los gráficos del documento. Cuando guarda archivos en el formato Texto sin formato (.txt), debe cambiar el formato del documento. Por tanto, utilice el formato Texto sin formato (.txt) solo si los otros formatos de archivo no resuelven el problema.

Si el comportamiento extraño persiste, vaya al método 7.

Método 7: copie las partes ilesas del documento dañado en un documento nuevo

Paso 1: cree un documento nuevo

  1. En Word, haga clic en el menú Archivo y en Nuevo.
  2. Haga clic en Documento en blanco y después en Crear.

Paso 2: abra el documento dañado

  1. Seleccione Archivo y haga clic en Abrir.
  2. Haga clic en el documento dañado y luego en Abrir.

Paso 3: copie las partes ilesas del documento y, a continuación, péguelas en el documento nuevo

Nota

si el documento contiene saltos de sección, copie únicamente el texto que hay entre dichos saltos. No copie los saltos de sección, ya que puede llevar el daño al nuevo documento. Cambie la vista de documento a la vista de borrador cuando copie y pegue entre los documentos para evitar transferir los saltos de sección. Para cambiar a la vista de borrador, en la pestaña Ver, haga clic en Borrador en el grupo Vistas de documento.

  1. En el documento dañado, busque y seleccione una parte ilesa del contenido del documento.
  2. En la pestaña Inicio, haga clic en Copiar en el grupo Portapapeles.
  3. En la pestaña Ver, haga clic en Cambiar ventanas en el grupo Ventana.
  4. Haga clic en el nuevo documento que creó en el paso 1.
  5. En la pestaña Inicio, haga clic en Pegar en el grupo Portapapeles.
  6. Repita los pasos 3a a 3e para cada parte ilesa del documento. Debe reconstruir las secciones dañadas del documento.

Método 8: cambie a la vista de documento para quitar el contenido dañado

Si el documento aparece truncado (no se muestran todas las páginas), es posible que se pueda cambiar a la vista de documento y quitar el contenido dañado.

  1. Determine el número de página en la que el contenido dañado está haciendo que el documento aparezca truncado.

    1. En Word, seleccione Archivo y, después, haga clic en Abrir.
    2. Haga clic en el documento dañado y luego en Abrir.
    3. Desplácese para ver la última página que se muestra antes de que el documento aparezca truncado. Observe y anote el contenido que aparece en esa página.
  2. Cambie las vistas y quite el contenido dañado.

    1. En la pestaña Ver del grupo Vistas de documento, haga clic en la vista Diseño Web o Borrador.
    2. Desplácese para ver el contenido que se mostró antes de que el documento apareciera truncado.
    3. Seleccione y elimine el siguiente párrafo, tabla u objeto en el archivo.
    4. En la pestaña Ver del grupo Vistas de documento, haga clic en Diseño de impresión. Si el documento continúa apareciendo truncado, siga cambiando las vistas y elimine contenido hasta que el documento no aparezca truncado en la vista Diseño de impresión.
    5. Guarde el documento.

Método 9: Abra el documento con el Bloc de notas

Si el documento está dañado y ninguno de los métodos anteriores funciona, intente recuperar su contenido al abrir el documento con el Bloc de notas.

Nota

Al usar este método, perderá todo el formato. La intención es recuperar el contenido.

  1. Localice el documento dañado mediante el Explorador de archivos de Windows.
  2. Haga clic con el botón derecho en el documento y seleccione Abrir con.
  3. Seleccione Bloc de notas:

Abra el documento de Word en el Bloc de notas. 4. El documento se abrirá en el Bloc de notas con código y texto adicionales alrededor del contenido.

Nota

Es posible que tenga que cambiar el tipo de archivo de "Documentos de texto (.txt)" a "Todos los archivos (.*)". 5. Para borrar el texto, elimine todos o la mayoría de los caracteres adicionales. 6. Seleccione Archivo y haga clic en Guardar como. Cambie el nombre del documento para asegurarse de que no sobrescribe el dañado.

Vuelva a Word y abra el nuevo documento. Una vez en Word, puede limpiarlo e intentar aplicar de nuevo el formato perdido.