Requisitos previos de los orígenes de datos de Power BIPower BI Data Source Prerequisites

Para cada proveedor de datos, Power BI admite una versión de proveedor específica en los objetos.For each data provider, Power BI supports a specific provider version on objects. Para obtener más información sobre los orígenes de datos disponibles para Power BI, consulte Orígenes de datos.For more information about data sources available to Power BI, see Data Sources. La tabla siguiente describe estos requisitos.The following table describes these requirements.

Origen de datosData Source ProveedorProvider Versión mínima de proveedorMinimum provider version Versión mínima de origen de datosMinimum data source version Objetos admitidos de origen de datosSupported data source objects Vínculo de descargaDownload link
SQL ServerSQL Server ADO.net (integrado en .Net Framework)ADO.net (built into .Net Framework) .Net Framework 3.5 (únicamente).Net Framework 3.5 (only) SQL Server 2005 o superiorSQL Server 2005+ Tablas/vistas, funciones escalares, funciones de tablaTables/Views, Scalar functions, Table functions Se incluye en .NET Framework 3.5 o superiorIncluded in .NET Framework 3.5 or above
AccessAccess Motor de base de datos de Microsoft Access (ACE)Microsoft Access Database Engine (ACE) ACE 2010 SP1ACE 2010 SP1 Sin restricciónNo restriction Tablas/vistasTables/Views Vínculo de descargaDownload link
Excel (únicamente archivos .xls) (ver nota 1)Excel (.xls files only) (see note 1) Motor de base de datos de Microsoft Access (ACE)Microsoft Access Database Engine (ACE) ACE 2010 SP1ACE 2010 SP1 Sin restricciónNo restriction Tablas, hojasTables, Sheets Vínculo de descargaDownload link
Oracle (ver nota 2)Oracle (see note 2) ODP.NETODP.NET ODAC 11.2 versión 5 (11.2.0.3.20)ODAC 11.2 Release 5 (11.2.0.3.20) 9.x o superior9.x+ Tablas/vistasTables/Views Vínculo de descargaDownload link
System.Data.OracleClient (integrado en .Net Framework)System.Data.OracleClient (Built in .Net Framework) .NET Framework 3.5.NET Framework 3.5 9.x o superior9.x+ Tablas/vistasTables/Views Se incluye en .NET Framework 3.5 o superiorIncluded in .NET Framework 3.5 or above
IBM DB2IBM DB2 Cliente ADO.Net de IBM (parte del paquete de controladores del servidor de datos IBM)ADO.Net client from IBM (part of the IBM data server driver package) 10.110.1 9.1 o superior9.1+ Tablas/vistasTables/Views Vínculo de descargaDownload link
MySQLMySQL Connector/NetConnector/Net 6.6.56.6.5 5.15.1 Tablas/vistas, funciones escalaresTables/Views, Scalar functions Vínculo de descargaDownload link
PostgreSQLPostgreSQL NPGSQL ADO.NET providerNPGSQL ADO.NET provider 2.0.122.0.12 7.47.4 Tablas/vistasTables/Views Vínculo de descargaDownload link
TeradataTeradata Proveedor de datos .NET para Teradata.NET Data Provider for Teradata 14+14+ 12+12+ Tablas/vistasTables/Views Vínculo de descargaDownload link
SAP Sybase SQL AnywhereSAP Sybase SQL Anywhere iAnywhere.Data.SQLAnywhere para .NET 3.5iAnywhere.Data.SQLAnywhere for .NET 3.5 16+16+ 16+16+ Tablas/vistasTables/Views Vínculo de descargaDownload link

Nota

Los archivos de Excel que tienen una extensión .xlsx no requieren una instalación de proveedor independiente.Excel files that have an .xlsx extension do not require a separate provider installation.

Nota

Los proveedores de Oracle también necesitan software cliente de Oracle (versión 8.1.7 o superior).The Oracle providers also require Oracle client software (version 8.1.7+).