Introducción a Power BI DesktopGet started with Power BI Desktop

Bienvenido a la guía de introducción de Power BI Desktop.Welcome to the getting started guide for Power BI Desktop. En este paseo se muestra cómo funciona Power BI Desktop, lo que puede hacer y cómo crear modelos de datos eficaces e informes increíbles para ampliar la inteligencia empresarial.This tour shows you how Power BI Desktop works, what it can do, and how to build robust data models and amazing reports to amplify your business intelligence.

Para obtener una visión general rápida del funcionamiento de Power BI Desktop y cómo usarlo, puede examinar las pantallas de esta guía en solo unos minutos.For a quick overview of how Power BI Desktop works and how to use it, you can scan the screens in this guide in just a few minutes. Para obtener una descripción más completa, puede leer cada sección, realizar los pasos descritos y crear un archivo de Power BI Desktop propio para publicarlo en el servicio Power BI y compartirlo con otros usuarios.For a more thorough understanding, you can read through each section, perform the steps, and create your own Power BI Desktop file to post on the Power BI service and share with others.

Informe de Power BI Desktop

También puede ver el vídeo Introducción a Power BI Desktop y descargar el libro de Excel Ejemplo financiero para seguirlo junto al vídeo.You can also watch the Getting Started with the Power BI Desktop video, and download the Financial Sample Excel workbook to follow along with the video.

Funcionamiento de Power BI DesktopHow Power BI Desktop works

Con Power BI Desktop, puede:With Power BI Desktop, you can:

  1. Conectarse a datos, incluidos varios orígenes de datos.Connect to data, including multiple data sources.
  2. Dar forma a los datos con consultas que generan modelos de datos atractivos e interesantes.Shape the data with queries that build insightful, compelling data models.
  3. Usar los modelos de datos para crear visualizaciones e informes.Use the data models to create visualizations and reports.
  4. Compartir los archivos de informe para que otros usuarios puedan aprovecharlos, ampliarlos y compartirlos.Share your report files for others to leverage, build upon, and share. Puede compartir los archivos .pbix de Power BI Desktop como cualquier otro archivo, pero el método más atractivo consiste en cargarlos en el servicio Power BI.You can share Power BI Desktop .pbix files like any other files, but the most compelling method is to upload them to the Power BI service.

Power BI Desktop integra tecnologías probadas del motor de consultas de Microsoft, modelado de datos y visualización.Power BI Desktop integrates proven Microsoft query engine, data modeling, and visualization technologies. Los analistas de datos y otros usuarios pueden crear colecciones de consultas, conexiones de datos, modelos e informes, y compartirlos fácilmente con otros.Data analysts and others can create collections of queries, data connections, models, and reports, and easily share them with others. A través de la combinación de Power BI Desktop y el servicio Power BI, es más fácil modelar, compilar, compartir y extender nuevas conclusiones del mundo de los datos.Through the combination of Power BI Desktop and the Power BI service, new insights from the world of data are easier to model, build, share, and extend.

Power BI Desktop centraliza, simplifica y agiliza lo que de otro modo podría ser un proceso de diseño y creación de repositorios e informes de inteligencia empresarial disperso, arduo y desconectado.Power BI Desktop centralizes, simplifies, and streamlines what can otherwise be a scattered, disconnected, and arduous process of designing and creating business intelligence repositories and reports. ¿Listo para probarlo?Ready to give it a try? Empecemos.Let's get started.

Nota

Para los datos e informes que deben permanecer en el entorno local hay una versión de Power BI independiente y especializada denominada Power BI Report Server.For data and reporting that must remain on-premises, there's a separate and specialized version of Power BI called Power BI Report Server. Power BI Report Server usa una versión independiente y especializada de Power BI Desktop llamada Power BI Desktop para Power BI Report Server, que solo funciona con la versión Report Server de Power BI.Power BI Report Server uses a separate and specialized version of Power BI Desktop called Power BI Desktop for Power BI Report Server, which works only with the Report Server version of Power BI. En este artículo se describe la versión estándar de Power BI Desktop.This article describes standard Power BI Desktop.

Instalar y ejecutar Power BI DesktopInstall and run Power BI Desktop

Para descargar Power BI Desktop, vaya a la página de descarga de Power BI Desktop y seleccione Descarga gratuita.To download Power BI Desktop, go to the Power BI Desktop download page and select Download Free. O, para las opciones de descarga, seleccione Consulte las opciones de descarga o idiomas disponibles.Or for download options, select See download or language options.

También puede descargar Power BI Desktop desde el servicio Power BI.You can also download Power BI Desktop from the Power BI service. Seleccione el icono Descargar en la barra de menús superior y, después, seleccione Power BI Desktop.Select the Download icon in the top menu bar, and then select Power BI Desktop.

Descarga de Power BI Desktop desde el servicio Power BI

En la página de Microsoft Store, seleccione Obtener y siga las indicaciones para instalar Power BI Desktop en el equipo.On the Microsoft Store page, select Get, and follow the prompts to install Power BI Desktop on your computer. Inicie Power BI Desktop desde el menú Inicio de Windows o desde el icono de la barra de tareas de Windows.Start Power BI Desktop from the Windows Start menu or from the icon in the Windows taskbar.

La primera vez que se inicia Power BI Desktop, se muestra la pantalla de bienvenida.The first time Power BI Desktop starts, it displays the Welcome screen.

En la pantalla de bienvenida, puede obtener datos, ver orígenes recientes, abrir informes recientes, abrir otros informeso seleccionar otros vínculos.From the Welcome screen, you can Get data, see Recent sources, open recent reports, Open other reports, or select other links. También puede elegir si quiere mostrar siempre la pantalla de bienvenida durante el inicio.You can also choose whether to always show the Welcome screen at startup. Seleccione el icono Cerrar para cerrar la pantalla de bienvenida.Select the close icon to close the Welcome screen.

Pantalla de bienvenida de Power BI Desktop

En el lado izquierdo de Power BI Desktop aparecen iconos para las tres vistas de Power BI Desktop: Informe, Datosy Relaciones, de arriba a abajo.Along the left side of Power BI Desktop are icons for the three Power BI Desktop views: Report, Data, and Relationships, from top to bottom. La vista actual se indica mediante la barra amarilla situada a la izquierda y puede cambiar de vista si selecciona cualquiera de los iconos.The current view is indicated by the yellow bar along the left, and you can change views by selecting any of the icons.

Los tres iconos de vista de Power BI Desktop

La vista Informe es la predeterminada.Report view is the default view.

Vista Informe en Power BI Desktop

Power BI Desktop también incluye el Editor de Power Query, que se abre en una ventana independiente.Power BI Desktop also includes the Power Query Editor, which opens in a separate window. En el Editor de Power Query, puede crear consultas y transformar datos, y después cargar el modelo de datos refinados en Power BI Desktop para crear informes.In Power Query Editor, you can build queries and transform data, then load the refined data model into Power BI Desktop to create reports.

Conectar a datosConnect to data

Con Power BI Desktop instalado, está listo para conectarse con el mundo de los datos en continua expansión.With Power BI Desktop installed, you’re ready to connect to the ever-expanding world of data. Para ver los numerosos tipos de orígenes de datos disponibles, seleccione Obtener datos > Más en la pestaña Inicio de Power BI Desktop y, en la ventana Obtener datos, desplácese por la lista Todo de orígenes de datos.To see the many types of data sources available, select Get Data > More in the Power BI Desktop Home tab, and in the Get Data window, scroll through the list of All data sources. En este paseo rápido, se conectará a dos orígenes de datos web diferentes.In this quick tour, you connect to a couple of different Web data sources.

Selección de orígenes de datos web en Obtener datosSelect Web data source from Get Data

Imagine que es un analista de datos que trabaja para un distribuidor de gafas de sol.Imagine you're a data analyst working for a sunglasses retailer. Quiere ayudar al cliente a que dirija la venta de gafas de sol a zonas donde siempre brille el sol.You want to help your client target sunglasses sales where the sun shines most frequently. La página sobre los mejores y peores estados para jubilarse en Bankrate.com contiene datos interesantes al respecto.The Bankrate.com Best and worst states for retirement page has interesting data on this subject.

En la pestaña Inicio de Power BI Desktop, seleccione Obtener datos > Web para conectarse a un origen de datos web.On the Power BI Desktop Home tab, select Get Data > Web to connect to a web data source.

Selección del origen de datos Web

En el cuadro de diálogo De web, pegue la dirección https://www.bankrate.com/retirement/best-and-worst-states-for-retirement/ en el campo Dirección URL y seleccione Aceptar.In the From Web dialog box, paste the address https://www.bankrate.com/retirement/best-and-worst-states-for-retirement/ into the URL field, and select OK.

Dirección web pegada en el cuadro de diálogo De web

Si se le solicita, en la pantalla Acceder a contenido web, seleccione Conectar para usar el acceso anónimo.If prompted, on the Access Web Content screen, select Connect to use anonymous access.

La funcionalidad de consulta de Power BI Desktop entra en acción y contacta con el recurso web.The query functionality of Power BI Desktop goes to work and contacts the web resource. En la ventana Navegador se devuelve lo que se ha encontrado en la página web, en este caso, una tabla denominada Clasificación de los mejores y peores estados para jubilarse y un documento.The Navigator window returns what it found on the web page, in this case a table called Ranking of best and worst states for retirement, and a document. Como le interesa la tabla, selecciónela para ver una vista previa.You're interested in the table, so select it to see a preview.

En este momento, puede seleccionar Cargar para cargar la tabla, o bien Transformar datos para realizar cambios en la tabla antes de cargarlos.At this point you can select Load to load the table, or Transform data to make changes in the table before you load it.

Vista previa de la tabla desde la página web

Al seleccionar Transformar datos, se inicia el Editor de Power Query, con una vista representativa de la tabla.When you select Transform data, Power Query Editor launches, with a representative view of the table. El panel Configuración de la consulta está a la derecha, o bien puede mostrarlo si selecciona Configuración de la consulta en la pestaña Vista del Editor de Power Query.The Query Settings pane is on the right, or you can always show it by selecting Query Settings on the View tab of Power Query Editor.

Editor de Power Query con Configuración de la consulta

Para obtener más información sobre cómo conectarse a los datos, vea Conectarse a los datos en Power BI Desktop.For more information about connecting to data, see Connect to data in Power BI Desktop.

Dar forma a los datosShape data

Ahora que se ha conectado a un origen de datos, puede ajustar los datos según sea necesario.Now that you're connected to a data source, you can adjust the data to meet your needs. Para dar forma a los datos, proporcione al Editor de Power Query instrucciones paso a paso para ajustar los datos mientras los carga y presenta.To shape data, you provide Power Query Editor with step-by-step instructions for adjusting the data while loading and presenting it. La operación de dar forma no afecta al origen de datos original, solo a esta vista concreta de los datos.Shaping doesn't affect the original data source, only this particular view of the data.

Nota

Es posible que los datos de la tabla que se usan en esta guía cambien con el tiempo.The table data used in this guide might change over time. Por eso, los pasos que debe seguir pueden variar, por lo que tendrá que ser creativo y ajustar los pasos o los resultados; esto es parte de la diversión del aprendizaje.As such, the steps you need to follow might vary, requiring you to be creative about how you adjust steps or outcomes, which is all part of the fun of learning.

El modelado puede significar transformar los datos, como cambiar el nombre de columnas o tablas, quitar filas o columnas, o cambiar tipos de datos.Shaping can mean transforming the data, such as renaming columns or tables, removing rows or columns, or changing data types. El Editor de Power Query captura estos pasos secuencialmente en Pasos aplicados en el panel Configuración de la consulta.Power Query Editor captures these steps sequentially under Applied Steps in the Query Settings pane. Cada vez que esta consulta se conecte al origen de datos, se ejecutan esos pasos, para que los datos siempre tengan la forma especificada.Each time this query connects to the data source, those steps are carried out, so the data is always shaped the way you specify. Este proceso se produce siempre que se usa la consulta en Power BI Desktop, o bien cuando alguien más use la consulta compartida, como en el servicio Power BI.This process occurs when you use the query in Power BI Desktop, or when anyone uses your shared query, such as in the Power BI service.

Tenga en cuenta que en Pasos aplicados en Configuración de la consulta ya se incluyen algunos pasos.Notice that the Applied Steps in Query Settings already contain a few steps. Puede seleccionar cada paso para ver su efecto en el Editor de Power Query.You can select each step to see its effect in the Power Query Editor. En primer lugar, ha especificado un origen web y, después, ha visto una vista previa de la tabla en la ventana Navegador.First, you specified a web source, and then you previewed the table in the Navigator window. En el tercer paso, Tipo cambiado, Power BI ha reconocido datos de número entero al importarlos y ha cambiado de forma automática el Tipo de datos Texto web original a Números enteros.In the third step, Changed type, Power BI recognized whole number data when importing it, and automatically changed the original web Text data type to Whole numbers.

Panel Configuración de la consulta con tres pasos aplicados

Si tiene que cambiar un tipo de datos, seleccione la columna o columnas que quiera cambiar.If you need to change a data type, select the column or columns to change. Mantenga presionada la tecla Mayús para seleccionar varias columnas adyacentes o la tecla Ctrl para seleccionar columnas no adyacentes.Hold down the Shift key to select several adjacent columns, or Ctrl to select non-adjacent columns. Haga clic con el botón derecho en un encabezado de columna, seleccione Tipo cambiado, elija un nuevo tipo de datos en el menú, o bien, en la lista desplegable situada junto a Tipo de datos en el grupo Transformación de la pestaña Inicio, seleccione un tipo de datos nuevo.Either right-click a column header, select Change Type, and choose a new data type from the menu, or drop down the list next to Data Type in the Transform group of the Home tab, and select a new data type.

Cambio del tipo de datos

Nota

El Editor de Power Query de Power BI Desktop usa la cinta de opciones o los menús contextuales para las tareas disponibles.The Power Query Editor in Power BI Desktop uses the ribbon or the right-click menus for available tasks. La mayor parte de las tareas que puede seleccionar en las pestañas Inicio o Transformar también están disponibles en el menú que aparece al hacer clic con el botón derecho en un elemento y realizar una selección en el menú que aparece.Most of the tasks you can select on the Home or Transform tabs of the ribbon are also available by right-clicking an item and choosing from the menu that appears.

Ahora puede aplicar cambios y transformaciones propios a los datos y verlos en Pasos aplicados.You can now apply your own changes and transformations to the data and see them in Applied Steps.

Por ejemplo, en el caso de las ventas de gafas de sol, lo que más le interesa es la clasificación meteorológica, por lo que decide ordenar la tabla por la columna Weather (Tiempo) en lugar de Overall rank (Clasificación general).For example, for sunglasses sales you're most interested in the weather ranking, so you decide to sort the table by the Weather column instead of by Overall rank. Baje la flecha situada junto al encabezado Weather y seleccione Orden ascendente.Drop down the arrow next to the Weather header, and select Sort ascending. Ahora los datos aparecen ordenados por clasificación meteorológica y el paso Filas ordenadas aparece en Pasos aplicados.The data now appears sorted by weather ranking, and the step Sorted Rows appears in Applied Steps.

Orden ascendente de las filas

No le interesa mucho vender gafas de sol en los estados con peor clima, por lo que decide quitarlos de la tabla.You're not very interested in selling sunglasses to the worst weather states, so you decide to remove them from the table. En el grupo Reducir filas de la pestaña Inicio, seleccione Quitar filas > Quitar filas inferiores.From the Reduce Rows group of the Home tab, select Remove Rows > Remove Bottom Rows. En el cuadro de diálogo Quitar filas inferiores, escriba 10 y, después, seleccione Aceptar.In the Remove Bottom Rows dialog box, enter 10, and then select OK.

Quitar filas inferiores

Se quitan de la tabla las 10 filas inferiores con el peor clima y el paso Filas inferiores quitadas aparece en Pasos aplicados.The bottom 10 worst weather rows are removed from the table, and the step Removed Bottom Rows appears in Applied Steps.

Decide que la tabla tiene demasiada información adicional para sus necesidades y quita las columnas Affordability (Asequibilidad), Crime (Delitos), Culture (Cultura) y Wellness (Bienestar).You decide the table has too much extra information for your needs, and to remove the Affordability, Crime, Culture, and Wellness columns. Seleccione el encabezado de cada columna que quiera quitar.Select the header of each column that you want to remove. Mantenga presionada la tecla Mayús para seleccionar varias columnas adyacentes o la tecla Ctrl para seleccionar columnas no adyacentes.Hold down the Shift key to select several adjacent columns, or Ctrl to select non-adjacent columns.

Después, en el grupo Administrar columnas de la pestaña Inicio, seleccione Quitar columnas.Then, from the Manage Columns group of the Home tab, select Remove Columns. También puede hacer clic con el botón derecho en uno de los encabezados de columna seleccionados y seleccionar Quitar columnas en el menú.You can also right-click one of the selected column headers and select Remove Columns from the menu. Se quitan las columnas seleccionadas y el paso Columnas quitadas aparece en Pasos aplicados.The selected columns are removed, and the step Removed Columns appears in Applied Steps.

Quitar columnas

Pensándolo mejor, Affordability podría ser relevante para las ventas de gafas de sol.On second thought, Affordability might be relevant to sunglasses sales after all. Le gustaría volver a recuperar esa columna.You'd like to get that column back. Puede deshacer fácilmente el último paso del panel Pasos aplicados si selecciona el icono Eliminar X situado junto al paso.You can easily undo the last step in the Applied Steps pane by selecting the X delete icon next to the step. Ahora rehaga el paso, y seleccione solo las columnas que quiera eliminar.Now redo the step, selecting only the columns you want to delete. Para mayor flexibilidad, puede eliminar cada columna en un paso independiente.For more flexibility, you could delete each column as a separate step.

Puede hacer clic con el botón derecho en cualquier paso del panel Pasos aplicados para eliminarlo, cambiarle el nombre, subirlo o bajarlo en la secuencia, o agregar o eliminar pasos después de este.You can right-click any step in the Applied Steps pane and choose to delete it, rename it, move it up or down in the sequence, or add or delete steps after it. En el caso de los pasos intermedios, Power BI Desktop le avisará si el cambio puede afectar a los pasos posteriores e interrumpir la consulta.For intermediate steps, Power BI Desktop will warn you if the change could affect later steps and break your query.

Modificación de pasos aplicados

Por ejemplo, si ya no quiere ordenar la tabla por Weather, podría intentar eliminar el paso Filas ordenadas.For example, if you no longer wanted to sort the table by Weather, you might try to delete the Sorted Rows step. Power BI Desktop le advierte de que la eliminación de este paso podría interrumpir la consulta.Power BI Desktop warns you that deleting this step could cause your query to break. Ha quitado las 10 filas inferiores después de ordenar por condiciones meteorológicas, por lo que si quita el orden, se quitarán otras filas.You removed the bottom 10 rows after you sorted by weather, so if you remove the sort, different rows will be removed. También recibirá una advertencia si selecciona el paso Filas ordenadas e intenta agregar un nuevo paso intermedio en ese punto.You also get a warning if you select the Sorted Rows step and try to add a new intermediate step at that point.

Advertencia de eliminación de paso

Por último, cambie el título de la tabla para que haga referencia a ventas de gafas de sol y no a la jubilación.Finally, you change the table title to be about sunglass sales instead of retirement. En Propiedades en el panel Configuración de la consulta, reemplace el título anterior por Mejores estados para ventas de gafas de sol.Under Properties in the Query Settings pane, replace the old title with Best states for sunglass sales.

La consulta finalizada para los datos moldeados tiene el aspecto siguiente:The finished query for your shaped data looks like this:

Consulta finalizada

Para obtener más información sobre cómo dar forma a los datos, vea Combinar datos y darles forma en Power BI Desktop.For more information about shaping data, see Shape and combine data in Power BI Desktop.

Combinar datosCombine data

Los datos sobre diferentes estados resultan interesantes y serán útiles para crear otras consultas y análisis.The data about various states is interesting, and will be useful for building additional analysis efforts and queries. Pero hay un problema: la mayoría de los datos usa abreviaturas de dos letras para los códigos de estado, no el nombre completo de los estados.But there's one problem: most data out there uses two-letter abbreviations for state codes, not the full names of the states. Para usar esos datos, se necesita una manera de asociar las abreviaturas con los nombres de los estados.To use that data, you need some way to associate your state names with their abbreviations.

Está de suerte.You're in luck. Otro origen de datos público hace justamente eso, pero los datos necesitarán una importante cantidad de modelado antes de poder combinarlos con la tabla de gafas de sol.Another public data source does just that, but the data will need a fair amount of shaping before you can combine it with your sunglass table.

Para importar los datos de las abreviaturas de estados en el Editor de Power Query, seleccione Nuevo origen > Web en el grupo Nueva consulta de la pestaña Inicio de la cinta.To import the state abbreviations data into Power Query Editor, select New Source > Web from the New Query group on the Home tab of the ribbon.

Nuevo origen

En el cuadro de diálogo De web, escriba la dirección URL del sitio de las abreviaturas de estado: https://en.wikipedia.org/wiki/List_of_U.S._state_abbreviations.In the From Web dialog box, enter the URL for the state abbreviations site: https://en.wikipedia.org/wiki/List_of_U.S._state_abbreviations.

En la ventana Navegador, seleccione la tabla Codes and abbreviations for U.S. states, federal district, territories, and other regions (Códigos y abreviaturas de estados de EE. UU., Distrito Federal, territorios y otras regiones) y, después, seleccione Aceptar.In the Navigator window, select the table Codes and abbreviations for U.S. states, federal district, territories, and other regions, and then select OK. La tabla se abre en el Editor de Power Query.The table opens in Power Query Editor.

Quite todas las columnas excepto Name and status of region (Nombre y estado de la región), Name and status of region2 (Nombre y estado de la región 2) y ANSI.Remove all columns except for Name and status of region, Name and status of region2, and ANSI. Para conservar solo estas columnas, mantenga presionada la tecla Ctrl y selecciónelas.To keep only these columns, hold down Ctrl and select the columns. Después, haga clic con el botón derecho en uno de los encabezados de columna y seleccione Quitar otras columnas, o bien, en el grupo Administrar columnas de la pestaña Inicio, seleccione Quitar otras columnas.Then, either right-click one of the column headers and select Remove Other Columns, or, from the Manage Columns group of the Home tab, select Remove Other Columns.

Haga clic en la flecha desplegable situada junto a la columna Name and status of region2 y seleccione Filtros > Es igual a.Drop down the arrow next to the Name and status of region2 column header, and select Filters > Equals. En el cuadro de diálogo Filtrar filas, haga clic en el campo desplegable Escribir o seleccionar un valor situado junto a es igual a y seleccione State.In the Filter Rows dialog box, drop down the Enter or select a value field next to equals and select State.

Seleccione o y junto al segundo campo es igual a, seleccione State ("Commonwealth") .Select Or, and next to the second equals field, select State ("Commonwealth"). Seleccione Aceptar.Select OK.

Filtrar filas

Después de quitar valores adicionales como Federal district (Distrito Federal) e island (isla), ahora tiene una lista de los 50 estados y sus abreviaturas oficiales de dos letras.With extra values like Federal district and island removed, you now have a list of the 50 states and their official two-letter abbreviations. Puede cambiar el nombre de las columnas para que tengan más sentido, por ejemplo Nombre del estado, Estado y Abreviatura si hace clic con el botón derecho en los encabezados de columna y selecciona Cambiar el nombre.You can rename the columns to make more sense, for example State name, Status, and Abbreviation, by right-clicking the column headers and selecting Rename.

Tenga en cuenta que todos estos pasos se registran en Pasos aplicados en el panel Configuración de la consulta.Note that all of these steps are recorded under Applied Steps in the Query Settings pane.

Ahora la tabla moldeada tiene este aspecto:Your shaped table now looks like this:

Tabla de códigos de estado con forma

Cambie el título de la tabla por Códigos de estado en el campo Propiedades de Configuración de la consulta.Retitle the table to State codes in the Properties field of Query Settings.

Después de dar forma a la tabla Códigos de estado, puede combinar estas dos tablas en una.With the State codes table shaped, you can combine these two tables into one. Como las tablas que ahora tiene son el resultado de las consultas aplicadas a los datos, también se denominan consultas.Since the tables you now have are a result of queries you applied to the data, they're also called queries. Existen dos formas principales de combinar consultas: combinar y anexar.There are two primary ways of combining queries: merge and append.

Cuando tiene una o más columnas que quiere agregar a otra consulta, las consultas se combinan.When you have one or more columns you'd like to add to another query, you merge the queries. Cuando tiene filas de datos adicionales que quiere agregar a una consulta existente, la consulta se anexa.When you have additional rows of data you'd like to add to an existing query, you append the query.

En este caso, quiere combinar la consulta Códigos de estado con la consulta Mejores estados para las ventas de gafas de sol.In this case, you want to merge the State codes query into the Best states for sunglasses query. Para combinar las consultas, cambie a la consulta Mejores estados para las ventas de gafas de sol seleccionándola en el panel Consultas del lado izquierdo del Editor de Power Query.To merge the queries, switch to the Best states for sunglasses query by selecting it from the Queries pane on the left side of Power Query Editor. Después, seleccione Combinar consultas en el grupo Combinar de la pestaña Inicio de la cinta.Then select Merge Queries from the Combine group in the Home tab of the ribbon.

En la ventana Combinar, haga clic en el campo desplegable para seleccionar Códigos de estado en las otras consultas disponibles.In the Merge window, drop down the field to select State codes from the other queries available. Seleccione la columna que debe coincidir en cada tabla; en este caso Estado en la consulta Mejores estados para las ventas de gafas de sol y Nombre de estado en la consulta Códigos de estado.Select the column to match from each table, in this case State from the Best states for sunglasses query and State name from the State codes query.

Si aparece un cuadro de diálogo Niveles de privacidad, seleccione Ignorar las comprobaciones de los niveles de privacidad de este archivo y, después, seleccione Guardar.If you get a Privacy levels dialog, select Ignore privacy levels checks for this file and then select Save. Seleccione Aceptar.Select OK.

Combinación de consultas

Aparecerá una nueva columna denominada Códigos de estado a la derecha de la tabla Mejores estados para la venta de gafas de sol.A new column called State codes appears on the right of the Best states for sunglass sales table. Contiene la consulta de código de estado que ha combinado con la consulta de mejores estados para la venta de gafas de sol.It contains the state code query that you merged with the best states for sunglass sales query. Todas las columnas de la tabla combinada se condensan en la columna Códigos de estado.All the columns from the merged table are condensed into the State codes column. Puede expandir la tabla combinada e incluir solo las columnas que quiera.You can expand the merged table and include only the columns you want.

Columna de consulta combinada

Para expandir la tabla combinada y seleccionar qué columnas se van a incluir, seleccione el icono Expandir del encabezado de columna.To expand the merged table and select which columns to include, select the Expand icon in the column header. En el cuadro de diálogo Expandir, seleccione solo la columna Abreviatura.In the Expand dialog box, select only the Abbreviation column. Desactive Usar el nombre de columna original como prefijo y, después, seleccione Aceptar.Deselect Use original column name as prefix, and then select OK.

Selección de la columna expandida en la tabla combinada

Nota

Puede experimentar para ver cómo incorporar la tabla Códigos de estado.You can play around with how to bring in the State codes table. Experimente un poco y, si no le gustan los resultados, elimine ese paso de la lista Pasos aplicados en el panel Configuración de la consulta.Experiment a bit, and if you don’t like the results, just delete that step from the Applied Steps list in the Query Settings pane. Es una segunda oportunidad, que puede realizar tantas veces como sea necesario hasta que el proceso de expansión tenga la apariencia que busca.It's a free do-over, which you can do as many times as you like until the expand process looks the way you want it.

Para obtener una descripción más completa de los pasos para dar forma a los datos y combinarlos, vea Combinar datos y darles forma en Power BI Desktop.For a more complete description of the shape and combine data steps, see Shape and combine data in Power BI Desktop.

Ahora tiene una única tabla de consulta con dos orígenes de datos combinados, a los que se les ha dado forma para adecuarlos a sus necesidades.You now have a single query table that combines two data sources, each of which has been shaped to meet your needs. Esta consulta puede servir como base para una gran cantidad de conexiones de datos interesantes adicionales, como datos demográficos, niveles de bienestar y oportunidades de ocio en los estados.This query can serve as a basis for lots of additional, interesting data connections, such as demographics, wealth levels, or recreational opportunities in the states.

Consultas combinadas y moldeadas

Por ahora, tiene datos suficientes para crear un informe interesante en Power BI Desktop.For now, you have enough data to create an interesting report in Power BI Desktop. Como se trata de un hito, aplique los cambios en el Editor de Power Query y, para cargarlos en Power BI Desktop, seleccione Cerrar y aplicar en la pestaña Inicio de la cinta.Since this is a milestone, apply the changes in Power Query Editor and load them into Power BI Desktop by selecting Close & Apply from the Home tab of the ribbon. También puede seleccionar simplemente Aplicar para mantener abierta la consulta en el Editor de Power Query mientras trabaja en Power BI Desktop.You can also select just Apply to keep the query open in Power Query Editor while you work in Power BI Desktop.

Cerrar y aplicar los cambios

Puede realizar más cambios en una tabla después de cargarla en Power BI Desktop y volver a cargar el modelo para aplicar los cambios que realice.You can make more changes to a table after it is loaded into Power BI Desktop, and reload the model to apply any changes you make. Para volver a abrir el Editor de Power Query desde Power BI Desktop, seleccione Editar consultas en la pestaña Inicio de la cinta de Power BI Desktop.To reopen Power Query Editor from Power BI Desktop, select Edit Queries on the Home tab of the Power BI Desktop ribbon.

Elaborar informesBuild reports

En la vista Informe de Power BI Desktop, puede crear visualizaciones e informes.In Power BI Desktop Report view, you can build visualizations and reports. La vista Informe tiene seis áreas principales:The Report view has six main areas:

Vista Informe en Power BI Desktop

  1. La cinta en la parte superior, en la que se muestran las tareas comunes asociadas con los informes y las visualizaciones.The ribbon at the top, which displays common tasks associated with reports and visualizations.
  2. El área de lienzo en el centro, donde se crean y se organizan las visualizaciones.The canvas area in the middle, where visualizations are created and arranged.
  3. El área de pestañas de página en la parte inferior, que permite seleccionar o agregar páginas del informe.The pages tab area at the bottom, which lets you select or add report pages.
  4. El panel Filtros, donde puede filtrar las visualizaciones de datos.The Filters pane, where you can filter data visualizations.
  5. El panel Visualizaciones, donde puede agregar, cambiar o personalizar visualizaciones, y aplicar la obtención de detalles.The Visualizations pane, where you can add, change, or customize visualizations, and apply drillthrough.
  6. El panel Campos, donde se muestran los campos disponibles en las consultas.The Fields pane, which shows the available fields in your queries. Puede arrastrar estos campos al lienzo o a los paneles Filtros o Visualizaciones para crear o modificar visualizaciones.You can drag these fields onto the canvas, the Filters pane, or the Visualizations pane to create or modify visualizations.

Puede expandir y contraer los paneles Filtros, Visualizaciones y Campos si selecciona las flechas situadas en la parte superior de los paneles.You can expand and collapse the Filters, Visualizations, and Fields panes by selecting the arrows at the tops of the panes. Al contraer los paneles se proporciona más espacio en el lienzo para crear visualizaciones interesantes.Collapsing the panes provides more space on the canvas to build cool visualizations.

Expansión o contracción de los paneles

Para crear una visualización simple, seleccione cualquier campo de la lista de campos, o bien arrástrelo desde la lista Campos hasta el lienzo.To create a simple visualization, just select any field in the fields list, or drag the field from the Fields list onto the canvas. Por ejemplo, arrastre el campo Estado desde Mejores estados para las ventas de gafas de sol hasta el lienzo y vea lo que sucede.For example, drag the State field from Best states for sunglass sales onto the canvas, and see what happens.

Arrastre el campo Estado para crear una visualización de mapa

Preste atención.Look at that! Power BI Desktop ha reconocido que el campo State contiene datos de geolocalización y ha creado de forma automática una visualización basada en un mapa.Power BI Desktop recognized that the State field contained geolocation data and automatically created a map-based visualization. La visualización muestra los puntos de datos de los 40 estados del modelo de datos.The visualization shows data points for the 40 states from your data model.

En el panel Visualizaciones se muestra información sobre la visualización y le permite modificarla.The Visualizations pane shows information about the visualization and lets you modify it.

El panel Visualizaciones

  1. Los iconos muestran el tipo de visualización creado.The icons show the type of visualization created. Puede cambiar el tipo de una visualización seleccionada si selecciona otro icono, o bien crear una visualización si selecciona un icono sin ninguna visualización existente seleccionada.You can change the type of a selected visualization by selecting a different icon, or create a new visualization by selecting an icon with no existing visualization selected.
  2. La opción Campos del panel Visualización permite arrastrar campos de datos a Leyenda y otras áreas de campos del panel.The Fields option in the Visualization pane lets you drag data fields to Legend and other field wells in the pane.
  3. La opción Formato permite aplicar formato y otros controles a las visualizaciones.The Format option lets you apply formatting and other controls to visualizations.

Las opciones disponibles en las áreas Campos y Formato dependen del tipo de visualización y de los datos que tenga.The options available in the Fields and Format areas depend on the type of visualization and data you have.

Quiere que la visualización del mapa muestre solo los 10 primeros estados con mejor clima.You want your map visualization to show only the top 10 weather states. Para mostrar solo los 10 primeros estados, en el panel Filtros, mantenga el mouse sobre State is (All) (El estado es (Todos)) y expanda la flecha que aparece.To show only the top 10 states, in the Filters pane, hover over State is (All) and expand the arrow that appears. En la lista desplegable Tipo de filtro, seleccione N principales. En Mostrar elementos, seleccione Inferior, porque quiere mostrar los elementos con los rangos numéricos más bajos, y escriba 10 en el campo siguiente.Under Filter type, drop down and select Top N. Under Show items, select Bottom, because you want to show the items with the lowest numerical ranks, and enter 10 in the next field.

Arrastre el campo Weather (Tiempo) desde el panel Campos hasta el campo Por valor y, después, seleccione Aplicar filtro.Drag the Weather field from the Fields pane into the By value field, and then select Apply filter.

Filtro meteorológico de los 10 principales

Ahora solo verá los 10 estados principales con mejor clima en la visualización de mapa.You now see only the top 10 weather states in the map visualization.

Para cambiar el título de la visualización, seleccione el icono Formato en el panel Visualización, seleccione Título y escriba 10 estados principales con mejor clima en Texto del título.Retitle your visualization by selecting the Format icon in the Visualization pane, selecting Title, and typing Top 10 weather states under Title text.

Cambiar el título

Para agregar una visualización que muestre los nombres de los 10 estados principales con mejor clima y sus clasificaciones de 1 a 10, seleccione un área en blanco del lienzo y después el icono Gráfico de columnas en el panel Visualización.To add a visualization that shows the names of the top 10 weather states and their ranks from 1 to 10, select a blank area of the canvas and then select the Column chart icon from the Visualization pane. En el panel Campos, seleccione State y Weather.In the Fields pane, select State and Weather. En un gráfico de columnas se muestran los 40 estados de la consulta, clasificados numéricamente de mayor a menor, o de peor a mejor clima.A column chart shows the 40 states in your query, ranked from highest to lowest numerical rank, or worst to best weather.

Visualización de gráfico de columnas

Para cambiar el orden de clasificación de modo que el número 1 aparezca en primer lugar, seleccione los puntos suspensivos Más opciones en la esquina superior derecha de la visualización y seleccione Orden ascendente en el menú.To switch the order of the ranking so that number 1 appears first, select the More options ellipsis at the upper right of the visualization, and select Sort ascending from the menu.

Orden ascendente

Para limitar la tabla a los 10 estados principales, aplique el mismo filtro de los 10 inferiores como ha hecho en la visualización del mapa.To limit the table to the top 10 states, apply the same bottom 10 filter as you did for the map visualization.

Cambie el título de la visualización de la misma forma que para la visualización del mapa.Retitle the visualization the same way as for the map visualization. Además, en la sección Formato del panel Visualización, cambie Eje Y > Título del eje de Weather a Clasificación meteorológica para que sea más descriptivo.Also in the Format section of the Visualization pane, change Y axis > Axis title from Weather to Weather ranking to make it more understandable. Después, establezca el selector Eje Y en Desactivado y Etiquetas de datos en Activado.Then, turn the Y axis selector to Off, and turn Data labels to On.

Ahora, los 10 estados principales con mejor clima aparecen en orden de clasificación junto con sus clasificaciones numéricas.Now, the top 10 weather states appear in ranked order along with their numerical rankings.

Gráfico de columnas finalizado

Puede crear visualizaciones similares o distintas para los campos Affordability y Overall ranking, o bien combinar varios campos en una visualización.You can make similar or other visualizations for the Affordability and Overall ranking fields, or combine several fields into one visualization. Hay todo tipo de informes y visualizaciones interesantes que puede crear.There are all sorts of interesting reports and visualizations you can create. En estas visualizaciones de Tabla y Gráfico de líneas y columnas agrupadas se muestran los 10 estados principales con mejor clima junto con su asequibilidad y clasificaciones generales:These Table and Line and clustered column chart visualizations shows the top 10 weather states along with their affordability and overall rankings:

Visualizaciones de Tabla y Gráfico de líneas y columnas agrupadas

Puede mostrar otras visualizaciones en otras páginas del informe.You can show different visualizations on different report pages. Para agregar una página nueva, seleccione el símbolo + situado junto a las páginas existentes en la barra de páginas, o bien seleccione Insertar > Nueva página en la pestaña Inicio de la cinta.To add a new page, select the + symbol next to the existing pages on the pages bar, or select Insert > New Page in the Home tab of the ribbon. Para cambiar el nombre de una página, haga doble clic en el nombre de la página en la barra de páginas, o bien haga clic con el botón derecho y seleccione Cambiar nombre de página y escriba el nombre nuevo.To rename a page, double-click the page name in the pages bar, or right-click it and select Rename Page, and then type the new name. Para ir a otra página del informe, selecciónela en la barra de páginas.To go to a different page of the report, select the page from the pages bar.

Barra de páginas

Puede agregar cuadros de texto, imágenes y botones a las páginas del informe desde el grupo Insertar de la pestaña Inicio. Para establecer opciones de formato para las visualizaciones, seleccione una visualización y después el icono Formato en el panel Visualizaciones.You can add text boxes, images, and buttons to your report pages from the Insert group of the Home tab. To set formatting options for visualizations, select a visualization and then select the Format icon in the Visualizations pane. Para configurar tamaños de página, fondos y otra información de la página, seleccione el icono Formato sin la visualización seleccionada.To configure page sizes, backgrounds, and other page information, select the Format icon with no visualization selected.

Cuando termine de crear las páginas y las visualizaciones, seleccione Archivo > Guardar y guarde el informe.When you finish creating your pages and visualizations, select File > Save and save your report.

Página de informe de Power BI Desktop finalizada

Para más información sobre los informes, consulte Vista de informes en Power BI Desktop.For more information about reports, see Report View in Power BI Desktop.

Compartir su trabajoShare your work

Ahora que tiene un informe de Power BI Desktop, puede compartirlo con otros usuarios.Now that you have a Power BI Desktop report, you can share it with others. Hay varias maneras de compartir el trabajo.There are a few ways to share your work. Puede distribuir el archivo .pbix del informe como cualquier otro archivo, cargar el archivo .pbix desde el servicio Power BI, o bien publicar directamente desde Power BI Desktop en el servicio Power BI.You can distribute the report .pbix file like any other file, you can upload the .pbix file from the Power BI service, or you can publish directly from Power BI Desktop to the Power BI service. Debe tener una cuenta de Power BI para poder publicar o cargar informes en el servicio Power BI.You must have a Power BI account to be able to publish or upload reports to Power BI service.

Para publicar en el servicio Power BI desde Power BI Desktop, seleccione Publicar en la pestaña Inicio de la cinta.To publish to the Power BI service from Power BI Desktop, from the Home tab of the ribbon, select Publish.

Selección de Publicar

Es posible que se le pida que inicie sesión en Power BI o que seleccione un destino.You may be prompted to sign in to Power BI, or to select a destination.

Cuando finalice el proceso de publicación, verá el cuadro de diálogo siguiente:When the publish process is complete, you see the following dialog:

Publicación correcta en Power BI

Al seleccionar el vínculo para abrir el informe en Power BI, el informe se abre en el sitio de Power BI en Mi área de trabajo > Informes.When you select the link to open the report in Power BI, your report opens in your Power BI site under My workspace > Reports.

Otra manera de compartir su trabajo es realizar la carga desde el servicio Power BI .Another way to share your work is to load it from within the Power BI service. Vaya a https://app.powerbi.com para abrir Power BI en un explorador.Go to https://app.powerbi.com to open Power BI in a browser. En la página Inicio de Power Bi, seleccione Obtener datos en la esquina inferior izquierda para iniciar el proceso de carga del informe de Power BI Desktop.On your Power BI Home page, select Get data at lower left to start the process of loading your Power BI Desktop report.

Selección de Obtener datos en la página Inicio de Power BI

En la página siguiente, seleccione Obtener en la sección Archivos.On the next page, select Get from the Files section.

Obtención de archivos

En la página siguiente, seleccione Archivo local.On the next page, select Local File. Busque y seleccione el archivo .pbix Power BI Desktop y seleccione Abrir.Browse to and select your Power BI Desktop .pbix file, and select Open.

Después de que se importe el archivo, verá que aparece en Mi área de trabajo > Informes en el panel izquierdo del servicio Power BI.After the file imports, you can see it listed under My workspace > Reports in the left pane of the Power BI service.

Archivo de Power BI Desktop importado en Power BI

Al seleccionar el archivo, aparece la primera página del informe.When you select the file, the first page of the report appears. Puede seleccionar otras páginas en las pestañas situadas a la izquierda del informe.You can select different pages from the tabs at the left of the report.

Puede realizar cambios en un informe del servicio Power BI si selecciona Más opciones > Editar en la parte superior del lienzo de informe.You can make changes to a report in the Power BI service by selecting More options > Edit from the top of the report canvas. Para guardar los cambios, seleccione Guardar una copia.To save your changes, select Save a copy.

Edición de un informe y guardado de una copia

Puede crear todo tipo de objetos visuales interesantes desde el informe en el servicio Power BI, que puede anclar a un panel.There are all sorts of interesting visuals you can create from your report in the Power BI service, which you can pin to a dashboard. Para más información sobre los paneles del servicio Power BI, vea Sugerencias para diseñar un panel de Power BI fantástico.To learn about dashboards in the Power BI service, see Tips for designing a great dashboard. Para más información sobre cómo crear, compartir y modificar los paneles, consulte Compartir un panel con compañeros y otros usuarios.For more information about creating, sharing, and modifying dashboards, see Share a dashboard.

Para compartir un informe o un panel, seleccione Compartir en la parte superior de la página del informe o panel abierto, o bien seleccione el icono Compartir situado junto al nombre del informe o panel en las listas Mi área de trabajo > Informes o Mi área de trabajo > Paneles.To share a report or dashboard, select Share at the top of the open report or dashboard page, or select the Share icon next to the report or dashboard name in the My workspace > Reports or My workspace > Dashboards lists.

Complete la pantalla Compartir informe o Compartir panel para enviar un correo electrónico u obtener un vínculo para compartir el informe o el panel con otros usuarios.Complete the Share report or Share dashboard screen to send an email or get a link to share your report or dashboard with others.

Compartir informe

Hay muchas mezclas y visualizaciones atractivas relacionadas con los datos que puede realizar con Power BI Desktop y el servicio Power BI.There are many compelling data-related mash-ups and visualizations you can do with Power BI Desktop and the Power BI service.

Pasos siguientesNext steps

Power BI Desktop admite la conexión a un puerto de diagnóstico.Power BI Desktop supports connecting to a diagnostics port. El puerto de diagnóstico permite que otras herramientas se conecten y realicen seguimientos con fines de diagnóstico.The diagnostics port allows other tools to connect to and perform traces for diagnostic purposes. Cuando se usa el puerto de diagnóstico, no se permite realizar ningún cambio en el modelo. Los cambios en el modelo pueden provocar daños y la pérdida de los datos.When using the diagnostics port, making any changes to the model is not supported. Changes to the model may lead to corruption and data loss.

Para más información sobre las numerosas funciones de Power BI Desktop, consulte los recursos siguientes:For more information on the many capabilities of Power BI Desktop, check out the following resources: