Información general sobre consultas en Power BI DesktopQuery overview in Power BI Desktop

Power BI Desktop le permite conectarse con el mundo de los datos, crear informes básicos y atractivos y compartir sus esfuerzos con otros usuarios, quienes a su vez pueden basarse en el trabajo que comparte con ellos y expandir sus propios esfuerzos de inteligencia empresarial.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

Power BI Desktop tiene tres vistas:Power BI Desktop has three views:

  • Vista de informes : donde usa las consultas que crea para generar visualizaciones atractivas, que se ordenan como quiere que aparezcan, y con varias páginas, que puede compartir con los demásReport view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Vista de datos : vea los datos en el informe en el formato de modelo de datos, donde puede agregar medidas, crear nuevas columnas y administrar relacionesData view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • Vista de relaciones : obtenga una representación gráfica de las relaciones que se han establecido en el modelo de datos y adminístrelas o modifíquelas según corresponda.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Se puede obtener acceso a estas vistas seleccionando uno de los tres iconos en el lado izquierdo de Power BI Desktop.These views are accessed by selecting one of the three icons along the left side of Power BI Desktop. En la siguiente imagen, la vista de informes está seleccionada y se indica mediante la banda de color amarillo situada junto al icono.In the following image, Report view is selected, indicated by the yellow band beside the icon.

Power BI Desktop también incorpora el Editor de consultas, donde puede conectarse a uno o varios orígenes de datos, dar forma y transformar los datos para satisfacer sus necesidades y, a continuación, cargar ese modelo en Power BI Desktop.Power BI Desktop also comes with Query Editor, where you can connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Este documento proporciona información general del funcionamiento de los datos en el Editor de consultas.This document provides an overview of the work with data in the Query Editor. Hay mucho más que aprender. Por lo tanto, al final de este documento encontrará vínculos que proporcionan información detallada acerca de los tipos de datos compatibles, la conexión a los datos, el modelado de los datos y la creación de relaciones, y sobre cómo comenzar.There's more to learn, of course, so at the end of this document you’ll find links to detailed guidance about supported data types, connecting to data, shaping data, creating relationships, and how to get started.

Pero primero, vamos a familiarizarnos con el Editor de consultas.But first, let’s see get acquainted with Query Editor.

Editor de consultasThe Query Editor

Para obtener el Editor de consultas, seleccione Editar consultas desde la pestaña Inicio de Power BI Desktop.To get to Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

Si no existe ninguna conexión de datos, el Editor de consultas aparece como un panel en blanco listo para mostrar datos.With no data connections, Query Editor appears as a blank pane, ready for data.

Una vez que se carga una consulta, el Editor de consultas resulta más interesante.Once a query is loaded, Query Editor view becomes more interesting. Si se conecta al siguiente origen de datos web, el Editor de consultas carga información acerca de los datos, a los que puede comenzar a dar forma enseguida.If we connect to the following Web data source, Query Editor loads information about the data, which you can then begin to shape.

http://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspxhttp://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

Aquí se muestra la apariencia del Editor de consultas una vez establecida la conexión de datos:Here’s how Query Editor appears once a data connection is established:

  1. En la cinta de opciones aparecen muchos botones activos que permiten interactuar con los datos de la consultaIn the ribbon, many buttons are now active to interact with the data in the query
  2. En el panel izquierdo se enumeran las consultas, disponibles para su selección, visualización y formaIn the left pane, queries are listed and available for selection, viewing, and shaping
  3. En el panel central se muestran los datos de la consulta seleccionada, disponibles para darles formaIn the center pane, data from the selected query is displayed and available for shaping
  4. Aparece la ventana Configuración de la consulta, con una lista de las propiedades de la consulta y de los pasos aplicadosThe Query Settings window appears, listing the query’s properties and applied steps

En las siguientes secciones analizaremos cada una de estas cuatro áreas: la cinta de opciones, el panel de consultas, la vista de datos y el panel de configuración de la consulta.We’ll look at each of these four areas – the ribbon, the queries pane, the data view, and the Query Settings pane – in the following sections.

La cinta de opciones de consultaThe query ribbon

La cinta de opciones del Editor de consultas consta de cuatro pestañas: Inicio, Transformar, Agregar columna y Vista.The ribbon in Query Editor consists of four tabs – Home, Transform, Add Column, and View.

La pestaña Inicio contiene las tareas de consulta más comunes, incluyendo el primer paso en cualquier consulta, que es Obtener datos.The Home tab contains the common query tasks, including the first step in any query, which is Get Data. La siguiente imagen muestra la cinta de opciones Inicio.The following image shows the Home ribbon.

Para conectarse a los datos y comenzar el proceso de creación de la consulta, seleccione el botón Obtener datos .To connect to data and begin the query building process, select the Get Data button. Aparece un menú que proporciona los orígenes de datos más comunes.A menu appears, providing the most common data sources.

Para obtener más información acerca de los orígenes de datos disponibles, consulte Orígenes de datos.For more information about available data sources, see Data Sources. Para obtener información sobre cómo conectarse a datos, con ejemplos y pasos a seguir, consulte Conectar a datos.For information about connecting to data, including examples and steps, see Connect to Data.

La pestaña Transformar proporciona acceso a tareas comunes de transformación de datos, como agregar o quitar columnas, cambiar tipos de datos, dividir columnas y otras tareas orientadas a datos.The Transform tab provides access to common data transformation tasks, such as adding or removing columns, changing data types, splitting columns, and other data-driven tasks. La siguiente imagen muestra la pestaña Transformar .The following image shows the Transform tab.

Para obtener más información acerca de la transformación de datos, incluidos ejemplos, vea Combinar y dar forma a datos.For more information about transforming data, including examples, see Combine and Shape Data.

La pestaña Agregar columna proporciona tareas adicionales relacionadas con agregar una columna, aplicar formato a los datos de una columna y agregar columnas personalizadas.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. La siguiente imagen muestra la pestaña Agregar columna .The following image shows the Add Column tab.

La pestaña Vista de la cinta de opciones se usa para alternar si se muestran determinados paneles o ventanas.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. También sirve para mostrar el Editor avanzado.It’s also used to display the Advanced Editor. La siguiente imagen muestra la pestaña Vista.The following image shows the View tab.

Resulta útil saber que muchas de las tareas disponibles en la cinta también están disponibles haciendo clic en una columna u otros datos, en el panel central.It’s useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

El panel izquierdoThe left pane

El panel izquierdo muestra el número de consultas activas, así como el nombre de cada consulta.The left pane displays the number of active queries, as well as the name of the query. Cuando selecciona una consulta en el panel izquierdo, los datos se muestran en el panel central, donde se les puede dar forma y transformar según sea necesario.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. La siguiente imagen muestra el panel izquierdo con varias consultas.The following image shows the left pane with multiple queries.

El panel central (panel de datos)The center (data) pane

En el panel central, o panel de datos, se muestran los datos de la consulta seleccionada.In the center pane, or Data pane, date from the selected query is displayed. Aquí es donde se realiza gran parte del trabajo de la vista de consultas.This is where much of the work of the Query view is accomplished.

En la siguiente imagen, se muestra la conexión de datos web establecida anteriormente, la columna Puntuación general está seleccionada y el encabezado muestra los elementos de menú disponibles al hacer doble clic en él.In the following image, the Web data connection established earlier is displayed, the Overall score column is selected, and its header is right-clicked to show the available menu items. Tenga en cuenta que muchos de estos elementos de menú contextual son los mismos que los botones que se encuentran en las fichas de la cinta.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Cuando se selecciona un elemento de menú contextual (o un botón de la cinta), en la vista de consultas se aplica el paso a los datos y se guarda como parte de la propia consulta.When you select a right-click menu item (or a ribbon button), Query applies the step to the data, and saves it as part of the query itself. Los pasos se registran en el panel Configuración de consulta en orden secuencial, como se describe en la sección siguiente.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

El panel Configuración de consultaThe query settings pane

El panel Configuración de consulta es donde se muestran todos los pasos asociados con una consulta.The Query Settings pane is where all steps associated with a query are displayed. Por ejemplo, en la imagen siguiente, la sección Pasos aplicados del panel Configuración de consulta refleja el hecho de que se acaba de cambiar el tipo de la columna Puntuación general .For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

A medida que se aplican más pasos de conformación a la consulta, estos se capturan en la sección Pasos aplicados .As additional shaping steps are applied to the query, they are captured in the Applied Steps section.

Es importante saber que los datos subyacentes no cambian; en su lugar, se ajusta y da forma a la vista de los datos y cualquier interacción con los datos subyacentes se basa en la vista formada y modificada de los datos de la consulta.It’s important to know that the underlying data is not changed; rather, Query Editor adjusts and shapes its view of the data, and any interaction with the underlying data occurs based on Query Editor’s shaped and modified view of that data.

En el panel Configuración de consulta , puede eliminar pasos y cambiar el nombre o el orden de estos como considere oportuno.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. Para ello, haga clic en el paso en la sección Pasos aplicados y, a continuación, elija la opción deseada del menú que aparece.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Todos los pasos de consulta se llevan a cabo en el orden en que aparecen en el panel Pasos aplicados.All query steps are carried out in the order they appear in the Applied Steps pane.

El Editor avanzadoThe Advanced Editor

Si desea ver el código que el Editor de consultas está creando con cada paso, o si desea crear su propio código de forma, puede usar el Editor avanzado.If you want to see the code that Query Editor is creating with each step, or want to create your own shaping code, you can use the Advanced Editor. Para iniciar el editor avanzado, seleccione Vista desde la cinta de opciones y después seleccione Editor avanzado.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Aparecerá una ventana que muestra el código de la consulta actual.A window appears, showing the existing query code.

Puede modificar directamente el código en la ventana Editor avanzado .You can directly edit the code in the Advanced Editor window. Para cerrar la ventana, seleccione el botón Listo o el botón Cancelar .To close the window, select the Done or Cancel button.

Guardar el trabajoSaving your work

Cuando la consulta se encuentre en el lugar deseado, puede hacer que el Editor de consultas aplique los cambios en el modelo de datos en Power BI Desktop y cerrar dicho editor.When your query is where you want it, you can have Query Editor apply the changes to the data model into Power BI Desktop, and close Query Editor. Para ello, seleccione Cerrar y aplicar en el menú Archivo del Editor de consultas.To do that, select Close & Apply from Query Editor's File menu.

Como la operación avanza, Power BI Desktop proporciona un cuadro de diálogo para mostrar su estado.As progress is made, Power BI Desktop provides a dialog to display its status.

Una vez que ha llegado al punto de consulta deseado, o si desea asegurarse de que el trabajo está guardado, Power BI Desktop puede guardar su trabajo en forma de un archivo .pbix.Once you have your query where you want it, or if you just want to make sure your work is saved, Power BI Desktop can save your work in the form of a .pbix file.

Para guardar el trabajo, seleccione Archivo > Guardar (o Archivo > Guardar como), como se muestra en la siguiente imagen.To save your work, select File > Save (or File > Save As), as shown in the following image.

Pasos siguientesNext steps

Se puede hacer todo tipo de cosas con Power BI Desktop.There are all sorts of things you can do with Power BI Desktop. Para obtener más información sobre sus capacidades, consulte los siguientes recursos:For more information on its capabilities, check out the following resources: