Herramienta de migración de Power BI EmbeddedPower BI Embedded migration tool

Esta herramienta de migración puede utilizarse para copiar los informes desde el servicio de Azure Power BI Embedded (PaaS) al servicio Power BI (SaaS).This migration tool can be used to copy your reports from the Power BI Embedded Azure service (PaaS) to the Power BI service (SaaS).

La migración del contenido de las colecciones de áreas de trabajo al servicio Power BI puede realizarse a la vez que usa su solución actual y no requiere ningún tiempo de inactividad.Migrating your content from your workspace collections to the Power BI service can be done in parallel to your current solution and doesn’t require any downtime.

LimitacionesLimitations

  • Los conjuntos de datos insertados no se pueden descargar y será necesario volver a crearlos con las API de REST de Power BI para el servicio Power BI.Pushed datasets cannot be downloaded and will need to be recreated using the Power BI REST APIs for the Power BI service.
  • Los archivos PBIX importados antes del 26 de noviembre de 2016 no podrán descargarse.PBIX files imported before November 26, 2016 will not be downloadable.

DescargarDownload

Puede descargar el ejemplo de herramienta de migración desde GitHub.You can download the migration tool sample from GitHub. Puede optar por descargar un archivo zip del repositorio o bien clonarlo localmente.You can either download a zip of the repository, or you can clone it locally. Una vez descargado, puede abrir powerbi-migration-sample.sln dentro de Visual Studio para compilar y ejecutar la herramienta de migración.Once downloaded, you can open powerbi-migration-sample.sln within Visual Studio to build and run the migration tool.

Planes de migraciónMigration Plans

El plan de migración es solo un conjunto de metadatos que cataloga el contenido de Power BI Embedded y cómo desea publicarlo en el servicio Power BI.Your migration plan is just metadata that catalogs the content within Power BI Embedded and how you want to publish them to the Power BI service.

Comience con un nuevo plan de migraciónStart with a new migration plan

Un plan de migración es un conjunto de metadatos de los elementos disponibles en Power BI Embedded que desea migrar al servicio Power BI.A migration plan is the metadata of the items available in Power BI Embedded that you then want to move over to the Power BI service. El plan de migración se almacena como un archivo XML.The migration plan is stored as an XML file.

Comenzará por crear un nuevo plan de migración.You will want to start by creating a new migration plan. Para crear un nuevo plan de migración, haga lo siguiente.To create a new migration plan, do the following.

  1. Seleccione File (Archivo) > New Migration Plan (Nuevo plan de migración).Select File > New Migration Plan.

  2. En el cuadro de diálogo Select Power BI Embedded Resource Group (Seleccionar grupo de recursos de Power BI Embedded), deberá seleccionar la lista desplegable Environment (Entorno) y seleccionar Prod. (Producción).In the Select Power BI Embedded Resource Group dialog, you will want to select the Environment dropdown and select prod.
  3. Se le pedirá que inicie sesión.You will be prompted to sign in. Usará las credenciales de inicio de sesión de la suscripción de Azure.You will use your Azure subscription login.

    Importante

    Esta no es su cuenta de organización de Office 365 con la que inició sesión en Power BI.This is not your Office 365 organization account that you sign into Power BI with.

  4. Seleccione la suscripción de Azure que almacena las colecciones de áreas de trabajo de Power BI Embedded.Select the Azure subscription which stores your Power BI Embedded workspace collections.

  5. En la lista de suscripciones, seleccione el Resource Group (Grupo de recursos) que contiene las colecciones de áreas de trabajo y elija Select (Seleccionar).Below the subscription list, select the Resource Group that contains your workspace collections and select Select.

  6. Seleccione Analizar.Select Analyze. Esto le proporcionará un inventario de los elementos de su suscripción de Azure para comenzar con el plan.This will get an inventory of the items within your Azure subscription for you to begin your plan.

    Nota

    El proceso de análisis podría tardar varios minutos, en función del número de colecciones de áreas de trabajo y cuánto contenido exista en la colección de áreas de trabajo.The analyze process could take several minutes depending on the number of Workspace collections and how much content exists in the workspace collection.

  7. Cuando Analizar finalice, le pedirá que guarde el plan de migración.When Analyze is complete, it will prompt you to save your migration plan.

En este punto, el plan de migración se ha conectado a su suscripción de Azure.At this point, you have connected your migration plan to your Azure subscription. A continuación se describe el flujo de trabajo con el plan de migración.Read below to understand the flow of how to work with your migration plan. Esto incluye analizar y planear la migración, la descarga, la creación de grupos y la carga.This includes Analyze & Plan Migration, Download, Create Groups and Upload.

Guardar el plan de migraciónSave your migration plan

Puede guardar el plan de migración para su uso posterior.You can save your migration plan for use later. Esto creará un archivo XML que contiene toda la información del plan de migración.This will create an XML file that contained all the information in your migration plan.

Para guardar el plan de migración, haga lo siguiente.To save your migration plan, do the following.

  1. Seleccione File (Archivo) > Save Migration Plan (Guardar plan de migración).Select File > Save Migration Plan.

  2. Asigne un nombre al archivo o use el nombre del archivo generado y seleccione Save (Guardar).Give your file a name or use the generated file name and select Save.

Abrir un plan de migración existenteOpen an existing migration plan

Puede abrir un plan de migración guardado para seguir trabajando en la migración.You can open a saved migration plan to continue working on your migration.

Para abrir el plan de migración existente, haga lo siguiente.To open your existing migration plan, do the following.

  1. Seleccione File (Archivo) > Open Existing Migration Plan (Abrir plan de migración existente).Select File > Open Existing Migration Plan.

  2. Seleccione el archivo de migración y seleccione Open (Abrir).Select your migration file and select Open.

Paso 1: Analizar y planear la migraciónStep 1: Analyze & Plan Migration

La pestaña Analyze & Plan Migration (Analizar y planear la migración) proporciona una visión de lo que hay actualmente en el grupo de recursos de la suscripción de Azure.The Analyze & Plan Migration tab gives you a view of what is currently in your Azure subscription’s resource group.

Pestaña Analizar y planear la migración

Examinaremos SampleResourceGroup como ejemplo.We will look at the SampleResourceGroup as an example.

Topología de PaaSPaaS Topology

Se trata de una lista de Grupo de recursos > Colecciones de áreas de trabajo > Áreas de trabajo.This is a listing of your Resource Group > Workspace collections > Workspaces. Las colecciones de áreas de trabajo y el grupo de recursos mostrarán un nombre descriptivo.The resource group and workspace collections will show a friendly name. Las áreas de trabajo mostrarán un GUID.The workspaces will show a GUID.

Los elementos de la lista también mostrarán un color y un número con el formato (n.º/nº).The items in the list will also display a color and a number in the format of (#/#). Indica el número de informes que se pueden descargar.This indicates the number of reports that can be downloaded. El color negro significa que se pueden descargar todos los informes.A black color means that all reports can be downloaded.

El color rojo significa que algunos informes no se pueden descargar.A red color means that some reports cannot be downloaded. El número de la izquierda indicará el número total de informes que se pueden descargar.The left number will indicate the total number of reports that can be downloaded. El número de la derecha indica el número total de informes dentro de la agrupación.The number on the right indicates the total number of reports within the grouping.

Puede seleccionar un elemento dentro de la topología de PaaS para mostrar los informes en la sección informes.You can select an item within the PaaS topology to display the reports in the reports section.

InformesReports

La sección de informes mostrará una lista de los informes disponibles y se indica si se pueden descargar o no.The reports section will list out the reports available and indicates whether it can be downloaded or not.

Estructura de destinoTarget structure

En la sección Estructura de destino se indica a la herramienta dónde se descargarán los elementos y cómo cargarlos.The Target structure is where you tell the tool where things will be downloaded to and how to upload them.

Plan de descargaDownload Plan

Se creará automáticamente una ruta de acceso.A path will automatically be created for you. Puede cambiar esta ruta de acceso si lo desea.You can change this path if you wish. Si cambia la ruta de acceso, deberá seleccionar Update paths (Actualizar rutas de acceso).If you do change the path, you will need to select Update paths.

Nota

Esto no realiza realmente la descarga.This does not actually perform the download. Únicamente especifica la estructura de dónde se van a descargar los informes.This is only specifying the structure of where the reports will be downloaded to.

Plan de cargaUpload Plan

Aquí puede especificar un prefijo que se utilizará para las áreas de trabajo de la aplicación que se creará en el servicio Power BI.Here you can specify a prefix to be used for the App Workspaces that will be created within the Power BI service. Después de el prefijo irá el GUID para el área de trabajo que existía en Azure.After the prefix will be the GUID for the workspace that existed in Azure.

Nota

No se crean realmente los grupos en el servicio Power BI.This does not actually create the groups within the Power BI service. Únicamente se define la estructura de nomenclatura para los grupos.This only defines the naming structure for the groups.

Si cambia el prefijo, deberá seleccionar Generate Upload Plan (Generar plan de carga).If you change the prefix, you will need to select Generate Upload Plan.

Puede hacer clic con el botón derecho en un grupo y elegir cambiar el nombre del grupo dentro del plan de carga directamente, si lo desea.You can right click on a group and choose to rename the group within the Upload plan directly, if desired.

Nota

El nombre del grupo no debe contener espacios ni caracteres no válidos.The name of the group must not contain spaces or invalid characters.

Paso 2: DescargarStep 2: Download

En la pestaña Download (Descargar), verá la lista de informes y los metadatos asociados.On the Download tab, you will see the list of reports and associated metadata. Puede ver el estado de la exportación junto con el estado de la exportación anterior.You can see what the export status is along with the previous export status.

Tiene dos opciones.You have two options.

  • Seleccione algunos informes específicos y seleccione Download Selected (Descargar selección).Select specific reports and select Download Selected
  • Seleccione Download All (Descargar todo).Select Download All.

En una descarga correcta, verá el estado Done (Listo) e indicará que existe el archivo PBIX.For a successful download, you will see a status of Done and it will reflect that the PBIX file exists.

Una vez completada la descarga, seleccione la pestaña Create Groups (Crear grupos).After the download is completed, select the Create Groups tab.

Paso 3: Crear gruposStep 3: Create Groups

Después de haber descargado los informes que están disponibles, puede ir a la pestaña Create Groups (Crear grupos). Esta pestaña creará las áreas de trabajo de la aplicación dentro del servicio Power BI según el plan de migración que ha creado.After you have downloaded the reports that are available, you can go to the Create Groups tab. This tab will create the app workspaces within the Power BI service based on the migration plan that you created. Se creará el área de trabajo de la aplicación con el nombre proporcionado en la pestaña Upload (Cargar) en Analyze & Plan Migration (Analizar y planear la migración).It will create the app workspace with the name you provided on the Upload tab within Analyze & Plan Migration.

Para crear las áreas de trabajo de la aplicación, puede seleccionar Create Selected Groups (Crear los grupos seleccionados) o Create All Missing Groups (Crear todos los grupos que faltan).To create the app workspaces, you can select either Create Selected Groups or Create All Missing Groups.

Cuando seleccione cualquiera de estas opciones, se le solicitará iniciar sesión.When you select either of these options, you will be prompted to sign in. Utilice las credenciales para el servicio Power BI en el que desea crear las áreas de trabajo de la aplicación.You will want to use your credentials for the Power BI service that you want to create the app workspaces on.

Esto creará el área de trabajo de la aplicación en el servicio Power BI.This will create the app workspace within the Power BI service. No se cargan los informes en el área de trabajo de la aplicación.This does not upload the reports to the app workspace.

Puede comprobar que se creó el área de trabajo de la aplicación iniciando sesión en Power BI y validando que el área de trabajo existe.You can verify that the app workspace was created by signing into Power BI and validating that the workspace exists. Observará que no hay nada en el área de trabajo.You will notice that nothing is in the workspace.

Después de crear el área de trabajo, puede continuar en la pestaña Upload (Cargar).After the workspace is created, you can move onto the Upload tab.

Paso 4: CargarStep 4: Upload

En la pestaña Upload (Cargar), esto permite cargar los informes en el servicio Power BI.On the Upload tab, this will upload the reports to the Power BI service. Verá una lista de los informes que se descargaron en la pestaña Descargar junto con el nombre del grupo de destino en función del plan de migración.You will see a list of the reports that we downloaded on the Download tab along with the target group name based on your migration plan.

Puede cargar los informes seleccionados o puede cargar todos los informes.You can upload selected reports, or you could upload all the reports. También puede restablecer el estado de la carga en volver a cargar los elementos.You can also reset the upload status to re-upload items.

También tiene la opción de seleccionar qué hacer si existe un informe con el mismo nombre.You also have the option of selecting what to do if a report with the same name exists. Puede elegir entre Abort (Anular), Ignore (Omitir) y Overwrite (Sobrescribir).You can choose between Abort, Ignore and Overwrite.

Nombres de informe duplicadosDuplicate report names

Si tiene un informe que tiene el mismo nombre, pero sabe que es un informe diferente, debe cambiar el valor de TargetName del informe.If you have a report that has the same name, but you know it is a different report, you will need to change the TargetName of the report. Puede cambiar el nombre editando manualmente el código XML del plan de migración.You can change the name by manually editing the migration plan XML.

Debe cerrar la herramienta de migración para realizar el cambio y, a continuación, volver a abrir la herramienta y el plan de migración.You will need to close the migration tool to make the change and then re-open the tool and the migration plan.

En el ejemplo anterior, uno de los informes clonados genera un error que indica que ya existe un informe con el mismo nombre.In the above example, one of the cloned reports failed indicating a report with the same name existed. Si decidimos mirar el código XML del plan de migración, se verá lo siguiente.If we go look at the migration plan XML, we will see the following.

<ReportMigrationData>
    <PaaSWorkspaceCollectionName>SampleWorkspaceCollection</PaaSWorkspaceCollectionName>
    <PaaSWorkspaceId>4c04147b-d8fc-478b-8dcb-bcf687149823</PaaSWorkspaceId>
    <PaaSReportId>525a8328-b8cc-4f0d-b2cb-c3a9b4ba2efe</PaaSReportId>
    <PaaSReportLastImportTime>1/3/2017 2:10:19 PM</PaaSReportLastImportTime>
    <PaaSReportName>cloned</PaaSReportName>
    <IsPushDataset>false</IsPushDataset>
    <IsBoundToOldDataset>false</IsBoundToOldDataset>
    <PbixPath>C:\MigrationData\SampleResourceGroup\SampleWorkspaceCollection\4c04147b-d8fc-478b-8dcb-bcf687149823\cloned-525a8328-b8cc-4f0d-b2cb-c3a9b4ba2efe.pbix</PbixPath>
    <ExportState>Done</ExportState>
    <LastExportStatus>OK</LastExportStatus>
    <SaaSTargetGroupName>SampleMigrate</SaaSTargetGroupName>
    <SaaSTargetGroupId>6da6f072-0135-4e6c-bc92-0886d8aeb79d</SaaSTargetGroupId>
    <SaaSTargetReportName>cloned</SaaSTargetReportName>
    <SaaSImportState>Failed</SaaSImportState>
    <SaaSImportError>Report with the same name already exists</SaaSImportError>
</ReportMigrationData>

Para el elemento con error, podemos cambiar el nombre de SaaSTargetReportName.For the failed item, we can change the name of the SaaSTargetReportName.

<SaaSTargetReportName>cloned2</SaaSTargetReportName>

A continuación, podemos volver a abrir el plan en la herramienta de migración y cargar el informe con error.We can then re-open the plan, in the migration tool, and upload the failed report.

Volviendo a Power BI, podemos ver que los informes y conjuntos de datos se han cargado en el área de trabajo de la aplicación.Going back to Power BI, we can see that the reports and datasets have been uploaded in the app workspace.

Cargar un archivo PBIX localUpload a local PBIX file

Puede cargar una versión local de un archivo de Power BI Desktop.You can upload a local version of a Power BI Desktop file. Tendrá que cerrar la herramienta, editar el archivo XML y colocar la ruta de acceso completa a su archivo PBIX local en la propiedad PbixPath.You will have to close the tool, edit the XML and put the full path to your local PBIX in the PbixPath property.

<PbixPath>[Full Path to PBIX file]</PbixPath>

Después de editar el archivo XML, vuelva a abrir el plan en la herramienta de migración y cargue el informe.After you have edited the xml, re-open the plan within the migration tool and upload the report.

Informes de DirectQueryDirectQuery reports

Debe actualizar la cadena de conexión para los informes de DirectQuery.You will need to update to update the connection string for DirectQuery reports. Esto puede realizarse en powerbi.com o bien puede consultar mediante programación la cadena de conexión desde Power BI Embedded (Paas).This can be done within powerbi.com, or you can programmatically query the connection string from Power BI Embedded (Paas). Para obtener un ejemplo, consulte Extract DirectQuery connection string from PaaS report (Extraer cadena de conexión de DirectQuery desde un informe de PaaS).For an example, see Extract DirectQuery connection string from PaaS report.

A continuación, puede actualizar la cadena de conexión para el conjunto de datos en el servicio Power BI (Saas) y establecer las credenciales para el origen de datos.You can then update the connection string for the dataset within the Power BI service (Saas) and set the credentials for the data source. También puede buscar en los ejemplos siguientes para ver cómo hacerlo.You can look at the following examples to see how to do this.

InserciónEmbedding

Ahora que los informes se han migrado desde el servicio Power BI Embedded de Azure al servicio Power BI, puede actualizar la aplicación y comenzar la inserción de los informes en el área de trabajo de la aplicación.Now that your reports have been migrated from the Power BI Embedded Azure service to the Power BI service, you can now update your application and begin embedding the reports in this app workspace.

Para más información, consulte Migración de contenido de la colección de áreas de trabajo de Power BI Embedded a Power BI.For more information, see How to migrate Power BI Embedded workspace collection content to Power BI.

Pasos siguientesNext steps

Inserción con Power BIEmbedding with Power BI
Migración de contenido de la colección de áreas de trabajo de Power BI Embedded a Power BIHow to migrate Power BI Embedded workspace collection content to Power BI
¿Qué es Power BI Premium?Power BI Premium - what is it?
Repositorio Git de la API de JavaScriptJavaScript API Git repo
Repositorio Git de C# de Power BIPower BI C# Git repo
Ejemplo de inserción de JavaScriptJavaScript embed sample
Notas del producto de Power BI PremiumPower BI Premium whitepaper

¿Tiene más preguntas?More questions? Pruebe a preguntar a la comunidad de Power BITry asking the Power BI Community