Requisitos del sistema de Windows PowerShellWindows PowerShell System Requirements

En este artículo se enumeran los requisitos del sistema para Windows PowerShell 3.0, Windows PowerShell 4.0, Windows PowerShell 5.0 y Windows PowerShell 5.1.This article lists the system requirements for Windows PowerShell 3.0, Windows PowerShell 4.0, Windows PowerShell 5.0, and Windows PowerShell 5.1. Y, características especiales, como el entorno de scripting integrado (ISE) de Windows PowerShell, los comandos del Modelo de información común (CIM) y los flujos de trabajo.And, special features, such as Windows PowerShell Integrated Scripting Environment (ISE), Common Information Model (CIM) commands, and workflows.

Windows® 8.1 y Windows Server® 2012 R2 incluyen todos los programas necesarios.Windows® 8.1 and Windows Server® 2012 R2 include all required programs. Este artículo está diseñado para usuarios de versiones anteriores de Windows.This article is designed for users of earlier releases of Windows.

Requisitos de sistema operativoOperating system requirements

Windows PowerShell 5.1Windows PowerShell 5.1

Windows PowerShell 5.1 se ejecuta en las siguientes versiones de Windows.Windows PowerShell 5.1 runs on the following versions of Windows. Para ejecutar Windows PowerShell 5.1, instale Windows Management Framework 5.1.To run Windows PowerShell 5.1, install Windows Management Framework 5.1. Para más información, consulte Instalación y configuración de WMF 5.1.For more information, see Install and Configure WMF 5.1.

Versión de WindowsWindows version Requisito del sistemaSystem requirement
Windows Server 2019Windows Server 2019 Instalado de forma predeterminadaInstalled by default
Windows Server 2016Windows Server 2016 Instalado de forma predeterminadaInstalled by default
Windows Server 2012 R2Windows Server 2012 R2 Instalar Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows Server 2012Windows Server 2012 Instalar Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows Server 2008 R2 con Service Pack 1Windows Server 2008 R2 with Service Pack 1 Instalar Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows 10 versión 1607 y posterioresWindows 10 version 1607 and up Instalado de forma predeterminadaInstalled by default
Windows 10 versión 1507, 1511Windows 10 version 1507, 1511 Instalar Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows 8.1Windows 8.1 Instalar Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows 7 con Service Pack 1Windows 7 with Service Pack 1 Instalar Windows Management Framework 5.1Install Windows Management Framework 5.1

Windows PowerShell 5.0Windows PowerShell 5.0

Windows PowerShell 5.0 se ejecuta en las siguientes versiones de Windows.Windows PowerShell 5.0 runs on the following versions of Windows. Para ejecutar Windows PowerShell 5.0, instale Windows Management Framework 5.1.To run Windows PowerShell 5.0, install Windows Management Framework 5.1. Para más información, consulte Instalación y configuración de WMF 5.1.For more information, see Install and Configure WMF 5.1. Windows Management Framework 5.1 sustituye a Windows Management Framework 5.0.Windows Management Framework 5.1 supersedes Windows Management Framework 5.0.

Versión de WindowsWindows version Requisito del sistemaSystem requirement
Windows Server 2019Windows Server 2019 Versión posterior instalada de forma predeterminadaHigher version installed by default
Windows Server 2016Windows Server 2016 Versión posterior instalada de forma predeterminadaHigher version installed by default
Windows Server 2012 R2Windows Server 2012 R2 Instalar Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows Server 2012Windows Server 2012 Instalar Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows Server 2008 R2 con Service Pack 1Windows Server 2008 R2 with Service Pack 1 Instalar Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows 10 versión 1607 y posterioresWindows 10 version 1607 and up Versión posterior instalada de forma predeterminadaHigher version installed by default
Windows 10 versión 1507, 1511Windows 10 version 1507, 1511 Instalado de forma predeterminadaInstalled by default
Windows 8.1Windows 8.1 Instalar Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows 7 con Service Pack 1Windows 7 with Service Pack 1 Instalar Windows Management Framework 5.1Install Windows Management Framework 5.1

Windows PowerShell 4.0Windows PowerShell 4.0

Windows PowerShell 4.0 se ejecuta en las siguientes versiones de Windows.Windows PowerShell 4.0 runs on the following versions of Windows. Para ejecutar Windows PowerShell 4.0, instale la versión especificada de Windows Management Framework para el sistema operativo.To run Windows PowerShell 4.0, install the specified version of the Windows Management Framework for your operating system.

Versión de WindowsWindows version Requisito del sistemaSystem requirement
Windows 8.1Windows 8.1 Instalado de forma predeterminadaInstalled by default
Windows Server 2012 R2Windows Server 2012 R2 Instalado de forma predeterminadaInstalled by default
Windows® 7 con Service Pack 1Windows® 7 with Service Pack 1 Instalar Windows Management Framework 4.0Install Windows Management Framework 4.0
Windows Server® 2008 R2 con Service Pack 1Windows Server® 2008 R2 with Service Pack 1 Instalar Windows Management Framework 4.0Install Windows Management Framework 4.0

Windows PowerShell 3.0Windows PowerShell 3.0

Windows PowerShell 3.0 se ejecuta en las siguientes versiones de Windows.Windows PowerShell 3.0 runs on the following versions of Windows. Para ejecutar Windows PowerShell 3.0, instale la versión especificada de Windows Management Framework para su sistema operativo.To run Windows PowerShell 3.0, install the specified version of the Windows Management Framework for your operating system.

Versión de WindowsWindows version Requisito del sistemaSystem requirement
Windows 8Windows 8 Instalado de forma predeterminadaInstalled by default
Windows Server 2012Windows Server 2012 Instalado de forma predeterminadaInstalled by default
Windows® 7 con Service Pack 1Windows® 7 with Service Pack 1 Instalar Windows Management Framework 3.0Install Windows Management Framework 3.0
Windows Server® 2008 R2 con Service Pack 1Windows Server® 2008 R2 with Service Pack 1 Instalar Windows Management Framework 3.0Install Windows Management Framework 3.0
Windows Server 2008 con Service Pack 2Windows Server 2008 with Service Pack 2 Instalar Windows Management Framework 3.0Install Windows Management Framework 3.0

Requisitos de Microsoft .NET FrameworkMicrosoft .NET Framework requirements

En la tabla siguiente se muestran los requisitos de .NET Framework para Windows PowerShell.The following table shows the .NET Framework requirements for Windows PowerShell.

VersiónVersion Requisito de .NET.NET requirement
Windows PowerShell 5.1Windows PowerShell 5.1 Requiere la instalación completa de Microsoft .NET Framework 4.5.Requires the full installation of Microsoft .NET Framework 4.5. Windows 8.1 y Windows Server 2012 R2 incluyen Microsoft .NET Framework 4.5 de manera predeterminada.Windows 8.1 and Windows Server 2012 R2 include Microsoft .NET Framework 4.5 by default.
Windows PowerShell 5.0Windows PowerShell 5.0 Requiere la instalación completa de Microsoft .NET Framework 4.5.Requires the full installation of Microsoft .NET Framework 4.5. Windows 8.1 y Windows Server 2012 R2 incluyen Microsoft .NET Framework 4.5 de manera predeterminada.Windows 8.1 and Windows Server 2012 R2 include Microsoft .NET Framework 4.5 by default.
Windows PowerShell 4.0Windows PowerShell 4.0 Requiere la instalación completa de Microsoft .NET Framework 4.5.Requires the full installation of Microsoft .NET Framework 4.5. Windows 8.1 y Windows Server 2012 R2 incluyen Microsoft .NET Framework 4.5 de manera predeterminada.Windows 8.1 and Windows Server 2012 R2 include Microsoft .NET Framework 4.5 by default.
Windows PowerShell 3.0Windows PowerShell 3.0 Requiere la instalación completa de Microsoft .NET Framework 4.Requires the full installation of Microsoft .NET Framework 4. Windows 8 y Windows Server 2012 incluyen Microsoft .NET Framework 4.5 de manera predeterminada, con lo que se cumple este requisito.Windows 8 and Windows Server 2012 include Microsoft .NET Framework 4.5 by default, which fulfills this requirement.

Use los vínculos siguientes para descargar Microsoft .NET Framework desde el Centro de descarga de Microsoft.Use the following links to download Microsoft .NET Framework from the Microsoft Download Center.

VersiónVersion VínculoLink
.NET Framework 4.5 (dotNetFx45_Full_setup.exe).NET Framework 4.5 (dotNetFx45_Full_setup.exe) Microsoft .NET Framework 4.5Microsoft .NET Framework 4.5
.NET Framework 4 (dotNetFx40_Full_setup.exe).NET Framework 4 (dotNetFx40_Full_setup.exe) Microsoft .NET Framework 4 (instalador web)Microsoft .NET Framework 4 (Web Installer)

Windows Management Framework 4.0Windows Management Framework 4.0

Windows PowerShell 5.0 requiere que Windows Management Framework 4.0 esté preinstalado en Windows Server 2008 R2 SP1 y Windows 7 SP1.Windows PowerShell 5.0 requires Windows Management Framework 4.0 to be preinstalled on Windows Server 2008 R2 SP1 and Windows 7 SP1.

WS-Management 3.0WS-Management 3.0

Windows PowerShell 3.0 y Windows PowerShell 4.0 requieren WS-Management 3.0, que admite el servicio WinRM y el protocolo WSMan.Windows PowerShell 3.0 and Windows PowerShell 4.0 require WS-Management 3.0, which supports the WinRM service and WSMan protocol. Este programa está incluido en Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows Management Framework 4.0 y Windows Management Framework 3.0.This program is included in Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows Management Framework 4.0, and Windows Management Framework 3.0.

Instrumental de administración de Windows 3.0Windows Management Instrumentation 3.0

Windows PowerShell 3.0 y Windows PowerShell 4.0 requiere Instrumental de administración de Windows 3.0 (WMI).Windows PowerShell 3.0 and Windows PowerShell 4.0 require Windows Management Instrumentation 3.0 (WMI). Este programa está incluido en Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows Management Framework 4.0 y Windows Management Framework 3.0.This program is included in Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows Management Framework 4.0, and Windows Management Framework 3.0. Si este programa no está instalado en el equipo, las características que requieren WMI, como los comandos CIM, no se ejecutan.If this program isn't installed on the computer, features that require WMI, such as CIM commands, don't run.

Common Language Runtime 4.0Common Language Runtime 4.0

Windows PowerShell 3.0, Windows PowerShell 4.0 y Windows PowerShell 5.0 se compilan en Common Language Runtime (CLR) 4.0.Windows PowerShell 3.0, Windows PowerShell 4.0, and Windows PowerShell 5.0 are compiled against Common Language Runtime (CLR) 4.0.

Requisitos de la interfaz gráfica de usuarioGraphical user interface requirements

Windows PowerShell es una aplicación basada en consola que no requiere una interfaz gráfica de usuario.Windows PowerShell is a console-based application that doesn't require a graphical user interface. Es idónea para equipos que no tienen pantallas, monitores ni interfaz de usuario, como las opciones de instalación de Server Core de Windows Server 2012 R2 o Windows Server 2012.It's well suited to computers that don't have screens or monitors, or a user interface, such as the Server Core installation options of Windows Server 2012 R2 or Windows Server 2012.

Algunos elementos requieren una interfaz gráfica de usuario.Some items require a graphical user interface. Para obtener más información, vea el artículo de ayuda de cada elemento.For details, see the help article for each item.

Requisitos del motor de Windows PowerShellWindows PowerShell engine requirements

Windows PowerShell 4.0 está diseñado para ser compatible con versiones anteriores de Windows PowerShell 3.0 y Windows PowerShell 2.0.Windows PowerShell 4.0 is designed to be backwards compatible with Windows PowerShell 3.0 and Windows PowerShell 2.0. Los cmdlets, proveedores, complementos, módulos y scripts escritos para Windows PowerShell 2.0 y Windows PowerShell 3.0 se ejecutan sin cambios en Windows PowerShell 4.0.Cmdlets, providers, snap-ins, modules, and scripts written for Windows PowerShell 2.0 and Windows PowerShell 3.0 run unchanged in Windows PowerShell 4.0.

Pero debido a un cambio en la directiva de activación de tiempo de ejecución en Microsoft .NET Framework 4, los programas de host de Windows PowerShell escritos para Windows PowerShell 2.0 y compilados con Common Language Runtime (CLR) 2.0 no se pueden ejecutar sin modificaciones en Windows PowerShell 3.0, que está compilado con CLR 4.0.However, due to a change in the runtime activation policy in Microsoft .NET Framework 4, Windows PowerShell host programs that were written for Windows PowerShell 2.0 and compiled with Common Language Runtime (CLR) 2.0 can't run without modification in Windows PowerShell 3.0, which is compiled with CLR 4.0.

El requisito mínimo del motor de Windows PowerShell 2.0 es Microsoft .NET Framework 2.0.50727.The Windows PowerShell 2.0 engine's minimum requirement is Microsoft .NET Framework 2.0.50727. Este requisito se cumple mediante Microsoft .NET Framework 3.5 Service Pack 1.This requirement is fulfilled by Microsoft .NET Framework 3.5 Service Pack 1. Este requisito no se cumple con Microsoft .NET Framework 4 y versiones posteriores de Microsoft .NET Framework.This requirement isn't fulfilled by Microsoft .NET Framework 4 and later releases of Microsoft .NET Framework.

Para información sobre cómo agregar o instalar el motor de Windows PowerShell 2.0 y agregar o instalar las versiones necesarias de Microsoft .NET Framework, consulte Instalación del motor de Windows PowerShell 2.0.For information about adding or installing the Windows PowerShell 2.0 engine, and adding or installing the required versions of the Microsoft .NET Framework, see Installing the Windows PowerShell 2.0 Engine. Para obtener información sobre cómo iniciar el motor de Windows PowerShell 2.0, consulte Iniciar el motor de Windows PowerShell 2.0.For information about starting the Windows PowerShell 2.0 engine, see Starting the Windows PowerShell 2.0 Engine.

Entorno de preinstalación de WindowsWindows Preinstallation Environment

Windows PowerShell 2.0, Windows PowerShell 3.0 y Windows PowerShell 4.0 se ejecutan en el Entorno de preinstalación de Windows (Windows PE).Windows PowerShell 2.0, Windows PowerShell 3.0, and Windows PowerShell 4.0 run in the Windows Preinstallation Environment (Windows PE). Pero no se admiten los cmdlets siguientes.However, the following cmdlets aren't supported.

El servicio WinRM no está presente en Windows PE.The WinRM service isn't present on Windows PE.

Consulte tambiénSee also

Instalación de Windows PowerShellInstalling Windows PowerShell

Inicio de Windows PowerShellStarting Windows PowerShell

Windows Management FrameworkWindows Management Framework