No se sincronizan los roles SAP y del almacén de perfiles de usuario - Evento 5008 (Duet Enterprise)

 

Se aplica a: Duet Enterprise for Microsoft SharePoint and SAP

Última modificación del tema: 2011-08-05

Nombre de alerta: no se sincronizan los roles de SAP y del almacén de perfiles de usuario

Identificador de evento:   5008

Resumen

Los usuarios de Duet Enterprise y sus roles se sincronizan con el sistema SAP y se almacenan en el almacén de perfiles del servicio de perfiles de usuario. Una función del proceso de sincronización consiste en recuperar la lista de roles SAP eliminados del sistema SAP y actualizar el almacén de perfiles de usuario mediante la eliminación de la propiedad de roles SAP de los usuarios de SAP eliminados. El trabajo del temporizador de sincronización de perfiles de Duet Enterprise inicia la sincronización de los usuarios del almacén de perfiles de usuario de SharePoint con los roles asignados en el sistema SAP. La cuenta de servicio del servicio de temporizador que ejecuta la sincronización de perfiles de Duet Enterprise debe tener permisos de control total en la aplicación de servicio de perfiles de usuario.

Síntomas

Este evento aparece en el registro de eventos:

Identificador de evento: 5008 Descripción: no se pudieron actualizar los roles SAP de los usuarios eliminados del back-end.

Causa

El problema se puede deber a una o varias de las causas siguientes:

  • Se produjeron errores transitorios en el back-end de SAP o un problema de conectividad de red.

  • La aplicación de servicio de perfiles de usuario no se está ejecutando.

  • La cuenta de trabajo del temporizador no tiene permisos de control total en la aplicación de servicio de perfiles de usuario.

    Para obtener más información acerca de cómo proporcionar permisos de cuentas administradas a un administrador de la aplicación de servicio para una aplicación de servicio de perfiles de usuario específica, vea Asignación de la administración de una aplicación de servicio de perfiles de usuario (SharePoint Server 2010) (https://go.microsoft.com/fwlink/?linkid=204625&clcid=0xC0A).

  • Se produjo un error en el método DeletedIDEnumerator del modelo BDC asociado a la sincronización de roles que recupera los usuarios eliminados del back-end. Es posible que el administrador de SharePoint no tenga permisos suficientes en el modelo BDC para ejecutar este método.

Resolución

Comprobación de la conectividad de red y del back-end de SAP

  • Haga ping a los servidores de la granja de servidores remota para asegurarse de que están disponibles. Pida al administrador de la granja de servidores remota que haga ping a los servidores de la granja.

    Nota

    Póngase en contacto con el administrador de SAP y compruebe que no haya problemas de conectividad en el sistema SAP.

Iniciar el servicio de perfiles de usuario

  1. Confirme que la cuenta de usuario que está realizando este procedimiento pertenece al grupo de administradores de la granja de servidores de SharePoint.

  2. En el sitio web de Administración central de SharePoint, haga clic en Configuración del sistema.

  3. En la página Configuración del sistema, en la sección Servidores, haga clic en Administrar servicios en el servidor.

  4. Haga clic en Inicio en la columna Acción del servicio de perfiles de usuario.

  5. Haga clic en Aceptar para iniciar el servicio.

Comprobar la cuenta de servicio

  1. Compruebe que la cuenta de usuario que realiza este procedimiento pertenece al grupo Administradores del equipo local.

  2. Haga clic en Inicio, elija Herramientas administrativas y, a continuación, haga clic en Servicios.

  3. En el complemento Servicios, haga clic con el botón secundario en el servicio de temporizador V4 de Windows SharePoint Services y, a continuación, haga clic en Propiedades.

  4. En el cuadro de diálogo Propiedades del servicio, en la ficha Iniciar sesión, escriba la contraseña de la cuenta, confirme la contraseña y, a continuación, haga clic en Aceptar.

  5. Haga clic con el botón secundario en el servicio y, a continuación, haga clic en Iniciar.

Comprobar el acceso a la aplicación de servicio de perfiles de usuario

  1. En la página principal de Administración central, en la sección Administración de aplicaciones, haga clic en Administrar aplicaciones de servicio.

  2. En la página Administrar aplicaciones de servicio, haga clic en la fila que contiene la aplicación de servicio de perfiles de usuario que se implementó para Duet Enterprise.

    La aplicación de servicio de perfiles de usuario de la instalación de Duet Enterprise se especifica en el archivo Duet EnterpriseDuetConfig.config.

  3. En el grupo Uso compartido de la cinta de opciones, haga clic en Permisos.

  4. En el cuadro de diálogo Permisos de conexión, realice uno de los siguientes procedimientos:

    • Si la cuenta del trabajo del temporizador aparece en el panel central, haga clic en la cuenta de usuario.

    • Si la cuenta del trabajo del temporizador no aparece en el panel central, escriba la cuenta de usuario en el panel superior y, a continuación, haga clic en Agregar.

  5. En el panel inferior, compruebe que la casilla de verificación Control total esté activada.

  6. Haga clic en Aceptar.

    Para obtener más información, vea Restringir o permitir el acceso a una aplicación de servicio (SharePoint Server 2010) (https://go.microsoft.com/fwlink/?linkid=202009&clcid=0xC0A).